The Corsair User Forums  

Go Back   The Corsair User Forums > Search Forums

Showing results 1 to 8 of 8
Search took 0.02 seconds.
Search: Posts Made By: AndreiD
Forum: Cooling 01-09-2018, 01:48 PM
Replies: 34
Views: 67,633
Posted By AndreiD
I remember it depends on the motherboard since...

I remember it depends on the motherboard since the PCB thickness can vary between them? Mine wasn't exactly snug after the install so that was the issue back then for me. Ymmv temp wise.
Forum: Cooling 01-09-2018, 01:39 PM
Replies: 34
Views: 67,633
Posted By AndreiD
Found this old thread again, but I think you need...

Found this old thread again, but I think you need rubber ones since I recall metal ones didn't fit quite snug behind the socket. Give it a try and see if it works, be sure not to over-tighten the...
Forum: Cooling 09-26-2014, 01:51 AM
Replies: 34
Views: 67,633
Posted By AndreiD
Glad the tip helped people out, would also like...

Glad the tip helped people out, would also like to provide an additional tip I learned after a few installations, be careful with the radiator screw slots, because they strip easily if you tighten...
Forum: Keyboards and Mice 09-26-2014, 01:40 AM
Replies: 227
Views: 157,965
Posted By AndreiD
Came across this thread randomly, just wanted to...

Came across this thread randomly, just wanted to chime in, I actually ended up avoiding Corsair products because of the new gaming line logo. Was looking for a gaming mouse and mechanical keyboard...
Forum: Cooling 12-05-2012, 04:13 PM
Replies: 34
Views: 67,633
Posted By AndreiD
The issue seems to happen with some Gigabyte...

The issue seems to happen with some Gigabyte boards too from what I've found on other forums. But anyway, there's an easy workaround so not a big deal.
Forum: Cooling 12-05-2012, 04:52 AM
Replies: 8
Views: 3,077
Posted By AndreiD
Happened to my H80i, the pump seems to be...

Happened to my H80i, the pump seems to be alright, but I think the electronic part handling the LED and Corsair Link died on mine (the LED doesn't light up anymore, tried connecting to different USB...
Forum: Cooling 12-05-2012, 04:43 AM
Replies: 34
Views: 67,633
Posted By AndreiD
Corsair H80i needs backplate washers

Hi! About a week ago I got myself the new Corsair H80i closed loop water cooling system, and after I first installed it, I have to say I wasn't really that much impressed with it. I was upgrading...
Forum: Cooling 11-30-2012, 01:37 AM
Replies: 24
Views: 13,130
Posted By AndreiD
I have the exact same issue. Just got my H80i...

I have the exact same issue.
Just got my H80i today, and when I first started it the noise was unbearable. Installed Corsair Link then updated my firmware to 1.0.4 and the noise is now gone, but...
Showing results 1 to 8 of 8

 
Forum Jump

All times are GMT -4. The time now is 12:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.