The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   iCUE Software (https://forum.corsair.com/forums/forumdisplay.php?f=280)
-   -   [BUG] Unhandled exception - ICUE crashes on load (https://forum.corsair.com/forums/showthread.php?t=176396)

almostcraig 04-01-2018 06:28 PM

[BUG] Unhandled exception - ICUE crashes on load
 
I woke my computer up from sleep and iCue (which has been working okay since release) crashed. Normally this is fine but it kept crashing every single time. Uninstall/reinstall, crash upon opening. System restore, doesn't make a difference. On debug, it says there is an unhandled exception in Qt5Core.dll and thats crashing everything.

Now i'm back in Link and CUE 2 and my h150i Pro is stuck in a rainbow loop and I can't control its fan speeds. Does anyone know where I can get a clean 150i Pro driver? iCue has completely trashed mine.

Toasted 04-01-2018 07:59 PM

The driver you need should be located in;
C:\Program Files (x86)\CorsairLink4\Drivers\490

DevBiker 04-01-2018 08:38 PM

To get a clean driver install without iCue, the best thing for you to do is uninstall iCue (I think you've done this). From there, go to Device Manager and find the driver "Corsair UsbXP Driver" and remove the driver, deleting all files. Then install Link fresh.

almostcraig 04-02-2018 08:33 PM

Quote:

Originally Posted by Toasted (Post 948102)
The driver you need should be located in;
C:\Program Files (x86)\CorsairLink4\Drivers\490

Unfortunately there isnt a drivers folder in my CorsairLink4 folder

Quote:

Originally Posted by DevBiker (Post 948116)
To get a clean driver install without iCue, the best thing for you to do is uninstall iCue (I think you've done this). From there, go to Device Manager and find the driver "Corsair UsbXP Driver" and remove the driver, deleting all files. Then install Link fresh.

I tried doing this, made sure to delete all files in the driver and on uninstall, clean install, didn't matter. My H150i pro is borked, still cant control lights or fans. Thanks anyway guys

DevBiker 04-02-2018 10:38 PM

Quote:

Originally Posted by almostcraig (Post 948319)
I tried doing this, made sure to delete all files in the driver and on uninstall, clean install, didn't matter. My H150i pro is borked, still cant control lights or fans. Thanks anyway guys

Well, which version of Link? There are widespread reports of the latest version of Link not working with the Pro coolers. Installing the previous version of Link resolves the issue.

almostcraig 04-03-2018 09:49 PM

Quote:

Originally Posted by DevBiker (Post 948344)
Well, which version of Link? There are widespread reports of the latest version of Link not working with the Pro coolers. Installing the previous version of Link resolves the issue.

You're my hero - 4.9.5.25 finally let me turn control things again. Thank you!


All times are GMT -4. The time now is 04:12 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.