The Corsair User Forums

The Corsair User Forums (
-   Keyboards and Mice (
-   -   Scimitar Pro RGB (Black) Unwanted profile switching (

davecombine 01-06-2018 01:29 AM

Scimitar Pro RGB (Black) Unwanted profile switching
I've been looking everywhere for someone else having this problem, however I haven't found anyone else who seems to report it.

I've just bought my Scimitar Pro RGB and have installed CUE 2, and have it updated to the most recent version, and I've edited the "default" profile to my liking. I have changed the "Profile switch" button to be "Forward" and the "DPI Switch" button to be "Backward", as well as the lighting to all be one static color.

For no apparent reason, after a few minutes of usage, the mouse completely deactivates and becomes unresponsive for a few seconds, and then reverts back to (what I think is) the profile Scimitar Pro HW 1. The key binds, lighting, and DPI all change. When I go back into CUE, it says that it is still on the default profile.

Whenever I try switching to another profile and back again to go back to the default profile, the key binds revert back to what I want them to, however the lighting becomes messed up: everything but the "side zone" and the "DPI light" becomes stuck on rainbow. CUE says that they're back on the color I want, however no matter what I do, it's stuck on rainbow.

This happens multiple times, and the only fix I have seen is restarting my computer. Is my mouse defective? Or could something else be causing this?

Toasted 01-06-2018 07:48 AM

Have you tried reflashing the firmware via CUE?
Tried a different USB port?

davecombine 01-06-2018 09:21 PM

I have tried both, and neither have worked.

If it helps, I discovered that it seems to be happening more frequently when I'm in the middle of a Twitch call.

Shaxx 01-08-2018 09:09 AM

This similar issue started happening to me yesterday as well.I wasn’t on the latest firmware version and it would just change the profiles on its own.

updated the CUE software and somehow it made it worse, now instead of switching profiles the mouse actually disconnects from windows or it will freeze for a couple of seconds before working again. I’ve tried reinstalling drivers, downgrading versions and nothing.

It’s a bummer because I really enjoy this mouse and I’ve already gotten used to it but this software is just way too buggy.

Toasted 01-10-2018 08:33 AM

Can you try creating a new profiles rather than using the default profile and then moving that to the top of the list?

Actions/Lighting effects can be transferred over using the Actions/Lighting library.

davecombine 01-13-2018 12:16 AM

I was about to say that after a few days that had worked, but then it stopped again, as soon as I was in a Twitch call.

I'm gonna go ahead and move this to being a Twitch problem rather than a Corsair problem.. although I don't understand why Twitch would be making my mouse glitch out all of the time.

Toasted 01-13-2018 07:24 AM

If you have not done so already, you'll want to put in a support ticket with steps to reproduce the problem. If it is reproducible and identified as a bug on Corsair's side, it will be looked in to.

Corsair Nick 01-15-2018 07:14 PM

Is the reset occur when holding the default profile switch button on top, even though you have changed it to Forward or Back? Is CUE also running while this happens or is it closed?

davecombine 01-15-2018 07:36 PM

I had not payed that much attention, but since my push-to-talk key is the Forward bind (originally profile switch), then yes I suppose it does.

The problem occurs when CUE is closed, as well as open.

All times are GMT -4. The time now is 07:38 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.