The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Audio (https://forum.corsair.com/forums/forumdisplay.php?f=207)
-   -   Void wireless doesn't work anymore? [firmware 39.02] (https://forum.corsair.com/forums/showthread.php?t=160736)

pachu 07-24-2016 10:54 AM

Void wireless doesn't work anymore? [firmware 39.02]
 
Hi, I was going to update the device to firmware v39.02, but when I plugged the headset via USB Windows said "Installing device...".

After one or two minutes, it showed up that the device couldn't be installed, and since that it shows up as "Unknown device".

Now the headset doesn't turn on or even charge, Windows keeps showing it up as Unknown device and if I try to update to v39.02 or just force the update from server, it keeps telling to connect the headset via USB, but can't recognize it.

It's my headset dead?

Update: I've already check if the headset was in bootloader mode and I don't think so since it doesn't shows up as "Avnera device"

OggyPanda 07-25-2016 03:11 AM

I had the same problem, unplugged the wireless dongle then plugged it back in and updated the firmware via usb cable and it's working again

Toasted 07-25-2016 05:47 AM

If OggyPanda's suggestion did not help. Try it on another computer and see whether Windows correctly detects the devices.

pachu 07-25-2016 10:23 AM

First of all, thanks for the responses, but it doesn't work, the headset doesn't turn on and my PC doesn't recognize it, I've tried in other PC and I have the same problem.

Toasted 07-26-2016 06:01 AM

Have you tried putting the headset into bootloader mode? Does it do anything or is the devices still unrecognised?


All times are GMT -4. The time now is 02:17 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.