The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Corsair Link (https://forum.corsair.com/forums/forumdisplay.php?f=209)
-   -   Need Help ASAP! (https://forum.corsair.com/forums/showthread.php?t=113976)

smithy1294 01-07-2013 10:14 AM

i dont understand what i need to do :@ why wont the drivers install properly :@

smithy1294 01-07-2013 10:30 AM

1 Attachment(s)
Here's my device manager..

Ripshod 01-07-2013 10:31 AM

code 10 again then. It should show as a 'HID-compliant device'. Only thing you can try (again) is to uninstall it and reboot with as many USB devices disconnected as you can, obviously you'll still need your keyboard/mouse. It looks like there is no easy answer for this issue.

We've already seen that other USB devices can interfere with the driver install, whether through bad drivers or whatever.

Also the software itself is not 100% stable.

All setups are different. My pc had no problem flashing the firmware or running the software, but my system is different to yours (even if it had the same hardware there would still be a difference).

Corsair inherited this system from CIS, and it was buggy from the start. I believe what they've done is try to fix the errors rather than start from scratch.

Whatever happens now it can only get better. I took it upon myself to try and understand the issues and try to sort them out. But still, there have been hardware changes throughout production of these coolers that just make the problem worse.

More testing is needed. Not just with motherboards, but as it is a USB device they obviously need to test with as many USB devices and configurations as they can.

It doesn't help resolve your problem, just explains my beliefs.

smithy1294 01-07-2013 10:41 AM

Right what about if i plug the USB dongle into my psu then the psu corsair link thing into the usb dongle and atleast try and get that working through Corsair link?

Ripshod 01-07-2013 10:46 AM

Scrub that

Ripshod 01-07-2013 10:53 AM

The cooler installs as 2 devices.

First is the 'USB Input Device', that's the Corsair Hydro USB you see in CorsairLink. (the interface itself as you saw a bridge device being installled)

The second should be a 'HID-compliant device' in device manager. That's the cooler itself. You've got to check all the HID compliant devices for the hardware ID 'USB\VID_1B1C&PID_0C04&REV_0200', the same ID for both.
If it's not listed then it's a hardware problem.

You may be getting that code 10 because the cooler is not being seen.

If this is the case then i believe you have a faulty unit.

Microsoft's drivers are over 6 years old now. It really is time Corsair wrote their own.

smithy1294 01-07-2013 11:06 AM

Man i think i've done it, what you initially said was right!
What i did:
Thought hmm it always fails initially when its plugged in and i boot so i decided to power off unplug the usb connecter from the h100i and power on, waited til everything was loaded ya now the usual stuff and then once i was convinced it was finished booting and loading services i opened device manager made and plugged it back in then hit 'scan new hardware changes' or its called something like that, anyway that found the 'USB Input device' like you said in your previous post and loaded the whole found new hardware pop up box, which said it was scanning windows update which i canceled then it said it installed drivers in device manager but it still had the orange triangle thing didnt bother looking what it said at the time but i went to update driver then went to select my own and unticked compatable devices i then installed the standard USB Input Device again an voila that then kicked in found new hardware with the HID compliant devices, only thing i havent checked is Corsair Link but (fingers crossed) for now it (kinda) works :D

P.S sorry for the essay ^

Ripshod 01-07-2013 11:09 AM

Should have let windows update run it's course, but then the system should have the HID drivers already. I've amended my driver post with the info we've just discovered. Fingers crossed eh?

Essays are GOOD, more info the better.

My question now is 'Will it still be there when you reboot?'

smithy1294 01-07-2013 11:15 AM

Haha everything crossed at the moment just restarting and waiting for everything to settle down before I do anything again just to make sure currently replying to this off my phone an I don't wanna give out false information but i didn't let windows update run due to the fact that the drivers it installed everytime were from windows update and they weren't working (perhaps newer but not working drivers on windows update or old no idea) so I was hoping it might find working drivers in my system which it did but not fully still recognised it as a USB input device tho which was the start I needed to run the previous posts process :)

EDIT: CorsairLink 2.2 doesn't list the devices in the first tab but its in the option tab as Hydro USB version 2.0, i just need to know how to get it into that first window along with everything else plugged into the h100i

going to try re-installing cos cant remember if i installed corsair link before it recognised the device in windows or not :P

Ripshod 01-07-2013 11:24 AM

No. Hydro USB is just the interface (which I'm glad is working now).
The cooler will show as Corsair H100i Version: 1.x.x

Is the HID-compliant device listed in device manager with the correct hardware ID? That's the actual cooler.

smithy1294 01-07-2013 11:27 AM

Yeh i have a matching id between the USB input device and the HID device, both with working drivers

EDIT: Just re-installed 2.2 and it no longer finds Hydro USB yet there still there in device manager working fine, going to try another reboot

Ripshod 01-07-2013 11:32 AM

If the cooler isn't listed in the software as Corsair H100i then you'll have to redo the flash in 2.1.1 cos 2.2.0 won't see it without the new firmware.

Should be done soon ( about 4 more posts lol)

smithy1294 01-07-2013 11:40 AM

Last time i was in 2.1.1 i couldnt see the h100i in the bootloader is was that just because windows couldnt find it?

Ripshod 01-07-2013 11:42 AM

Yes, cos it wasn't even installed.

And so it didn't flash.

smithy1294 01-07-2013 11:55 AM

No i mean i have no option to flash the h100i in 2.1.1 even now the device is installed (in windows) i have no option, the only option i have is the corsair commander :(

Ripshod 01-07-2013 11:59 AM

This is v wierd. We're about 80% there, just this to sort. Take a break, I am - hungry again lol.
If you want you could try 2.1.7 while I'm away, may not get you anywhere tho

smithy1294 01-07-2013 12:02 PM

i'll try the 2.1.7 and yeh you deserve a break, seriously cant believe you've put up with me this long :P

Ripshod 01-07-2013 12:08 PM

And I can't believe you've stuck it so long. If it was me this thing would be RMA'd already lol

smithy1294 01-07-2013 12:09 PM

Its not broken its just not working and i've only just fitted it :P

smithy1294 01-07-2013 12:18 PM

Right i have installed 2.1.7 and it still detects the Hydro USB, ran update FW an it lets me select h100i, i select the H100i_v1.0.4.s19 file and then it says bootloader in progress then seconds later ERROR loading FW file :@ it then lets me close it, i re-open corsair link and boom no Hydro USB, only way to get it back is too restart :@

EDIT:

Why won't it detect it, do i have to flash it to detect it?

Ripshod 01-07-2013 12:52 PM

mm, then I'd say you do have a USB conflict somewhere. Do you have USB3? Try in that with nothing else connected to the USB3? Have you tried with your keyboard/mouse on a different port?

Clutching at straws but it is a USB conflict. What's happening is the flash is starting, but the HID is dropping out during the process so it doesn't complete.

Are you using Windows' default USB2.0 drivers or drivers from your motherboard's manufacturer?

smithy1294 01-07-2013 12:57 PM

I have usb but how do i fit it into that its a different header isnt it? and how do you find out which usb 2 drivers your using?

Ripshod 01-07-2013 01:13 PM

If you haven't installed any USB drivers then you are using the Windows drivers. USB ports at the rear of your PC with a USB-A to mini USB-B lead (phone, or USB hub lead) or am I right recalling you saying you don't have one of those?

smithy1294 01-07-2013 01:27 PM

yeh i dont have one of these leads :(

Ripshod 01-07-2013 01:33 PM

For now you could just connect the fans to the fan headers on your mobo. Use speedfan to control them. We'll play a little more later lol.

Leave the pump connected to the cpu fan header so you're protected against pump failure.

smithy1294 01-07-2013 01:37 PM

Theres gotta be some way :@ :(

Ripshod 01-07-2013 01:41 PM

It's only a temp fix. I've got my fingers crossed that the new software (whenever it lands) includes drivers written specifically for the H80i/H100i.

That's the way i see it.

106 posts and we still haven't sorted it. It's the HID drop-out that's causing this, and I have no fix for that (yet)

I'm sure I asked before. is it an Asus mobo?

smithy1294 01-07-2013 01:43 PM

How can we be sure, cos theres no sound of the device disconnecting or anything and if i go into device manager afterwards im certain the device still remains, CorsairLink just cannot find it again even if i restart the service it only finds it if i restart the computer all together

Ripshod 01-07-2013 01:45 PM

The drivers just drop, there won't be a dsconnect signal.

smithy1294 01-07-2013 01:46 PM

Ffs corsair!!!

Ripshod 01-07-2013 01:51 PM

Not necessarily Corsair's fault. What's your mobo?

I'll explain.
I know for a fact your cooler is okay. I also know the CorsairLink software is okay.
What I don't know yet what is causing the drivers to drop.
Hence my mobo question.

smithy1294 01-07-2013 01:52 PM

I dont understand how it works for some people and not others, and i had it working once like first time ever but then i turned off computer came back 30mins later re booted and it wasnt working so system restored and its never worked since, i think thats how my LEDS are cycling cos i was messing with the LED setting but i didnt think i saved any an if i did it would only save to a profile which is no longer there anyway surely

Motherboard:

Gigabyte Z68X-UD3P-B3, i've had a look an no USB drivers on the site other than USB3.0 ones which i have

Ripshod 01-07-2013 01:58 PM

Last question then you can get some rest for a bit while I chat with Gigabyte.

What keyboard/mouse?

Something else I should have asked earlier ffs:

Which version of the intel RST drivers are you running?

smithy1294 01-07-2013 02:01 PM

Keyboard is a USB Logictech k300 and mouse is a USB Steelseries Xai

Ripshod 01-07-2013 02:14 PM

Have you got a spare keyboard laying around you could try?

smithy1294 01-07-2013 02:16 PM

No but i dont actually need a keyboard i dont have a login so i wont need a keyboard

Ripshod 01-07-2013 02:17 PM

Getting somewhere. Do you have Intel's Rapid Storage Technology drivers installed. If so which version?

Could try the firmware update without the keyboard as it's all mouse.

smithy1294 01-07-2013 02:19 PM

i think so but where would this be mentioned?

Ripshod 01-07-2013 02:22 PM

Device manager? Being and AMD fanboy I wouldn't know the ins and outs of it. Suffice to say the more recent intel RST drivers clash with CorsairLink. I'm hunting through forums now to find a version and download for you.

smithy1294 01-07-2013 02:24 PM

Then lets go with i havent got these drivers and see where that takes us


All times are GMT -4. The time now is 12:49 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.