The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Corsair Link (https://forum.corsair.com/forums/forumdisplay.php?f=209)
-   -   Need Help ASAP! (https://forum.corsair.com/forums/showthread.php?t=113976)

Ripshod 01-06-2013 08:10 PM

So it goes down in my book that manufacturers rewrite their own HID drivers that stop microsoft's installing. That makes total sense and will probably be the answer a lot of users are looking for. Would also explain why units get bricked by the firmware updates.

We done good for Corsair here methinks. :cool:

I'm buzzin' for ya :D

smithy1294 01-06-2013 08:11 PM

Hahahaha again thanks for all the help :)

Ripshod 01-06-2013 08:12 PM

npz m8, that's what we're all here for.

Ripshod 01-06-2013 08:19 PM

And I can now confirm the 'Integrated USB Bridge' in 'Devices and Printers' is indeed H80i/H100i.
The other CorsairLink devices may also appear as separate integrated USB bridge devices. I'll confirm this when I fit the dongle for my psu.

smithy1294 01-06-2013 08:21 PM

Awesome, one small problem, device wont upgrade FW, in 1.2.7 it says FW is 0.0 :S trying to put 2.09 on an nothing (on commander btw)

Ripshod 01-06-2013 08:31 PM

Now the commander. I don't have one :roll:
I have seen it before on these forums tho
Hopefully someone else will pop in and help you with that one ;):

smithy1294 01-06-2013 08:36 PM

Oh right ok I just thought the h100i had like a built in one that required separate FW but if not that's fine I'll just need the h100i FW an the 860i FW :)

Ripshod 01-06-2013 08:38 PM

Is everything working tho? I'm not gonna leave this til you're sorted. It's a learning curve so I can help more peeps avoid the hurdles.

smithy1294 01-06-2013 08:42 PM

Haha I must say I haven't tried as I haven't updated it to 2.20 yet however once I do that and update FW ill be sure to let you know for now tho I'm off to bed, I think you've deserved a break my friend, everything should be fine and (fingers crossed) easy pickings from here on out, again thanks a lot and ill report back whether its good news or bad (:

doubleT 01-07-2013 06:22 AM

Sorry, I was under the impression you're running the PSU and the H100i through the Link Commander and the fans through the Cooling Node. Disregard what I said about Cooling Node (needing a FW upgrade) then. ;)

Hope you get everything sorted out.

smithy1294 01-07-2013 06:54 AM

The only problem i have now is that CorsairLink says 'ERROR loading FW file' when trying to update my h100i FW... anyone know anything?
Running CorsairLink 2.2

smithy1294 01-07-2013 07:18 AM

2 Attachment(s)
I've discovered then when i first boot my system that it finds the h100i pump as the HID device in device manager, however as soon as i run the FW update in corsair link, this device becomes the 'unknown device' we were having earlier, and the only way to get it back to the HID is to restart this system, see this wouldnt be a problem but i dont have anything detected in CorsairLink as the screenshot shows

Ripshod 01-07-2013 07:32 AM

Go to the options tab and put a tick in the 'Show All Devices' box.
They should show then.
What happens is when you update the firmware the hardware ID changes and it's detected as a different device.

smithy1294 01-07-2013 07:35 AM

Hey again, 'Show all devices' is ticked still nothing :(

Ripshod 01-07-2013 07:37 AM

mmm, d**n software. Is it definitely in device manager? (try the hardware ID trick again to make sure). If it's there reinstall the software. When you uninstall delete the corsair folder in C:\Users\{username}\AppData\Roaming\
Again try swapping USBs about.
I hope this is all fixed soon, it's all so complicated at the moment.

smithy1294 01-07-2013 07:52 AM

Hardware id is correct, reinstalled and restarted and still nothing, tried swapping my external usb's around, nothing, tried my internal usb header swapping and again it says 'unknown device'

Ripshod 01-07-2013 07:57 AM

When did you first install it? If it wasn't too long ago, as long as you're not gonna lose any files, maybe system restore to before you first installed any Corsair software and reinstall 2.2.0?
As you've already updated the firmware it should all just go straight in.

smithy1294 01-07-2013 08:00 AM

I havent updated any FW, im so confused i dont know what i need to do, imagine its the first time doing all this and everything went smoothly i've just install Corsair 2.2, now what would you do?

Ripshod 01-07-2013 08:06 AM

To be honest I would now say hold off with the firmware and software till Corsair sort the bugs.
The cooler will run fine without any software (like the old H100) so long as you haven't got a hardcore overclock on your CPU.
Don't want to brick your cooler ;)

At least now it's recognised properly and I've learnt a few more things to help me help others.
Funny thing, out of the 10 units I've installed I've only had one fault (pins popped out of the fan splitter's plug)

The fact is it won't be recognised by 2.2.0 - you need the firmware update for that.
Maybe download 2.1.7 and run that? See how it goes? At least you'll then be ready to flash the new firmware (when it arrives)

smithy1294 01-07-2013 08:27 AM

Installing 2.1.7 now, will be back shortly :P

smithy1294 01-07-2013 08:29 AM

Right its installed, still have no devices and in Options then Devices it doesnt see the Hydro usb thing that 2.2 did

Ripshod 01-07-2013 08:37 AM

Now things are getting really wierd.

It's recognised correctly in device manager but not by the software that's need to flash the firmware.

Honestly? Now I'd personally use it as is til we find an answer. No point leaving broken files all over your drive. Maybe corsair will see this issue and provide some custom drivers for us? We can but hope.

I don't think you should go any further for now. I'm still absorbing all the various info on these forums. Just consider it a H100 til we find the answer??

Unless one of the gurus pop in and give us the answer.

I'm embarassed. I'm feeling like I've been chasing my tail and wasting your time. I'm sorry I can't be more help atm.

smithy1294 01-07-2013 08:45 AM

Right just did the whole 10min power hard reboot thing and its detected it in Corsair 2.1.7 now do i flash it like you said earlier?

Ripshod 01-07-2013 08:49 AM

If you need to. Sometimes the firmware update can brick these coolers.
If you have a problem that needs the firmware update then yes, do it. Otherwise I recommend waiting til a newer (read 'better') firmware is released.

smithy1294 01-07-2013 08:51 AM

This is ******, i pay money for all this 'awesome new software' that doesnt bloody work! :( i just wanted to detect my h100i and ax860i and be able to change the fan speeds and stuff, this is crap

Ripshod 01-07-2013 08:54 AM

Then do the update if you want to control the fans.
Remember that 2.1.7 may lose the unit after the update - that's when you should uninstall 2.1.7, delete the corsair folder, reboot and install 2.2.0.
That will give you full control

c**p is a strong word, but I agree

smithy1294 01-07-2013 08:55 AM

it didnt update it said ERROR loading the FW file again :@

Ripshod 01-07-2013 08:56 AM

did you extract the s19 file from the zip. Make sure you have the right one (best way to make sure is to download it from Corsair's main site)

smithy1294 01-07-2013 08:56 AM

H100i_v1.0.4.s19
is what i tried?

Ripshod 01-07-2013 08:59 AM

Wow. Some say use 2.1.1 for the flash, but from what I know 2.1.7 was the first with the H80i/H100i bootloader, which is needed for the flash.
If you read the stickied firmware guide it does say 2.1.1 for the flash. i used 2.1.7 without issue.

**try the 2.1.1**

smithy1294 01-07-2013 09:01 AM

i cant see where it says that they used 2.1.1

Ripshod 01-07-2013 09:02 AM

http://forum.corsair.com/v3/showthread.php?t=112507

We have peeps using 2.1.1, and others that have to use 2.1.7

Different advice from different people makes this all the more confusing.

smithy1294 01-07-2013 09:26 AM

ffs you cant even update the FW with 2.1.1 :@

smithy1294 01-07-2013 09:29 AM

All I want to do is be able to control my fans for my h100i through its pump thing, how hard is that! :(

smithy1294 01-07-2013 09:39 AM

Just did major system restore before i put anything Corsair related on and it went found new hardware 'Integrated USB bridge' which it has never done :eek: :confused:


EDIT:

And then it failed :@

Ripshod 01-07-2013 09:41 AM

Best bet now would be to post in the stickied firmware topic, someone will pick it up. But you are certainly not alone. :(: :(:

smithy1294 01-07-2013 09:43 AM

Cant the thread is closed :( i just don't understand why it cant install Windows drivers..? why cant Corsair just have there own drivers instead of relying on someone elses :(

Ripshod 01-07-2013 09:46 AM

That is my point m8. been asking for that since I joined these forums. I was one of those that tried to force the AXi drivers to install for my H80i.

Just want to check - which version of windows?

Firmware update topic is still open, someone posted @1.:27

http://forum.corsair.com/v3/showthread.php?t=112507

smithy1294 01-07-2013 09:47 AM

Windows 7 Ultimate - SP1 - 64Bit

Ripshod 01-07-2013 09:49 AM

okay. Make the post m8, better chance of someone Corsair seeing it.


All times are GMT -4. The time now is 06:28 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.