The Corsair User Forums

The Corsair User Forums (
-   Corsair Link (
-   -   Need Help ASAP! (

smithy1294 01-06-2013 05:23 PM

Need Help ASAP!
Just got a h100i and ax860i thinking corsair link would be pretty awesome, problem is my h100i link commander thing gets 'USB not recognised' and then fails to instal drivers.

i've done the whole thing where you install 1.2.7 then install the commander FW 2.06 (however it never actually completes always gets stuck in process, so i task manager force quit) then i uninstalled 1.2.7 to install 2.20 and the drivers dont install, they sit on my harddrive and i can see them but they dont work, tried right clicking on CMIusb.inf but it tells me you cant install it that way in a pop up, and now im stuck and confused and need help, thanks in advance

Win 7 64bit

(thinks thats you need to know)

doubleT 01-06-2013 05:29 PM

Are you sure the FW update got stuck? What did it say?
I thought at first that it didn't do anything. But luckily I was patient enough and it worked out fine.

After uninstalling 1.2.7 you HAVE to reboot. Only after that you should install the 2.2 version.

Ripshod 01-06-2013 05:31 PM

Are you 100% sure the update hasn't worked? Some have reported this then said the firmware had actually installed.
Driver: Device manager - right click the dongle - update driver software - browse my computer - let me pick from a list... - have disc - browse to the inf file.

smithy1294 01-06-2013 05:34 PM

doubleT how long did you wait i left it like 3mins? i dunno will try longer (: and i didnt know you HAD to reboot will defo try that, thanks

Ripshod thats the thing the dongle isnt there, its just 'unkown device' but i know its the dongle.

EDIT: also doubleT should corsair link lock up when its updating FW cos thats all mine does

Ripshod 01-06-2013 05:36 PM

Still do it. If the drivers still refuse to install try uninstalling it (select 'delete drivers' if it's there). If it doesn't work then I think something else is going on. If you have USB keyboard or mouse try moving them to a different port and try again.


If you have a USB A to mini USB B (mobile phone, card reader etc) try connecting to one of your rear USB with that

smithy1294 01-06-2013 05:42 PM

Right bootloader has been 'in process' for 5mins now, surely it shouldnt take this long and Ripshod i will try your suggestion in a sec :) and too the second post i have a usb keyboard and mouse but surely that shouldnt do anything as there just going straight into the motherboard? And i do not have a cable but i was also thinking of that method if i did have the required cable

EDIT: approaching almost 10mins now :(

Ripshod 01-06-2013 05:49 PM

Have the fans spun right up and settled down?

doubleT: How did you get out of it, reboot?

smithy1294 01-06-2013 05:50 PM

when i first boot my computer everything ramps up to max then settles, the fans on my h100i seem to be at a constant rate like balanced not too fast not too slow? its hard to explain haha

Ripshod 01-06-2013 05:52 PM

Shut down, turn the power off. Drain all remaining power with the power button then leave it for 10 minutes and boot up again. Grabb a cuppa while you wait - I'm going nowhere.

smithy1294 01-06-2013 06:21 PM

im back, found new hardware now its trying to install 'Integrated USB bridge'? doesnt look like its finding anything though

smithy1294 01-06-2013 06:25 PM

Nope just came up...
USB Input Device FAILED..?

now what should i do try and get it to find the inf file?

Ripshod 01-06-2013 06:27 PM

Device manager - right click the device - update driver software - browse my computer - let me pick from a list... - have disc - browse to the inf file.

Ripshod 01-06-2013 06:30 PM

I've just reread your first post. Do you actually have a Commander unit installed or just the H100i and AX860i?

Originally Posted by smithy1294 (Post 623896)
then install the commander FW 2.06

smithy1294 01-06-2013 06:30 PM

Just tried this and it says that it doesnt contain a compatible software driver for your device :(

smithy1294 01-06-2013 06:31 PM

i have nothing installed :( nothing really 'installs' i try and do the commander and it just says 'in process' for ever

Ripshod 01-06-2013 06:34 PM

Panicked me for a mo, thought you was trying to flash the h100i with the commander firmware. My bad. Give me a few mins I'll look into driver settings for windows update

Ripshod 01-06-2013 06:40 PM

Control Panel> Devices and Printers>

Right-click the name of your computer, and then click Device installation settings.

Click Yes, do this automatically (recommended), and then click Save changes. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

If Yes is already selected, click Cancel to close the dialog box.

Back into device manager, right click the device> update driver software> Search Automatically for.....

This should automatically download and install Windows' default HID driver. May have to reboot

Ripshod 01-06-2013 06:42 PM

It is a HID Device, I have the USB Bridge in my devices

smithy1294 01-06-2013 06:46 PM

Sorted it to an extent, its found the drivers and installed them now what i get is code 10 the device cannot start... shall i reboot see if that helps?

Ripshod 01-06-2013 06:47 PM

They are the wrong drivers. The included drivers are for the AXi PSU only. Everything else should use the Windows' HID driver. Uninstall those - they won't do anything - they'll always be code 10


Remind myself to write a tutorial

smithy1294 01-06-2013 06:49 PM

But there called 'Corsair Link(TM) USB Dongle'?

Ripshod 01-06-2013 06:50 PM

Yeah, the dongle for the psu. It's so frustrating I understand. I started with the exact same driver issue - even wrote my own

smithy1294 01-06-2013 06:51 PM

i dont have a dongle for the psu, well i do but my psu is plugged into my h100i pump?

Ripshod 01-06-2013 06:53 PM

So you don't need those drivers at all. Did you do what I suggested in my post above - windows update will take care of all the drivers

smithy1294 01-06-2013 06:53 PM

Windows update found nothing...

Ripshod 01-06-2013 06:55 PM

? That is v strange. :bigeyes:
Gonna write the driver tutorial tonight (I'm in the UK). I'll go into it as best I can. Hopefully you'll get to go through it before you go to bed tonight.

smithy1294 01-06-2013 06:56 PM

Hahaha i hope so but dont worry if it takes a while im sure too be up til 2am (im also UK) :) thanks for all the help :)

Ripshod 01-06-2013 06:59 PM

lol, sys then

Ripshod 01-06-2013 07:27 PM

Part 1 of the guide - should see you right. If it doesn't work there is another issue.

smithy1294 01-06-2013 07:39 PM

Nope still nothing :( in 'Universal Serial Bus Controllers' is where my 'unknown device' is but when i update through automatically search it says windows has already found the best drivers for this device 'Unknown device'

Ripshod 01-06-2013 07:45 PM

mmm. Have you tried a different USB header, it'll force it to be freshly detected.
Shame you haven't got a mini USB B lead to test in one of your rear USBs. Don't go out and buy one - that is just a theory that needs confirming.
I'm not giving up on you yet.
Your H100i is lit up blue or white, not red or flashing??

Ripshod 01-06-2013 07:48 PM

1. Right click the 'unknown device' and select 'Properties'
2. Select the 'Details' tab
3. Click on the drop down 'Property' box (should already say 'Device description') and select 'Hardware Ids'
4. You're looking for 'HID\VID_1B1C&PID_0C04' or 'HID\VID_1B1C&PID_0C04&REV_0200'

smithy1294 01-06-2013 07:48 PM

hahah yeh only got 2 'spare headers' however i have 3 in total and i have tried all 3, they all detect it but detect it as unknown, my h100i is changing colours its on a cycle or something its cool but does that mean its 'working' or not?

the id =

Ripshod 01-06-2013 07:52 PM

Did you say you had USB keyboard/mouse? May be worth moving them to a different socket and trying again.

This is the first time I've come across 'cycling' colors. That must mean something i don't know about yet. What speed are the fans at?

Ripshod 01-06-2013 07:54 PM

One second. open Corsair Link, go to the options tab and select devices. Take a screenie and post it please.

smithy1294 01-06-2013 07:54 PM

Fans are SP120 quiets running at about 1125rpm each..

smithy1294 01-06-2013 08:03 PM

Fixed it i believe... i was googling around and saw someone was having problems related to there usb headers that came from a incompatible pci usb hub thing, which i have one in my system and have never used so i thought hmmm, took it out restarted an VOILA (: the HID-compliant device with the correct hardware ID, thanks for all your help i really appreciate it but in the end it was down to faulty hardware haha we would never of guessed that!

smithy1294 01-06-2013 08:04 PM

however now that its found it what do i do? remove all corsair link then install 1.2.7 and start from fresh?

doubleT 01-06-2013 08:05 PM

Ha, who could've guessed. Hope everything goes well now.

edit: Just saw your post.

Yeah, install 1.2.7, then update all the FW.
Uninstall 1.2.7 - REBOOT (Important!) - Install 2.2.0

Ripshod 01-06-2013 08:07 PM

Yep, do that. Good progress ;)

All times are GMT -4. The time now is 12:09 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.