The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Corsair Link (https://forum.corsair.com/forums/forumdisplay.php?f=209)
-   -   Need Help ASAP! (https://forum.corsair.com/forums/showthread.php?t=113976)

Ripshod 01-06-2013 07:45 PM

mmm. Have you tried a different USB header, it'll force it to be freshly detected.
Shame you haven't got a mini USB B lead to test in one of your rear USBs. Don't go out and buy one - that is just a theory that needs confirming.
I'm not giving up on you yet.
Your H100i is lit up blue or white, not red or flashing??

Ripshod 01-06-2013 07:48 PM

1. Right click the 'unknown device' and select 'Properties'
2. Select the 'Details' tab
3. Click on the drop down 'Property' box (should already say 'Device description') and select 'Hardware Ids'
4. You're looking for 'HID\VID_1B1C&PID_0C04' or 'HID\VID_1B1C&PID_0C04&REV_0200'

smithy1294 01-06-2013 07:48 PM

hahah yeh only got 2 'spare headers' however i have 3 in total and i have tried all 3, they all detect it but detect it as unknown, my h100i is changing colours its on a cycle or something its cool but does that mean its 'working' or not?

the id =
USB\UNKNOWN

Ripshod 01-06-2013 07:52 PM

Did you say you had USB keyboard/mouse? May be worth moving them to a different socket and trying again.

This is the first time I've come across 'cycling' colors. That must mean something i don't know about yet. What speed are the fans at?

Ripshod 01-06-2013 07:54 PM

One second. open Corsair Link, go to the options tab and select devices. Take a screenie and post it please.

smithy1294 01-06-2013 07:54 PM

Fans are SP120 quiets running at about 1125rpm each..

smithy1294 01-06-2013 08:03 PM

Fixed it i believe... i was googling around and saw someone was having problems related to there usb headers that came from a incompatible pci usb hub thing, which i have one in my system and have never used so i thought hmmm, took it out restarted an VOILA (: the HID-compliant device with the correct hardware ID, thanks for all your help i really appreciate it but in the end it was down to faulty hardware haha we would never of guessed that!

smithy1294 01-06-2013 08:04 PM

however now that its found it what do i do? remove all corsair link then install 1.2.7 and start from fresh?

doubleT 01-06-2013 08:05 PM

Ha, who could've guessed. Hope everything goes well now.

edit: Just saw your post.

Yeah, install 1.2.7, then update all the FW.
Uninstall 1.2.7 - REBOOT (Important!) - Install 2.2.0

Ripshod 01-06-2013 08:07 PM

Yep, do that. Good progress ;)

Ripshod 01-06-2013 08:10 PM

So it goes down in my book that manufacturers rewrite their own HID drivers that stop microsoft's installing. That makes total sense and will probably be the answer a lot of users are looking for. Would also explain why units get bricked by the firmware updates.

We done good for Corsair here methinks. :cool:

I'm buzzin' for ya :D

smithy1294 01-06-2013 08:11 PM

Hahahaha again thanks for all the help :)

Ripshod 01-06-2013 08:12 PM

npz m8, that's what we're all here for.

Ripshod 01-06-2013 08:19 PM

And I can now confirm the 'Integrated USB Bridge' in 'Devices and Printers' is indeed H80i/H100i.
The other CorsairLink devices may also appear as separate integrated USB bridge devices. I'll confirm this when I fit the dongle for my psu.

smithy1294 01-06-2013 08:21 PM

Awesome, one small problem, device wont upgrade FW, in 1.2.7 it says FW is 0.0 :S trying to put 2.09 on an nothing (on commander btw)


All times are GMT -4. The time now is 08:29 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.