The Corsair User Forums

The Corsair User Forums (
-   Cooling (
-   -   ML140's RGB No Lights (

Bristlebeard 11-13-2019 03:00 AM

ML140's RGB No Lights
2 Attachment(s)
Hello everyone,

I've got 3 ML140 RGB fans that I bought secondhand. I was told they worked without issue, and they came with the RGB fan hub.
I purchased a brand new LNP to use with them.

I've connected the RGB fan hub to sata power, and then connected that to the LNP which is also plugged into sata power (I'm troubleshooting each of the 3 fans).

The fan is plugged into a the motherboards pwm fan connecter, and connected to the RGB fan hub. The LNP is connected to a USB connector on the motherboard. All of the fans spin without issue. None of the fans have any light (not sure if they have a default they cycle through).

I've read through a ton of forum posts, and also through Zotty's thread about how to connect everything. I thought maybe I had a bad RGB fan hub, so I got another one to confirm this and had no change.

I'm not sure what to do at this point and am looking for some direction. I have a Gigabyte Z370 Gaming 7 motherboard. The iCue software detects the LNP and I've added the ML140 to both the Lightning Channel 1 and 2 to troubleshoot. The original owner claims he controlled the fans using Gigabytes RGBFusion, which I'm not sure how he would accomplish that (just mentioning for full disclosure)

I've attached screenshots of what iCue looks like.


Zotty 11-13-2019 05:09 AM

Hi bud....

First... used with GB's fusion. how? and could be a worry....

Second... you have the fan in port 1 on the RGB Fan LED Hub?.. can't miss any ports out... 3 fans? ports 1 through to 3 is the only way.

if i had to take a guess going off of what you have said. either a broken RGB Fan LED Hub or broken fans.. I wonder how the original owner had them set up too work with fusion

Bristlebeard 11-13-2019 11:43 AM

Hi Zotty,

To answer your questions, yes I have the fan in port 1. I read that you have to have them sequential in order to function. I've tried each fan individually as well as all 3 in different orders 1-3 on the hub.

I got a second RGB fan LED Hub and have the same results.

Secondly, thanks for the response. I'll need to confirm with the previous owner on how he had them connected. It's possible he was just using them with the default lighting they are shipped out with (that's my guess).

In reading some different posts last night I thought I would try a workaround that someone else had that is related to specific branded usb hardware/drivers. Specifically the AsMedia USB controller. My Gigabyte Z370 Aorus Gaming 7 is built with the AsMedia USB controller, and I'm curious to see if powering off a USB to mini usb connection at least gets the lights working on the ML140's. I won't be able to test that until I get home from work later tonight though.

I'll keep you posted on whether or not that's a fix.

DevBiker 11-13-2019 11:52 AM

For the older Gigabyte boards, you could plug the Fan Hub cable directly in to the Gigabyte Addressable Port - just line up the triangle on the connector with the +5V on the motherboard. It's not quite the exact correct usage but, because it has the same pitch, it can work. The pins, however, are thicker - which makes me wonder if that configuration expanding the internal pin connection and that's why it's not working with an LNP now.

Bristlebeard 11-13-2019 06:28 PM

I went home for lunch because I really wanted to get the fans working. I used a USB to mini-usb cable, unplugged the usb cable adapter from the LNP and went directly to the back of my motherboard.
I then downloaded the Asmedia USB drivers from Gigabytes website, did a reboot and not change.

I guess my next option is to plug everything into my sons computer and see if it's my system that's having issues. Beyond that, I'm stumped.

Bristlebeard 11-14-2019 12:26 AM

Are the ML RGB fans supposed to have default lighting that works without having to use the iCue software?
I connected everything to my sons B450 motherboard and no lights came on.
I didn't install the iCue software however because he doesn't have any Corsair fans in his case.

Zotty 11-14-2019 06:28 PM

normally at least... the first fan connected lights up... but its not a given. sometimes Commander Pro/Node Pro's like to be told what is connected to them and then they remember that...... so at this point... install iCUE and add the fans to your device....

c-attack 11-14-2019 06:43 PM

Straight out of the box, they should default to this swirling rainbow pattern when power is applied. This does not require iCUE, only SATA power via the RGB Lighting Hub and the LNP or Commander Pro as well. I just tried to test this out by plugging a ML140-RGB into a spare RGB Lighting Hub not connected to anything else. The fan did not come on without the C-Prp/LNP link. Once connected it does. Quit iCUE and it stays spiral rainbow. Disconnect from LNP/C-pro is stays rainbow. Disconnect the fan lighting wire then reconnect. No lights. To me that means the LNP/C-Pro is required to be connected to initiate lighting. If iCUE is running when you connect, then you must designate lighting parameters.

Also be aware that if you have altered the "hardware lighting" save on your Commander Pro or Lighting Node Pro, that is save to the device (LNP/C-Pro) and will still be active when you move it.

On your original install, the first fan should have lit up in that "ML - 1 fan" configuration, once you added a lighting effect to the list. Since the hardware save method became available, some of these things have changed. When you first install any new devices/fan, you must designate the model and number, then go to the proper lighting channel and add (and apply) that effect. Since you did this and nothing happened, I suspect there might be an issue with the RGB Lighting Hub. That is where the lighting power comes from. You could try a different SATA connector, but if it is not coming on with PC #2, that also suggests a problem. The failure of any fans to light when shuffled 1-2-3 also suggest a problem with the RGB Hub versus a break in one of the fans.

All times are GMT -4. The time now is 05:57 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.