The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Audio (https://forum.corsair.com/forums/forumdisplay.php?f=207)
-   -   Corsair Raptor HS40 7.1 USB Gaming Headset not working or registering (https://forum.corsair.com/forums/showthread.php?t=156306)

Squashed 02-17-2016 02:24 PM

Corsair Raptor HS40 7.1 USB Gaming Headset not working or registering
 
Last Christmas I was given a Corsair Raptor HS40 gaming headset. I've had it for about 2 months, and have mostly enjoyed the product and would recommend it. However today the device stopped working randomly and my computer will not register it. Neither the headphones or the microphone work, and it stopped working randomly today, while it was working fine last night. I have tried all of the USB ports as well as tried to use it on my old laptop, which didn't register it either which leads me to believe that it is a problem with the headset and not the computer. When plugged in, the blue light on the cable lights up, but while normally the mute button could be pressed to turn the light red, it stays blue. While I play enjoy playing games, I do not know a lot about tech and am very confused by this and do not know what to do. Any help would be appreciated.

Squashed 02-17-2016 03:22 PM

EDIT: I have seen the recent update, which I have downloaded, installed, uninstalled and reinstalled but still nothing works.

Toasted 02-18-2016 05:40 AM

If Windows does not see the headset when plugged in, it could be a bad headset.

Can you open Device Manager. There should be a error listed in one of the tress which is related to the headset. If so, can you right click the device >properties>general tab>copy_paste the device status here?

Also put in a support ticket to get the headset replaced. I'm not exactly sure whether you have the receipt or not, but if you can get it, it will be best to do so as this is usually needed to confirm the warranty status.
https://corsair.secure.force.com/

Squashed 02-18-2016 09:26 AM

Thanks for your help. Unfortunately as the computer does not recognise the headset, it does not come up here. Both of these options show that there is no problem however. http://imgur.com/humLXvU

I don't have the receipt or box, and it was bought from a retailer. I'll wait another day and if this is not fixed I'll put in a ticket to hopefully get a replacement. Once again, thanks.

Toasted 02-19-2016 05:50 AM

It doesn't look like the headset may even be recognised as its a USB device. It should have its own separate entry in Device Manager.

Open Devices and Printers (Control Panel) and see whether or not the headset is seen there with a warning icon or something similar.

I would suggest you ask for the receipt for warranty as it will be needed for a warranty replacement. Unless an exception can be made but this will be up to Corsair's discretion.

Squashed 02-19-2016 10:48 AM

Well thats a shame. I'll wait one more day to see if there is any other solution but if not I'll make a ticket. Thanks for your help.

Toasted 02-21-2016 06:56 AM

I would suggest you make a ticket now as Technical support and Customer service can be contacted from the ticket.

Walesnet 02-22-2016 12:17 PM

I was having the same problem with my sons month old headset. It's been driving me up the wall as suddenly and for no apparent reason, it wasn't registering as a device at all, but the blue lights were on.

Thanks to this forum, I just installed the update as below

http://softwaredownloads.corsair.com...2.0.37.msi.zip

Then the headset appeared again and I was able to select them as playback and record device

Squashed 02-22-2016 03:59 PM

I have tried, this and it has unfortunately not worked. I appreciate the help however.

Looks like I'm going to have to just buy another headset unfortunately.

Walesnet 02-22-2016 08:25 PM

One last thing to try is run it again, it will remove the drivers, then reinstall them by running once more. This is the process that worked for me.

Corsair James 02-22-2016 08:31 PM

We can replace it for you under warranty if nothing else works so go ahead and put in a ticket.

Squashed 02-23-2016 02:26 PM

Sorry mate already bought a new headset.

Bicylce 02-23-2016 09:47 PM

I'm addicted to gaming and i always buy expensive gaming gear..i have Sennheiser Game ZERO and it's amazing..its little bit expensive but the experience they offer is the real thing :sunglasse

kyle6199 08-24-2016 08:50 PM

This is exactly what's wrong with mine... I purchased mine from PC world in the UK around 4 months ago i think. i have no box or receipt.... This is sudden as it was working perfectly fine last night and this morning! >:(


Anyone found a fix for this yet....

abagah 08-26-2016 12:08 PM

i would assume no. i have literally just had the same happen to me just now. the error showing

"device descriptor request failed"

given the number of people having these issues, Corsair should have recalled this product, and about now its getting close to total incompetence that this product is still being sold knowing that it is breaking for a lot of people within 3-4 months


All times are GMT -4. The time now is 10:23 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.