The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Keyboards and Mice (https://forum.corsair.com/forums/forumdisplay.php?f=214)
-   -   Unable to update firmware in Glaive (https://forum.corsair.com/forums/showthread.php?t=176476)

crainger 04-04-2018 06:27 AM

Unable to update firmware in Glaive
 
So this has me stumped.

I have a Corsair Glaive that was on 1.03, CUE 2.23.40 reported a firmware update. When running the update it failed @ 0% and the mouse would disappear from CUE. Closing and reopening CUE brought it back.

I contacted support who had me soft reset the Glaive. Then place the mouse into bootloader mode and copy 1.03 across manually and reattempt the firmware update. This didn't work either.

My friend dropped by with her PC, running CUE 2.15.83. The mouse updated to 1.04 no problems! So seems the issue might be my PC.

My PC is a 8700K, MSI Z370 Gaming 5, Win 10 with a Corsair K95 Platinum also connected. The keyboard updates no problems. Just the mouse would not.

Anyone come across something like this before?

I also tried disabling USB legacy mode
Disconnecting all other USB devices

I didn't try disabling XHCI as I believe Skylake and up needs this enabled for USB to work at all.
I also haven't tried disabling MSI fast boot, as that only affects USB devices during boot.

Other than the firmware issue, the mouse works fine. I just don't want to have a problem, down the track where a firmware update is the fix.

Corsair Mint 04-04-2018 02:20 PM

Hi crainger,

Thanks for providing all this information for your setup. Usually, if the mouse has issues with firmware update, it could involve the USB stack, sometimes moving to a different USB row helps to allow the firmware update move beyond the starting point.

Apophis3 04-04-2018 02:49 PM

Had a similar issue with my Dark Core on v0.22. Did not update on my Kaby Lake system. Used an older system with USB2.0 ports, and that worked. Once on 0.33 or later, it worked over USB3.

crainger 04-04-2018 10:56 PM

Hmmm, that might be it. My friends PC is an older z97 Broadwell system. I just plugged it into the front USB 2.0 ports.

I'll still play around a bit more. Support have given me some more settings to try, if I find something I'll be sure to post.

etaxi341 06-08-2018 02:46 PM

Gibts schon irgendwelche Lösungen dafür? Versuche meine Glaive seit Monaten zu updaten... Und jetzt muss ich eigentlich mal Updaten, da das "Doppelklick Problem" bei mir aufgetreten ist. Bin stuck auf 1.03... Updates schlagen immer fehl

Nefasto 06-27-2018 01:37 PM

1 Attachment(s)
SOLVED!

Corsair send me this:

"We would first suggest you try a soft-reset of the mouse. This will clear the mouse’s internal memory, which often corrects issues such as the one you are experiencing. Please follow the directions below:

1: Unplug the mouse.
2: Hold the left and right mouse click.
3: While holding the left and right mouse, plug in the mouse.
4: Hold the left and right mouse down for 10 seconds.
5: Release the left and right mouse.
If these steps didn't work, please follow the instructions below.

Reinstalling the firmware of your device may correct the issue. We suggest doing this manually, and have uploaded the firmware for your device to the ticket in order to do so. Please follow the directions below:

1: Unplug your mouse from the computer.
2: Locate the small pinhole underneath your mouse. For some, this will be located directly on the bottom in plain sight. On others, it will be located underneath one of the removable weights attached to the bottom of the mouse.
3: Using a small paperclip or push-pin, press down on the button inside the pinhole.
4: Plug your mouse back into the computer, while holding down the pinhole button.
5: Once it is plugged back in, your computer should recognize a drive called CRP_Disabled. Please open this.
6: Download the firmware file from the ticket. If it is compressed into a .RAR file, please extract this file to an easily found location on the computer.
7: Delete the file FIRMWARE.BIN from the CRP_DISABLED drive, and then place the file with ISP in it’s name to the CRP_Disabled drive.
8: Once you have performed the steps above, please unplug your mouse and then plug it back in. The device will then return to normal. Please test to see if the issue reappears. If it does, please inform us on the ticket for further troubleshooting."

The second solution, worked!


All times are GMT -4. The time now is 06:28 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.