The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Audio (https://forum.corsair.com/forums/forumdisplay.php?f=207)
-   -   HS1 USB on Win7 x64 - Microphone Issues (https://forum.corsair.com/forums/showthread.php?t=93976)

McMalakai 03-16-2011 01:38 AM

HS1 USB on Win7 x64 - Microphone Issues
 
So I rolled the dice on these relatively new headphones only because of CORSAIR's other support in their other product lines.

I'm in Windows 7 x64 SP1.

Unfortunately, I seem to be having the same mic issues as everyone else in this forum. In some online games, people can't hear me, and when I self-test using the game, I can barely hear myself ( Team Fortress 2). In Ventrilo ( x64 3.0.7 ) my $10 analog mic sounds perfect whereas my $98 HS1 mic is "crackly, popping, has an annoying background tone".

First, let me say, to RAM_GUY or anyone else at CORSAIR reading this, consider sending a pair of the headphones to one of the Ventrilo programmers. You might get a much lower level of feedback on what's going wrong and where.

Things I've tried to fix "it" ( more on "it" below )
  • For the Microphone device, under the Adavanced Tab, I disabled Exclusive Mode.
  • Disabled all extra Playback/Recording devices listed in the Sound control panel.
  • Disabled RealTek HD Audio via Bios
  • Killed any unknown process, and kept Antivirus disabled.
  • Went ahead and shutdown a lot of ancillary services I run ( development crap, SQL Server..etc)
  • Removed the Corsair drivers, rebooted, and went with pure MS drivers
  • Tried different "Enhancements" tab settings for the recording device ( Corsair driver only, MS driver has none ).

So, some things I've noticed:
  1. Based on the codec the application uses, people may be able to hear you "fine", they just also hear a crackle/pop and sometimes a high or low frequency tone ( see below ). Most people in online games would ignore this ( lots of crappy microphone's out there ). But if the codec is a certain type and or format, you could come out as almost completely garbled.
  2. You can alter the background "interference" tone by changing the default recording format. This is under Recording Device->Advanced Tab->Default Format. If you enable "Listen to this device" on the Listen tab ( and this hit apply ) and then go to the advanced tab, you can switch through each of the formats and hit apply to hear the effect. I found this interesting. It tells me the source of the interference is before ( or irregardless of ) Windows 7 WASPI.
  3. The encoding CODEC and Format dramatically affects whether the crack/pop/tone coming from the HS1 is exacerbated or eliminated. Using the Ventrillo "settings" page as an experimental tool, you can try combinations that can demonstrate why some people say their microphone is "fine" and others say it doesn't work ( completely garbled ).
  4. The CODEC used in voice comms for Team Fortress 2 seems to be highly susceptible to audio artifacts. What is considered a 'light' static and nominal 'buzzing' at 16bit x 48000Hz will, after the CODEC, become inaudible.
  5. Changing the microphone level ( via either driver ) results in a noticeable 'pop' for each level of the change. I'm not an electrical engineer, but this artifact worries me.
  6. Sometimes my microphone lights blink. I thought this was only when transmitting, but sometimes they'll both start blinking in unison, and keep going even after i'm done transmitting. When are these supposed to blink? This could help us track down a problem.
  7. Using Ventrilo again to monitor the mic, it will report the incoming dB level, it registers AbsZero instead of 0. If you adjust the Hardware level slider for the HS1, until you start to get '0' for monitor level, the mic is then set way to low. This is troubling. This will prevent voice activation from working properly. Also, I can only imagine what it does to CODEC's
  8. The green bars shown in the windows device property pages that related to the microphone's current 'monitoring' level ( what it hears, same thing Ventrillo gives you as dB's when you click Monitor ) does not appear to be correlated well. While taping the mic may cause a spike, simply talking into it normally rarely causes what you expect to see change. Almost like the min/max is too large, and it takes extreme quiet or extreme loud to move the meter.
  9. Trying to configure Windows speech, in which step one is Setup your Microphone, no matter what levels I choose, it keeps telling me it can't hear anything. Again, I think this is tied to numbers that describe the current monitor level.
  10. Microsofts default drivers are about 10x louder than the Corsair drivers. ( see next one )
  11. The Microphone recording 'level' slider has two different ranges for the two drivers. MS is -16dB to +11dB, Corsair is -96dB to +33dB. But the MS level is much louder when you monitor the mic. There's probably some 'base' level recorded in the registry for the USB ID someplace.

I feel like something obvious is set wrong. Some floor/ceiling number probably had a decimal shifted on it. My gut tells me this is a driver issue. Some setup of the mic is wrong. This may affect the MS driver because it polls the USB device for some min/max pickup gain value, and that number is bad.

Anyhow, it's late. When I have more time tomorrow i'll try some more experiments. I really like the feel of the mic and the sound seemed fine for what little I used them ( can't game much w/o microphone ).

fuzzywuzzy 03-17-2011 09:29 AM

I have exactly this issue myself and unfortunately both my machines are Win 7 64-bit so haven't been able to confirm it's just the OS version but a driver issue does look likely. Like you I've wasted a lot of time experimenting with various settings but to no avail.

If I shout it just about works but I didn't buy a premium headset for that. It's a shame because the ear cups (and sound from them) are great, much better than any previous headset I've had but the mic simply doesn't work as it should (at least under Win 7 64-bit).

I'll probably give it another couple of days hoping Corsair bother to respond to these posts highlighting the issue, if not I'll just buy some replacements from another manufacturer and not touch any Corsair products again.

McMalakai 03-17-2011 12:45 PM

Yeah it is a shame. Love the headphones feel. I used to use a pair of Bose Quiet Comfort headphones with a boom mic glued to the side. These are as comfortable as the Bose, and the boom mic ( if it worked ) would be in the perfect spot.

Right now I have my Logitech USB Web Cam mic as my primary comm device, and I use the Corsair headsets. It's a shame. That said, i'm amazed at the quality of the USB mic in the Logitech device. Even for a 'desktop' mic is can pic up a whisper and ignore the fan noise.

I'm still very confused on the llight colos on the inline remote. I get that Red means mic is muted. but what's the deal with the flash. Seems to be two different flash patterns.

Anyone know?

SyncError 03-18-2011 05:48 AM

I get crackling, popping, and squealing whenever the Corsair drivers are installed. Tested it on my desktop (see specs) and a laptop both running Windows 7 x64. The same thing happens. Once the Corsair drivers are installed, all the audio problems appear. The Microsoft drivers work flawlessly though. If I'm not mistaken, C-Media Electronics made the HS1 soundcard and drivers for the headset. Corsair designed the rest.

Seeing as how it doesn't seem like any driver update is planned, I'm never buying another Corsair product that requires drivers EVER again. The rest of its products are excellent though.

McMalakai 03-21-2011 03:40 PM

I can't call the MS drivers flawless ( with the HS1 ). I still get a lot of crackle/pop, and when it goes through a Ventrillo codec ( like SPEEX ) it sounds horrible.

Still useless through low quality CODEC's ( like TF2 in game voice ).

I plugged my HS1's into my gf's laptop, and had the same issues/problem. both are USB 2.0 both Win 7 x64. Maybe i'll try a duel boot to XP And see if the problem goes away.

Also, I think I'll go down to B&H and grab a USB 3.0 PCI card. My guess is it'll have no effect, but who knows....

RAM GUY 03-22-2011 05:09 PM

Hi Guys, we are looking into these reports and trying to duplicate them on our end. If anyone can duplicate the mic or headphone issues without the drivers installed and on multiple systems, then it may be a hardware issue with the HS1. In that case please Request an RMA. If it looks to be more driver related, then there is not a fix all solution at the moment, but once we can duplicate the issues we should be able to figure out whats causing them and come to a solution.

RAM GUY 03-22-2011 05:19 PM

McMalakai, the blinking lights indicate that the HS1 is not using our driver. Can you uninstall the HS1 driver and then try re-installing it from this link:

http://www.corsair.com/media/cms/drivers/HS1_Setup.zip

McMalakai 03-22-2011 05:49 PM

Quote:

Originally Posted by RAM GUY (Post 494743)
McMalakai, the blinking lights indicate that the HS1 is not using our driver. Can you uninstall the HS1 driver and then try re-installing it from this link:

http://www.corsair.com/media/cms/drivers/HS1_Setup.zip

Thanks, I sorta figured that one out. Was trying to MS drivers in testing.

I did get a new PCI USB 3.0 controller. It didn't make any appreciable difference.

HOWEVER....
I found something interesting. While trying the new USB controller, I put the Corsair drivers back on. After getting unacceptable results in my two tests ( TF2 in-game, and Ventrillo Codec: Speex 32KHz, 16 bit, 10 Q ) I decided to experiment with the "Enhancements" tab.

With the "Low Frequency Protection" enabled, and set to _ANY_ cutoff, everything "works". It's not perfect, I still get a lot of background hiss/noise, but people can understand. Also, and even better, the "Monitor" test in Ventrillo now reports integers ( instead of AbsZero, it gives a range starting from 0 ). So VOX activation can work now.

This is with nothing else change ( Advanced Tab left to defaults ). I even switched back to my normal USB ports.

BASICALLY, here's what I think is going on...

The microphone is almost too sensitive. Perhaps pure digital has a downside. The CODEC's have trouble with all the information. This "Low Frequency Protection" is eliminating part of the range of the mic, which allows these CODECs to better do their job.

I don't know if that's the case, but I can tell you the LFP allowed me to finally use my HS1's in actual competitive gaming. My mic doesn't not sound as perfect as my old analog mic, but it's close enough. I wish I could run some more filters on the mic. I think my old audio card had special filters for voice mic's to eliminate ambient noise and other extreme frequencies.

Maybe our problem is the HS1 mic is 'studio' quality, and we're used to dealing with a mics that functioned on a more limited range.

Either way, it should work better out of the box. Tweak the defaults in software, and by default enable these filters. Then provide a means to disable them for someone who wants full range ( or is dealing with a better codec ).

RAM GUY 03-22-2011 06:54 PM

Thanks for the feedback, I am going to pass this information along to one of our audio engineers.

MordecaiWalfish 04-26-2011 04:28 AM

Had the same issue earlier this year
 
I had a similar issue with a Logitech USB mic I bought in December. Windows would erratically pick up soft and loud noises randomly and it was near impossible to use voice chat without it sounding like static & robot_invasion whenever i tried talking. I tested a friend's mic over the analog in and it worked perfectly.

I finally started removing component after component from my computer until I narrowed it down to my Xbox360 controller/Arcade Stick. I did some searching on google and quickly found out that this is quite a wide-spread issue with 360 peripherals, and the root seems to be the microphone input jack on 360 controllers. (both my wired 360 controller & Real Arcade Pro VX-SA arcade stick have mic ports & both caused this problem as soon as they were hooked up at the same time as my USB mic)

The worst part about this issue is that you can't just alleviate it by unplugging the controllers; Windows had to be completely restarted to get the USB mic to stop glitching out in this manner, every time.

I then took the clean start approach and completely removed all semblance of x360 peripherals from my system, reformatted, and tried the homebrew XBCD controller drivers for them instead. I tried this because the XBCD drivers have never supported the microphone input on 360 controllers & I figured it was the mic portion of the driver that was nuking my USB mic each time.

Same result. Any time either controller was plugged in at the same time as the USB mic, it instantly crapped out. Research on le internets showed that it was quite a wide-spread issue, for USB headsets, desktop microphones & even USB sound cards.

I eventually overcame this problem by upgrading from Windows XP Pro 32bit to Windows 7 Ultimate 64bit. Turns out my USB mic, like most, uses an ancient Microsoft driver from the turn of the millennium, Logitech has never released their own driver for this (or many other) USB mic's, instead relying on Microsoft's implementation.

It's obvious that they updated this driver for windows 7, both devices have worked flawlessly together since I upgraded to it. I noticed the OP had windows 7 already but if you by chance have any 360 peripherals plugged in or have ever had one plugged in since you last restarted your PC, that is a likely candidate for the cause of the issue you're having.


Best Wishes

//M.Walfish

McMalakai 04-26-2011 04:48 PM

Thanks for the input, but no XBOX controllers have ever been plugged into any of my systems.

I've switched between the win7 drivers and the Corsair driver, neither performs to the level I expect. As it stands now, I thought I could get away with 'good enough' mic operations for Ventrillo, but people just have too tough a time hearing me, and when they up my volume I can become painful to hear on vent.

I'm looking for a nice cheap Analog Microphone that I can plug into my on board audio, i'd like one that's 'boom' like that I can glue or tap to the side of my HS1. Hopefully it's only temporary, and a magic driver update fixes all these issues.

BTW, Corsair, you may want to think about building ( or require your sub contractor to build ) a mic test application. Have it record from the HS1, change different settings, apply different codecs, and save the output as a wav. Perhaps we can use this as a benchmark/debug app to better figure out what's going wrong.

barrix 04-26-2011 07:03 PM

I can't say much. Everything is good except just a mic issue and Comforting :)

RAM GUY 04-27-2011 01:02 PM

Quote:

Originally Posted by McMalakai (Post 499850)
Thanks for the input, but no XBOX controllers have ever been plugged into any of my systems.

I've switched between the win7 drivers and the Corsair driver, neither performs to the level I expect.

If you have mic issues with both the Corsair and win7 drivers then it could be a hardware problem with the mic. If you would like, we can try replacing it for you.

Request an RMA

tehrandom 07-08-2011 12:26 AM

Quote:

Originally Posted by RAM GUY (Post 499926)
If you have mic issues with both the Corsair and win7 drivers then it could be a hardware problem with the mic. If you would like, we can try replacing it for you.

Request an RMA

I just received my HS1 back from an RMA and I am suffering the same issue. The headset seems to work fine with Mumble, but it's useless in Ventrilo, and I have to use a $3 cheapie analog mic. This is unacceptable for a "gaming" headset. I am displeased and would like Corsair to contact me about making this right. I recently re-discovered Corsair and have been impressed by their overall build quality, and would like to keep that impression, but this headset is making that hard.

RAM GUY 07-08-2011 07:38 PM

That might suggest a setting is not set correctly for the head sets, can you call our Tech support and we can try and help you with that?


All times are GMT -4. The time now is 08:01 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.