The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Audio (https://forum.corsair.com/forums/forumdisplay.php?f=207)
-   -   2100s Not working (https://forum.corsair.com/forums/showthread.php?t=136186)

Hitmehn 01-04-2015 12:28 AM

2100s Not working
 
Last night they charged and worked perfectly and i did not have a problem at all with them, but about an hour or two ago they just would not charge. I heard the beeping noise they made when they are about to die which is normal. but when i went to plug them in the flashing amber light just didn't turn green like it normally did, so i tried a few other things


-Unplugging and plugging back in
-Trying a new USB port
-Unplugging the dongle thing and plugging it back into the PC



After all this i thought i would try and just let them die and maybe after they died they would work but now they are fully dead and STILL do not work. Any help will be appriciated because i really want these to get back working. Thank you.

Toasted 01-04-2015 05:54 AM

Have you tried a different charging cable (MicroUSB)?
Have you tried wiggling the cable? Does the charging indicator turn on?

Hitmehn 01-04-2015 09:51 PM

Nope, Still no fix.

I think it may be the micro USB thing though, so tomorrow i will go buy a new one and see if it works then. if not i will have to get a replacement.


All times are GMT -4. The time now is 10:06 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.