The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Keyboards and Mice (https://forum.corsair.com/forums/forumdisplay.php?f=214)
-   -   Strafe Not Responsive (https://forum.corsair.com/forums/showthread.php?t=179942)

122jdh 08-01-2018 01:04 PM

Strafe Not Responsive
 
I have the Non-RGB Strafe, Red LED, and it has stopped working. To be exact; I booted my computer to the login page where i was able to start typing and it was already typing, I cleared the items off and it continued to do so, even after a restart. On consecutive restarts it booted into my bios on its own, so I unplugged the keyboard and plugged it back in and it stopped the random typing.

Now only the lock keys, NUM, SCROLL, CAPS, light up when i plug it in. They stay lit, even when my PC is off. No other LEDs come on. I've tried literally every port, my 4 3.0 and 2 2.0 ports on the back and the two 3.0 and 2.0 ports each on the front panel. All the ports work, tried with my external, mouse, and a second keyboard. Strangely, when I connect the pass-through cable, which i never use, I get the same occurrence. The lights always stay lit unless I flip the switch on the power supply cutting power to the entire system.

Sometimes, I flipped the switch and then the lights don't come on immediately and then start blinking when I boot. Sometimes like this, I can hit the space-bar and windows will go to the password screen, but I am unable to type literally anything.

Using a second keyboard I can login to windows. Windows does not recognize my keyboard, nor does CUE. I tried my keyboard on my laptop to see if it was just my PC and the same thing happens. Even tried it on my damn Steam Link to no avail.

mpoffo 08-01-2018 02:30 PM

It unfortunately sounds like the keyboard has seen its last days. If it were just key presses or something you could check the keys/switches to make sure they are not dirty or there is debris in there that could cause some of that behavior. Did something happen prior to this to perhaps cause this issue? A spilt drink or something?

If under warranty I would contact Corsair but I am guessing you are not under warranty.

I recently had to replace my K95 RGB (original) since some key switches were going so I sympathize.


All times are GMT -4. The time now is 09:29 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.