The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Solid State Drives (SSD)

Reply
 
Thread Tools Rating: Thread Rating: 29 votes, 5.00 average. Display Modes
  #1  
Old 04-09-2010, 04:16 PM
Stewart1 Stewart1 is offline
Registered User
Stewart1's PC Specs
 
Join Date: Jan 2010
Location: Australia
Posts: 44
POST ID # = 447120
Stewart1 Reputation: 10
Default How can I check that I am using MSAHCI?

OK, now I have an updated X128, I want to be sure that the TRIM command is being passed. fsutil shows disabledeletenotify to be 0, so that is good. But other threads make it clear that I need to be using the MSAHCI driver. How do I establish that? I've looked at the Corsair in Device Manager and this is what I get:



None of those look like msahci.sys - or should I be looking somewhere else?
Reply With Quote


Did you find this post helpful? Yes | No
  #2  
Old 04-09-2010, 04:21 PM
RAM GUY's Avatar
RAM GUY RAM GUY is offline
Corsair Product Guru
 
Join Date: Apr 2001
Location: Fremont, CA
Posts: 118,289
POST ID # = 447121
RAM GUY Reputation: 10
Default

There is a FAQ about that on Microsoft's site search for how to Check enable TRIM support in Windows 7 at www.microsoft.com/technet
Reply With Quote


Did you find this post helpful? Yes | No
  #3  
Old 04-09-2010, 04:26 PM
Stewart1 Stewart1 is offline
Registered User
Stewart1's PC Specs
 
Join Date: Jan 2010
Location: Australia
Posts: 44
POST ID # = 447125
Stewart1 Reputation: 10
Default

Thanks RG. If you mean

http://blogs.msdn.com/e7/archive/200...rives-and.aspx

I have read it and I cannot see how to tell whether I am actually using the MSAHCI Driver.

edit: doubtless because Microsoft assumes that anyone reading that is going to be some sort of ubergeek, for whom such knowledge is a given. Alas not so in my case

Last edited by Stewart1; 04-09-2010 at 04:39 PM.
Reply With Quote


Did you find this post helpful? Yes | No
  #4  
Old 04-09-2010, 04:42 PM
PrObE's Avatar
PrObE PrObE is offline
SpeedRacer
PrObE's PC Specs
 
Join Date: Feb 2010
Posts: 61
POST ID # = 447128
PrObE Reputation: 10
Default

i was wondering the same thing and by using google and "common sence" i am quite confident that i have nailed down how to confirm the MSAHCI driver is active.

By looking at what to do if you are in IDE and want to go AHCI without re-installing you need to go to go into your registry and look-up:

HKey_local_machine/system/currentcontrolset/services/msahci

and set the "start" value to "0" to have it start at the next re-boot. From this i take it that the value (0) indicates that the MSAHCI driver starts and is "active".

Would be great if someone could confirm that this is the correct way to confirm this.

I have a value of (0) but suspect Trim is not "active" even though i was able to update the FW on my X128 so i would be very interested to know.

Cheers,
Reply With Quote


Did you find this post helpful? Yes | No
  #5  
Old 04-09-2010, 04:59 PM
Stewart1 Stewart1 is offline
Registered User
Stewart1's PC Specs
 
Join Date: Jan 2010
Location: Australia
Posts: 44
POST ID # = 447130
Stewart1 Reputation: 10
Default

@PrObE

This is what my registry settings look like:



There is something called "start" which has a value of 3. What does that imply? Should I change it?
Reply With Quote


Did you find this post helpful? Yes | No
  #6  
Old 04-09-2010, 05:45 PM
RAM GUY's Avatar
RAM GUY RAM GUY is offline
Corsair Product Guru
 
Join Date: Apr 2001
Location: Fremont, CA
Posts: 118,289
POST ID # = 447137
RAM GUY Reputation: 10
Default

There is an awesome Blog about SSD's in general on MSDN that is good reading to help understand the basics.

Quote:
Quote:
How to enable TRIM Command in Windows 7 with a Solid State Drive

To enable or disable TRIM Command, you will need to open an Elevated Command Prompt window.

How To Open an Elevated Command Prompt window: Click on Start Orb > Type "CMD.exe" in Search box > Right click on "CMD" and select "Run as Administrator" (If you receive a prompt confirmation, click YES)

How to Enable TRIM Command

In the Elevated command Prompt windows, type the following:

fsutil behavior set disabledeletenotify 0

How to Disable TRIM Command

In the Elevated command Prompt windows, type the following:

fsutil behavior set disabledeletenotify 1

How do I know if TRIM is working in Windows 7?

In the Elevated command Prompt windows, type the following:

fsutil behavior query disabledeletenotify
Results explained below:
DisableDeleteNotify = 1 (Windows TRIM commands are disabled)
DisableDeleteNotify = 0 (Windows TRIM commands are enabled)


How to enable AHCI in Windows 7 after Instalation:

There is one way to fix this, although you need to have knowledge of registry editing. The detailed steps from Microsoft are as follows:

1.Exit all Windows-based programs.
2.Click Start, type regedit in the Start Search box, and then press ENTER.
3.If you receive the User Account Control dialog box, click Continue.
4.Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINESystemCurrentControlSetServicesMsahci
5.In the right pane, right-click Start in the Name column, and then click Modify.
6.In the Value data box, type 0, and then click OK.
7.On the File menu, click Exit to close Registry Editor.

After this you’ll have to restart your computer, go to BIOS and enable AHCI. When you log in to Windows again, you’ll notice the installation of drivers for AHCI. Another restart will be required to finish the driver installation.

These steps are provided at your own risk and not suggested unless you know and understand the risks. You will want to make sure the controller driver and MB BIOS support this option before you enable it
Reply With Quote


Did you find this post helpful? Yes | No
  #7  
Old 04-09-2010, 05:56 PM
Stewart1 Stewart1 is offline
Registered User
Stewart1's PC Specs
 
Join Date: Jan 2010
Location: Australia
Posts: 44
POST ID # = 447141
Stewart1 Reputation: 10
Default

OK, thanks, and please bear with me here, because I am still a bit confused.

I am happy with being in IDE mode. But the implication o THIS, from the TRIM FAQ on this forum:

Quote:
- Microsoft Storage Driver (MSAHCI / working for IDE and AHCI mode)
is that I need to go through the MSAHCI enabling, ie changing the "Start" value to 0, even to allow the TRIM command to be passed to the drive in IDE mode. Is that correct?

Thanks for your patience.
Reply With Quote


Did you find this post helpful? Yes | No
  #8  
Old 04-09-2010, 06:00 PM
RAM GUY's Avatar
RAM GUY RAM GUY is offline
Corsair Product Guru
 
Join Date: Apr 2001
Location: Fremont, CA
Posts: 118,289
POST ID # = 447144
RAM GUY Reputation: 10
Default

You can check if TRIM is active with the steps I just posted. They (Microsoft) suggest AHCI mode as would I but It is solely up to the driver to pass the command no matter if its IDE or AHCI Mode, assuming of course that TRIM enabled Firmware is installed and you are using Windows 7 on a supported controller.
Reply With Quote


Did you find this post helpful? Yes | No
  #9  
Old 04-09-2010, 06:11 PM
Stewart1 Stewart1 is offline
Registered User
Stewart1's PC Specs
 
Join Date: Jan 2010
Location: Australia
Posts: 44
POST ID # = 447148
Stewart1 Reputation: 10
Default

I think you are saying that I have to edit the registry to start the MSAHCI driver, even if all I want it to do is pass the TRIM command to the drive in IDE mode.

So that is what I will try.

edit: OK, I've done it. msahci.sys still does not appear as a driver when I inspect the drive using Device Manager, but perhaps that's looking at something else. If I understand everything correctly, having checked disabledeletenotify=0 and msahci start=0, there is nothing else I can do, other than wait and observe the performance of the drive.

Last edited by Stewart1; 04-09-2010 at 06:34 PM.
Reply With Quote


Did you find this post helpful? Yes | No
  #10  
Old 04-09-2010, 06:46 PM
RAM GUY's Avatar
RAM GUY RAM GUY is offline
Corsair Product Guru
 
Join Date: Apr 2001
Location: Fremont, CA
Posts: 118,289
POST ID # = 447152
RAM GUY Reputation: 10
Default

Quote:
I think you are saying that I have to edit the registry to start the MSAHCI driver, even if all I want it to do is pass the TRIM command to the drive in IDE mode.
No I am suggesting that you check for TRIM support if it shows active then you should leave it alone unless of course you just want to use AHCI, then yes you have to edit the registry and enable it then reboot and enable it in BIOS.

So before you make that change you should make sure that you have that option in the BIOS and that you have the latest driver that support AHCI Mode.
Then you can go through the steps to enable it if you choose to.
Quote:
edit: OK, I've done it. msahci.sys still does not appear as a driver when I inspect the drive using Device Manager, but perhaps that's looking at something else. If I understand everything correctly, having checked disabledeletenotify=0 and msahci start=0, there is nothing else I can do, other than wait and observe the performance of the drive.
Edit to the Edit
You should be set and AHCI is a mode not a Hard ware driver so you will not see a driver listed in device manager other than the Microsoft MSAHCI.SYS which loads as a service or driver as Windows boots.

Last edited by RAM GUY; 04-09-2010 at 06:49 PM.
Reply With Quote


Did you find this post helpful? Yes | No
  #11  
Old 04-09-2010, 07:11 PM
Stewart1 Stewart1 is offline
Registered User
Stewart1's PC Specs
 
Join Date: Jan 2010
Location: Australia
Posts: 44
POST ID # = 447158
Stewart1 Reputation: 10
Default

I appreciate your patience Ram Guy.

So if you want to use TRIM in IDE mode, ALL YOU NEED TO DO is check that disabledeletenotify=0, is that right?

Despite this:
Quote:
- Microsoft Storage Driver (MSAHCI / working for IDE and AHCI mode)
Reply With Quote


Did you find this post helpful? Yes | No
  #12  
Old 04-10-2010, 12:53 AM
oldbrave oldbrave is offline
Medicine Man
oldbrave's PC Specs
 
Join Date: Jan 2010
Location: Sacramento, CA
Posts: 45
POST ID # = 447184
oldbrave Reputation: 10
Default

Look in the device manager under"IDE ATA/ATAPI controllers"
If you have the MSAHCI installed then there will be a entry
"Standard AHCI 1.0 Serial Controller"
Reply With Quote


Did you find this post helpful? Yes | No
  #13  
Old 04-10-2010, 01:22 AM
Stewart1 Stewart1 is offline
Registered User
Stewart1's PC Specs
 
Join Date: Jan 2010
Location: Australia
Posts: 44
POST ID # = 447187
Stewart1 Reputation: 10
Default

Quote:
Originally Posted by oldbrave View Post
Look in the device manager under"IDE ATA/ATAPI controllers"
If you have the MSAHCI installed then there will be a entry
"Standard AHCI 1.0 Serial Controller"
I don't. What I have is "ATA Channel 0" (x5), "ATA Channel 1" (x5) and "Standard Dual Channel PCI IDE Controller" (x5).

But as I have said, I was not seeking to turn on AHCI, and have not changed the mode from IDE in the BIOS. All I want is to ensure that the TRIM commands are being passed to the SSD.
Reply With Quote


Did you find this post helpful? Yes | No
  #14  
Old 04-10-2010, 06:40 AM
Stewart1 Stewart1 is offline
Registered User
Stewart1's PC Specs
 
Join Date: Jan 2010
Location: Australia
Posts: 44
POST ID # = 447208
Stewart1 Reputation: 10
Default

Update: I give up. Have gone into BIOS and enabled AHCI. "Standard AHCI 1.0 Serial Controller" now appears in Device Manager.
Reply With Quote


Did you find this post helpful? Yes | No
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.