The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Power Supplies

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 06-07-2018, 08:53 PM
Jolly Abbo Jolly Abbo is offline
Registered User
 
Join Date: Jun 2018
Posts: 1
POST ID # = 958119
Jolly Abbo Reputation: 10
Default Corsair TX550M buzzing issue

My PSU has always been fine, but it just randomly started buzzing today, I unplugged everything from it, and upon plugging the power back into the PSU I hear an electrical clicking sound (almost like you're plugging something into something you shouldn't).

after that, I still continue to get a light buzzing noise, but not as loud as it was previously. Should I be concerned about this, request an RMA from corsair, or just soldier on?

Thank you!
Reply With Quote


  #2  
Old 06-08-2018, 12:27 PM
Corsair Hotpot Corsair Hotpot is offline
Corsair Employee
Corsair Hotpot's PC Specs
 
Join Date: May 2017
Posts: 308
POST ID # = 958198
Corsair Hotpot Reputation: 10
Default

Hey Jolly,

I'd recommend contacting our support team and request for an RMA.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.