The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Power Supplies

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 01-13-2013, 10:37 AM
jt143 jt143 is offline
Registered User
jt143's PC Specs
 
Join Date: Jan 2013
Posts: 1
POST ID # = 626014
jt143 Reputation: 10
Default Can I please have some advice (HX650w)

For Christmas I have received a C70 case with 16gb (2x8) of Vengeance ram Intel i5 3570k, Asus z77 Sabertooth motherboard. As a surprise he got me Corsair force 3,h100i,sp120 and windows 7 64bit. out of his money that he saved from his last job. Since this build is a experience for my dad and I. he offered let me use his power supply replacing his HX650w to a CX430 because he doesnt need the extra power that I do.

When we were swapping them I couldn't stop noticing this yellow block has fused with a black block I don't know if this is meant to happen.



Thank you for your consideration and I hope too hear your response.

-Jake
Reply With Quote


  #2  
Old 01-13-2013, 12:12 PM
peanutz94's Avatar
peanutz94 peanutz94 is offline
Support Assistant
peanutz94's PC Specs
 
Join Date: Feb 2011
Location: Akron,Ohio
Posts: 9,740
POST ID # = 626040
peanutz94 Reputation: 84
Default

Cant rally see what your looking at . Can you get a better picture from right above it?
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.