The Corsair User Forums  

Go Back   The Corsair User Forums > Customer Service > Warranty and RMA Questions

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 08-24-2018, 02:58 AM
FPSTim FPSTim is offline
Registered User
FPSTim's PC Specs
 
Join Date: Aug 2018
Posts: 0
POST ID # = 969962
FPSTim Reputation: 10
Default Support Ticket RMA not showing up on site

I am trying to get to my support ticket on the support site but the site does not load for me. It shows a blank page with a loading bar that wants to go all the way but stops about 75% of the way. What can I do? I have tried to load the webpage ticket on another computer, 3 different browsers and even on my phone, both with WiFi on and using 4GLte. Nothing has worked so far.
Attached Images
File Type: jpg Corsair Suppoer Page Blank Loading With Black Bar.jpg (35.2 KB, 141 views)

Last edited by FPSTim; 08-24-2018 at 03:01 AM.
Reply With Quote
  #2  
Old 08-26-2018, 04:24 PM
FPSTim FPSTim is offline
Registered User
FPSTim's PC Specs
 
Join Date: Aug 2018
Posts: 0
POST ID # = 970313
FPSTim Reputation: 10
Default

It has been a couple of days and this issue is still not fixed. My issue persists is what I am saying.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.