The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 10-07-2018, 01:17 PM
KoGiK KoGiK is offline
Registered User
 
Join Date: Oct 2018
Posts: 2
POST ID # = 975453
KoGiK Reputation: 10
Default My HS70 doesn't work after updating 0.64

I just bought HS70 today about 12.00pm from Thai shop, and i connected it to mu pc that made me felt it has a quiet mic volume, so i tried to fix it out by updating firmware via iCUE to version 0.64(at first time i was failed to update and i tried to force updating it till it complete.

Now my HS70 doesn't work, it cannot be switched on. The light indicator also does't work or show up any light.

I tried to reset it on its dongle by pressing reset button 5 seconds and then connected my hs70 with usb cable and pressed it till i haven't seen light on my dongle stay solid and stop blinking.

Now i'm so sad, i don't know how to reaolve it. Please help me.
Thank you very much and pls forgive my broken english
Reply With Quote


  #2  
Old 10-08-2018, 01:59 PM
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 857
POST ID # = 975581
Corsair Nick Reputation: 39
Default

The headset might be in bootloader mode. Try performing the following and see if this brings the headset back:

1) Volume control in min position
2) Hold the mute button while plugging in USB cable with the headset off
3) Release mute button 3 seconds after the USB cable is plugged in
Reply With Quote


  #3  
Old 10-09-2018, 01:21 AM
KoGiK KoGiK is offline
Registered User
 
Join Date: Oct 2018
Posts: 2
POST ID # = 975640
KoGiK Reputation: 10
Default

I did it but still nothing happens. ��
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.