The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > iCUE Software

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #16  
Old 07-26-2018, 04:53 PM
xxric1993xx xxric1993xx is offline
Registered User
xxric1993xx's PC Specs
 
Join Date: Jul 2018
Location: Bavaria, Germany
Posts: 17
POST ID # = 965706
xxric1993xx Reputation: 10
Default

I already replied to that ticket, lets see what they respond tomorrow...

This is a real gamebreaker, though I am damn amazed from the K95 keyboard. But the MM800 gets more and more a pain in the ***. And my future plans, building a new pc with all corsair stuff, tower, fans etc. to match the RGB lighting, are growing smaller day by day I have problems with the MM800...
Reply With Quote
  #17  
Old 07-26-2018, 05:00 PM
Corsair James's Avatar
Corsair James Corsair James is offline
iCUE Product Manager
 
Join Date: Oct 2013
Location: Fremont, CA
Posts: 4,384
POST ID # = 965709
Corsair James Reputation: 71
Default

The mousepad isn't bricked. There is a way to bring back operation. Under the mousepad, there is a pinhole. Use a paperclip and depress the pinhole while simultaneously plugging in the USB cable. If successful, you'll see the device show up as a flash drive named CRP_DISABLED. Delete the bin file you see in it and copy into it what I attached instead. This will update the firmware and bring the device back from its bootloader state.

As for your USB issues, attach me the logs from iCUE (settings -> export logs) and we can try to see why its happening.
Attached Files
File Type: zip MM800 FW v0.03.24_App_v1.02.50.bin.zip (8.0 KB, 54 views)
__________________

iCUE - A CORSAIR Interface
https://www.corsair.com/us/en/icue

Last edited by Corsair James; 07-26-2018 at 05:09 PM.
Reply With Quote
  #18  
Old 07-26-2018, 05:03 PM
XRayAdamo XRayAdamo is offline
Registered User
XRayAdamo's PC Specs
 
Join Date: Jun 2018
Posts: 21
POST ID # = 965712
XRayAdamo Reputation: 10
Default

I've checked my logs, nothing interesting there. My problem a little different from others, but still related to the iCUE software. I do not know what happened and when exactly
Reply With Quote
  #19  
Old 07-26-2018, 05:06 PM
xxric1993xx xxric1993xx is offline
Registered User
xxric1993xx's PC Specs
 
Join Date: Jul 2018
Location: Bavaria, Germany
Posts: 17
POST ID # = 965713
xxric1993xx Reputation: 10
Default

Quote:
Originally Posted by Corsair James View Post
The mousepad isn't bricked. There is a way to bring back operation. Under the mousepad, there is a pinhole. Use a paperclip and depress the pinhole while simultaneously plugging in the USB cable. If successful, you'll see the device show up as a flash drive named CRP_DISABLED. Delete the bin file you see in it and copy into it what I attached instead. This will update the firmware and bring the device back from its bootloader state.

As for your USB issues, attach me the logs from iCUE (settings -> export logs) and we can try to see why its happening.
Well, you're right, i pressed the pin, replugged it and it opend the flash drive as mentioned.
But sadly you forgot to attach something to your answer? Or I am just to dumb to see it... Getting kinda euphorious, that there may be a soon solution...
Reply With Quote
  #20  
Old 07-26-2018, 05:10 PM
Corsair James's Avatar
Corsair James Corsair James is offline
iCUE Product Manager
 
Join Date: Oct 2013
Location: Fremont, CA
Posts: 4,384
POST ID # = 965714
Corsair James Reputation: 71
Default

Quote:
Originally Posted by xxric1993xx View Post
Well, you're right, i pressed the pin, replugged it and it opend the flash drive as mentioned.
But sadly you forgot to attach something to your answer? Or I am just to dumb to see it... Getting kinda euphorious, that there may be a soon solution...
Sorry the attachment didn't upload properly. It is there now.
__________________

iCUE - A CORSAIR Interface
https://www.corsair.com/us/en/icue
Reply With Quote
  #21  
Old 07-26-2018, 05:15 PM
XRayAdamo XRayAdamo is offline
Registered User
XRayAdamo's PC Specs
 
Join Date: Jun 2018
Posts: 21
POST ID # = 965718
XRayAdamo Reputation: 10
Default

Quote:
Originally Posted by xxric1993xx View Post
Well, you're right, i pressed the pin, replugged it and it opend the flash drive as mentioned.
But sadly you forgot to attach something to your answer? Or I am just to dumb to see it... Getting kinda euphorious, that there may be a soon solution...
Do not forget to tell us if this will fix your problem.
Reply With Quote
  #22  
Old 07-26-2018, 05:18 PM
xxric1993xx xxric1993xx is offline
Registered User
xxric1993xx's PC Specs
 
Join Date: Jul 2018
Location: Bavaria, Germany
Posts: 17
POST ID # = 965720
xxric1993xx Reputation: 10
Default

Quote:
Originally Posted by Corsair James View Post
Sorry the attachment didn't upload properly. It is there now.

Thank you very much! That brought the MM800 back to life. And since i did thatthe profile color scheme is working! Longer than usual =)

I will keep track of its state, and as soon as theres the rainbow spiral bug again, or not working properly with iCue i will add the logs.
But i really hope that wont be needed...

Thanks!

Quote:
Originally Posted by XRayAdamo View Post
Do not forget to tell us if this will fix your problem.
I won't! I'm amazed now, that it still works :D
Reply With Quote
  #23  
Old 07-26-2018, 05:32 PM
XRayAdamo XRayAdamo is offline
Registered User
XRayAdamo's PC Specs
 
Join Date: Jun 2018
Posts: 21
POST ID # = 965721
XRayAdamo Reputation: 10
Thumbs up

Quote:
Originally Posted by xxric1993xx View Post
Thank you very much! That brought the MM800 back to life. And since i did thatthe profile color scheme is working! Longer than usual =)

I will keep track of its state, and as soon as theres the rainbow spiral bug again, or not working properly with iCue i will add the logs.
But i really hope that wont be needed...

Thanks!


I won't! I'm amazed now, that it still works :D
That's good. I did not know that you can resurrect MM800 like that after firmware failure.
Thank you Corsair! :)
Reply With Quote
  #24  
Old 07-26-2018, 05:44 PM
xxric1993xx xxric1993xx is offline
Registered User
xxric1993xx's PC Specs
 
Join Date: Jul 2018
Location: Bavaria, Germany
Posts: 17
POST ID # = 965722
xxric1993xx Reputation: 10
Default

Well, that good mood lasted not long, but longer than usual. Now its back to rainbow spiral.

I attached the logs from iCue. The MM800 is recognized in iCue, but doesnt react to any iCue commands...

Edit: just checked the logs myself, and there a tons of errors concerning the MM800 in the logs. Here's just a small sample :D


Quote:
2018-07-26T23:41:07 I cue.dev: MouseMat LED colors change failed. request timed out for MM800RGB
2018-07-26T23:41:07 I cue.dev: MouseMat LED colors change failed. Device: MM800RGB, Execution result = 0, result = 0, platform error code = 995.
2018-07-26T23:41:12 I cue.dev: MouseMat LED colors change failed. request timed out for MM800RGB
2018-07-26T23:41:12 I cue.dev: MouseMat LED colors change failed. Device: MM800RGB, Execution result = 0, result = 0, platform error code = 995.
2018-07-26T23:41:12 W MainWindow_QMLTYPE_571(0x296c3e58) must be a top level window.
2018-07-26T23:41:12 W MainWindow_QMLTYPE_571(0x296c3e58) must be a top level window.
2018-07-26T23:41:12 W file:///C:/Program Files (x86)/Corsair/CORSAIR iCUE Software/QtQuick/Dialogs/DefaultFileDialog.qml:210:25: QML ListView: Binding loop detected for property "model"
2018-07-26T23:41:13 W libpng warning: iCCP: known incorrect sRGB profile
2018-07-26T23:41:13 W qrc:/qml/ui/DevicesPanel.qml:71:12: QML Loader: Binding loop detected for property "asynchronous"
2018-07-26T23:41:14 W qrc:/qml/ui/DevicesPanel.qml:94:4: QML Binding: Binding loop detected for property "value"
2018-07-26T23:41:14 W qrc:/qml/ui/DevicesPanel.qml:94:4: QML Binding: Binding loop detected for property "value"
2018-07-26T23:41:14 I cue.init.ui: Starting UI.
2018-07-26T23:41:18 W qrc:/qml/ui/DevicesPanel.qml:71:12: QML Loader: Binding loop detected for property "sourceComponent"
2018-07-26T23:41:18 W libpng warning: iCCP: known incorrect sRGB profile
2018-07-26T23:41:18 W libpng warning: iCCP: known incorrect sRGB profile
Attached Files
File Type: zip iCue Logs.zip (4.87 MB, 19 views)

Last edited by xxric1993xx; 07-26-2018 at 05:48 PM.
Reply With Quote
  #25  
Old 07-26-2018, 08:35 PM
Corsair James's Avatar
Corsair James Corsair James is offline
iCUE Product Manager
 
Join Date: Oct 2013
Location: Fremont, CA
Posts: 4,384
POST ID # = 965756
Corsair James Reputation: 71
Default

Quote:
Originally Posted by xxric1993xx View Post
Well, that good mood lasted not long, but longer than usual. Now its back to rainbow spiral.

I attached the logs from iCue. The MM800 is recognized in iCue, but doesnt react to any iCue commands...

Edit: just checked the logs myself, and there a tons of errors concerning the MM800 in the logs. Here's just a small sample :D
Thanks, I'll get these logs over for inspection.
__________________

iCUE - A CORSAIR Interface
https://www.corsair.com/us/en/icue
Reply With Quote
  #26  
Old 07-26-2018, 11:34 PM
XRayAdamo XRayAdamo is offline
Registered User
XRayAdamo's PC Specs
 
Join Date: Jun 2018
Posts: 21
POST ID # = 965769
XRayAdamo Reputation: 10
Default

Attaching my logs to
Same errors, but different behavior.
Let me remoind.

When I start PC and as soon as iCUE loads, MM800 turns solid RED and nothing can change it.
Only way to reset it is to turn off/on SDK support in iCUE
Attached Files
File Type: zip 111.zip (802.6 KB, 19 views)
Reply With Quote
  #27  
Old 07-31-2018, 03:49 PM
xxric1993xx xxric1993xx is offline
Registered User
xxric1993xx's PC Specs
 
Join Date: Jul 2018
Location: Bavaria, Germany
Posts: 17
POST ID # = 966442
xxric1993xx Reputation: 10
Default

@corsair James: How long do you think it takes to get an answer from the log analyses?
Reply With Quote
  #28  
Old 08-03-2018, 11:22 PM
XRayAdamo XRayAdamo is offline
Registered User
XRayAdamo's PC Specs
 
Join Date: Jun 2018
Posts: 21
POST ID # = 966993
XRayAdamo Reputation: 10
Default

My problem has been fixed.
I was stupid! It was MSI mystic light app that set MM800 to red! Oh my god! :(
Reply With Quote
  #29  
Old 08-04-2018, 02:54 AM
XRayAdamo XRayAdamo is offline
Registered User
XRayAdamo's PC Specs
 
Join Date: Jun 2018
Posts: 21
POST ID # = 967009
XRayAdamo Reputation: 10
Default

Update.
MSI Mystic Light does not have an option to not touch MM800. So no matter what you are doing it still affect mouse pad :(

So here is a solution. Tested on my PC.

Do these steps:
1. Exit mystic lights and kill LEDKeeper.exe from Task manager
2. Navigate to C:\Program Files (x86)\MSI\MysticLight\Lib. If you installed it on other drive, change C: to your drive
3. find SDKDLL.dll file and rename it to 1SDKDLL.dll
4. Restart.

After that you still can control MoBo lights, but controlling MM800 won't work anymore. Not a big deal since iCUE provides much better control over LEDs.

Last edited by XRayAdamo; 08-04-2018 at 02:57 AM.
Reply With Quote
  #30  
Old 08-05-2018, 01:51 AM
XRayAdamo XRayAdamo is offline
Registered User
XRayAdamo's PC Specs
 
Join Date: Jun 2018
Posts: 21
POST ID # = 967115
XRayAdamo Reputation: 10
Default

Do not do what I proposed.
It looks that dll is actually for any RGB light
I will post an update when I will be able to get rid of iCUE integration from Mystic light
Reply With Quote
Reply

Tags
corsair, icue, k95, mm800, mousepad

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.