The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 12-02-2013, 08:21 PM
Dunkyoo Dunkyoo is offline
Registered User
Dunkyoo's PC Specs
 
Join Date: May 2012
Posts: 13
POST ID # = 685468
Dunkyoo Reputation: 10
Default K95 volume scroll wheel not working

Hey guys,

After an RMA of my K90 I got the new K95 model!! Thanks a million for that Corsair!!

First I uninstalled the K90 software and then installed the K95 firmware and last the K95 software. Everything was working just fine but after a restart the volume wheel does nothing at all. I re-installed the software of the K95 (it first uninstalls the current software automatically) and the wheel worked again. After another restart it stops working again.

What to do?

Windows 8 64 bit (not 8.1)

Just changed my system specs by the way.
Reply With Quote


  #2  
Old 12-03-2013, 03:00 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,350
POST ID # = 685507
Toasted Toasted Reputation: 108
Default

Do the media keys work fine?
If no, try this
http://forum.corsair.com/v3/showthread.php?t=113001
Have you tried flashing the keyboard to the latest firmware?
Reply With Quote


  #3  
Old 12-03-2013, 02:51 PM
Dunkyoo Dunkyoo is offline
Registered User
Dunkyoo's PC Specs
 
Join Date: May 2012
Posts: 13
POST ID # = 685589
Dunkyoo Reputation: 10
Default

Today it did work when I started my pc but I checked HID services nevertheless and it didn't start automatically. It started manually so I changed it to automatically.

I guess this solves the problem. Thanks Toasted.

Ps; I did the firmware flash (first post)
Reply With Quote


  #4  
Old 04-11-2015, 06:01 AM
Random User Random User is offline
Registered User
 
Join Date: Mar 2015
Posts: 5
POST ID # = 772024
Random User Reputation: 10
Default Secondary Fix For Hotkeys

I found this forum just recently and I tried enabling the HID services which can be accessed through simply typing services into the search option where the windows icon is Human Interface Device Access right click on that and set it to automatic. If that does not work Download the VLC media player below.

http://www.videolan.org/vlc/index.html

and install this
Once you have done that go to Tools>Preferences>Hotkeys and untick Ignore keyboard volume buttons.
Rebind your media keys to the global column

And there you go all fixed enjoy the keyboard

Last edited by Random User; 04-11-2015 at 06:50 AM.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.