The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 06-10-2017, 12:09 PM
cxmachi cxmachi is offline
Registered User
 
Join Date: Jun 2017
Posts: 11
POST ID # = 907445
cxmachi Reputation: 10
Angry Steam and anything that polls USB devices crashes because of K70 RGB Lux

I am having an issue that is most definitely an issue with the K70 Lux RGB and how it interacts with the USB ports on this PC.

Whenever I plug in a USB device (be it a controller, a secondary mouse), Steam will freeze. The caps lock and num lock indicator on the keyboard will also not work anymore.

As soon as I set the polling switch on the keyboard to BIOS, then Steam unfreezes. When I set it back to

This is most definitely an issue with the keyboard as I have not had any of these issues prior to owning this keyboard. While you can say that it might be a compatibility issue with Steam, that's not really acceptable considering a gaming keyboard should at the very LEAST be working with Steam.

I've tried changing between USB ports, from USB 2.0 to 3.0 and back. Tried updating all the drivers and it's still the same issue. I've looked all over these forums and there is definitely quite a few of us experiencing the same issue.

Steps to Reproduce:
1. Start computer.
2. Notice that CUE has loaded up since my lights are showing RGB effects
3. Plug in a USB device like a controller or another mouse
4. Notice that Steam freezes and is unusable. ALSO notice that if you press Caps Lock or Numlock, the lights will not light up, no matter what you do.
5. Set polling switch to BIOS
6. Steam now unfreezes and is usable.
7. Set polling back to default. Caps lock and Numlock also now works again.
8. You can now unplug and replug USB devices without issue, but this only lasts for maybe 1 or 2 replugs. You have to go back to Step 1 again.

I don't want to have to do this workaround every single time. Note, I also just tested this and you can replace Steam with the Windows USB Game Controller screen. This keyboard is definitely causing USB conflicts and it's not just me.

Relevant specs:
Motherboard - Asus Maximus IX Hero
Keyboard - Corsair K70 RGB Lux

Attaching CUE log files as well
Attached Files
File Type: zip 2017-06-10T11-48-37 - Copy.zip (1.7 KB, 143 views)

Last edited by cxmachi; 06-10-2017 at 12:16 PM.
Reply With Quote


  #2  
Old 06-12-2017, 06:30 PM
ZeroFatal1ty ZeroFatal1ty is offline
Registered User
ZeroFatal1ty's PC Specs
 
Join Date: Jun 2017
Posts: 1
POST ID # = 907730
ZeroFatal1ty Reputation: 10
Default

Quote:
Originally Posted by cxmachi View Post
I am having an issue that is most definitely an issue with the K70 Lux RGB and how it interacts with the USB ports on this PC.

Whenever I plug in a USB device (be it a controller, a secondary mouse), Steam will freeze. The caps lock and num lock indicator on the keyboard will also not work anymore.

As soon as I set the polling switch on the keyboard to BIOS, then Steam unfreezes. When I set it back to

This is most definitely an issue with the keyboard as I have not had any of these issues prior to owning this keyboard. While you can say that it might be a compatibility issue with Steam, that's not really acceptable considering a gaming keyboard should at the very LEAST be working with Steam.

I've tried changing between USB ports, from USB 2.0 to 3.0 and back. Tried updating all the drivers and it's still the same issue. I've looked all over these forums and there is definitely quite a few of us experiencing the same issue.

Steps to Reproduce:
1. Start computer.
2. Notice that CUE has loaded up since my lights are showing RGB effects
3. Plug in a USB device like a controller or another mouse
4. Notice that Steam freezes and is unusable. ALSO notice that if you press Caps Lock or Numlock, the lights will not light up, no matter what you do.
5. Set polling switch to BIOS
6. Steam now unfreezes and is usable.
7. Set polling back to default. Caps lock and Numlock also now works again.
8. You can now unplug and replug USB devices without issue, but this only lasts for maybe 1 or 2 replugs. You have to go back to Step 1 again.

I don't want to have to do this workaround every single time. Note, I also just tested this and you can replace Steam with the Windows USB Game Controller screen. This keyboard is definitely causing USB conflicts and it's not just me.

Relevant specs:
Motherboard - Asus Maximus IX Hero
Keyboard - Corsair K70 RGB Lux

Attaching CUE log files as well


cxmachi, you are not alone.

I'm having the exact same issue with the same K70 RGB LUX and Maximus IX Formula. Sounds like a USB handling exception.

I already submitted a support ticket, so to spare the details I'll paste it here.... Lemme know if this is spot on.



Ticket Description:

Cue 2 and my K70 RGB LUX has issues when opening Steam and launching games (from other clients too). When Steam hangs, I can flip the polling-rate switch and it stops hanging. Steam, Need for speed 2015, Mass Effect Andromeda, Watchdogs, The Division, DOOM, Ghost Recon Wildlands, and others all hang on launch and close due to this issue. Hang time, appcrash, and timeout can last 30 seconds to 2 minutes.

This issue doesn't occur with K70 unplugged OR Cue 2 uninstalled. Everything loads instantaneously.

Steam and others function fine with another keyboard and Cue and the K70 performs fine without Cue installed.

This was with a clean OS, clean steam install, and clean CUE install with just drivers. All were latest versions, including motherboard BIOS. I've tried many USB configurations.

The problem seems to occur when CUE installs the "Virtual USB composite device" and "Corsair BUS." Then the keyboard has trouble with Steam/others.

I also have the Glaive, VOID Wireless, and Polaris mouse pad.

This link -> http://forum.corsair.com/v3/showthread.php?t=168442 - describes the problem identically.

Specs: Asus Maximus IX Formula, Intel i7 7700K, Corsair Vengeance RGB 32GB 3466Mhz, ASUS GTX1080ti OC, Samsung 960 Pro 1TB NMVe, Corsair HX1000i PSU.

BIOS Settings are all AUTO except CSM disabled. Legacy USB set to AUTO



Sound Familiar?
Reply With Quote


  #3  
Old 06-13-2017, 08:36 PM
cxmachi cxmachi is offline
Registered User
 
Join Date: Jun 2017
Posts: 11
POST ID # = 907886
cxmachi Reputation: 10
Default

That is definitely spot on. I noticed that when I completely uninstalled CUE, it removed the Corsair Composite Virtual Input Device driver in Device Manager.

I NO LONGER experience the issue once that was uninstalled. However, now I'm stuck with an RGB keyboard where I can't customize the lights or have any dynamic effects which completely defeats the purpose. Please, please, please find a way to reproduce and fix this Corsair.
Reply With Quote


  #4  
Old 06-15-2017, 05:41 PM
CCFAN's Avatar
CCFAN CCFAN is offline
Registered User
CCFAN's PC Specs
 
Join Date: May 2017
Posts: 21
POST ID # = 908174
CCFAN Reputation: 10
Question

Quote:
Originally Posted by ZeroFatal1ty View Post
cxmachi, you are not alone.

I'm having the exact same issue with the same K70 RGB LUX and Maximus IX Formula. Sounds like a USB handling exception.

I already submitted a support ticket, so to spare the details I'll paste it here.... Lemme know if this is spot on.



Ticket Description:

Cue 2 and my K70 RGB LUX has issues when opening Steam and launching games (from other clients too). When Steam hangs, I can flip the polling-rate switch and it stops hanging. Steam, Need for speed 2015, Mass Effect Andromeda, Watchdogs, The Division, DOOM, Ghost Recon Wildlands, and others all hang on launch and close due to this issue. Hang time, appcrash, and timeout can last 30 seconds to 2 minutes.

This issue doesn't occur with K70 unplugged OR Cue 2 uninstalled. Everything loads instantaneously.

Steam and others function fine with another keyboard and Cue and the K70 performs fine without Cue installed.

This was with a clean OS, clean steam install, and clean CUE install with just drivers. All were latest versions, including motherboard BIOS. I've tried many USB configurations.

The problem seems to occur when CUE installs the "Virtual USB composite device" and "Corsair BUS." Then the keyboard has trouble with Steam/others.

I also have the Glaive, VOID Wireless, and Polaris mouse pad.

This link -> http://forum.corsair.com/v3/showthread.php?t=168442 - describes the problem identically.

Specs: Asus Maximus IX Formula, Intel i7 7700K, Corsair Vengeance RGB 32GB 3466Mhz, ASUS GTX1080ti OC, Samsung 960 Pro 1TB NMVe, Corsair HX1000i PSU.

BIOS Settings are all AUTO except CSM disabled. Legacy USB set to AUTO



Sound Familiar?
Does it happen on K70 series keyboards only?

I'm planning to buy a K70 LUX RGB but now the plan is delayed after hearing so much similar reports.

I have an M65 Pro RGB mouse working and the CUE works normally; your problem does not occur on my laptop and mouse currently.

If it is only caused by the K70 keyboard, I would not buy it. And I also heard about the LED noise of K70. Bad news.
Reply With Quote


  #5  
Old 06-17-2017, 08:18 AM
c-attack c-attack is offline
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 6,796
POST ID # = 908356
c-attack Reputation: 96
Default

No, I have a K70 LUX rapidfire, a K95P, 1 M65 RGB laster, 1 M65 RGB Pro, and 1 Glaive and have never experienced this with Steam or anything else. Obviously they are experiencing some type of problem, but Steam is so widespread and the overwhelming majority of RGB keyboard owners likely have it installed. These pages would be flooded with reports if there was a direct causal connection between the keyboard, CUE, and Steam. Most likely there is another device or program in the mix.
Reply With Quote


  #6  
Old 07-06-2017, 12:25 PM
r3v3nant r3v3nant is offline
Registered User
r3v3nant's PC Specs
 
Join Date: Sep 2014
Location: Newbury Park, CA
Posts: 20
POST ID # = 910522
r3v3nant Reputation: 10
Default

I am having the same issue with a K70 LUX RGB I just added to my PC.. I plug any other USB controlled peripheral, like my xbox 360 controller and steam freezes. I've never seen this happen before with steam. It's a real bummer because that KB was the final part of my new build. Before adding the KB I had cue 2 running with an M65 RGB (optical) mouse and all was fine. So it's something about the K70 LUX and how it interacts with cue 2 I guess.
Reply With Quote


  #7  
Old 07-06-2017, 02:50 PM
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 857
POST ID # = 910542
Corsair Nick Reputation: 39
Default

Just curious, you both mentioned that you have issues when connecting a secondary controller. Are you experiencing issues only in Big Picture Mode for Steam? What happens if you launch the title from your Windows Desktop? Also, are either of you using a Steam Link? Finally, besides Xbox 360 Controller, which other controllers have you used, and are you using a third party software to pair it to the computer?
Reply With Quote


  #8  
Old 07-06-2017, 03:20 PM
r3v3nant r3v3nant is offline
Registered User
r3v3nant's PC Specs
 
Join Date: Sep 2014
Location: Newbury Park, CA
Posts: 20
POST ID # = 910546
r3v3nant Reputation: 10
Default

Nick, hopefully this helps. I had to edit a few times to get all the information in.

- this is only for the normal Steam view for me, I never use big picture.
- I am not using steam link at all.
- The driver for the 360 controller is the default Microsoft one, it auto-loads when I plug the controller in. I did force ably remove it and let windows re-add it once and that didn't change anything. My OS is windows 10 64 home with the creators update.
- The USB devices i have connected are: Corsair M65 RGB optical, K70 red led (no cue support), Logitech G13, Microsoft xbox 360 controller (wireless with USB transmitter) and an Anker 4-Port USB 3.0 Ultra-Slim Portable USB Hub. I have the HUB hung off of the USB port on the K70. I had it in that config when I was using the LUX also.

other things to note, I am running a commander pro and lighting node pro with corsair link (all latest fw and software). Those are on my USB bus also.

It's a weird issue for sure. I have a K70 red led with cherry mx reds on it now, no lighting effects or anything that communicates with cue on that one and all is fine. As soon as I introduce that K70 LUX with cue 2 I get that oddity. I am probably going to move the LUX to my other PC where I don't game much at all, because wow that's one nice kb.. with the mx browns. I was super bummed to because I was like "It's all DONE... oh wait.." ;)

Last edited by r3v3nant; 07-06-2017 at 03:38 PM.
Reply With Quote


  #9  
Old 07-06-2017, 04:56 PM
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 857
POST ID # = 910557
Corsair Nick Reputation: 39
Default

Thanks for the info. Can you open your Big Picture Mode and check the following:

* Controller -> Controller Settings
Can you check that you have "Xbox Configuration Support" Selected
* Controller -> Base Configuration -> Desktop Configuration
Verify if this screen says disabled
* Steam Overlay -> Check "Enable the Steam Overlay"
* On-Screen Keyboard -> Select "Use the Standard On-Screen Keyboard"

If you have created a custom profile in CUE, try creating a new profile with no remaps or macros. I know you mention you use the desktop to launch games, but I would try BPM in Steam to see if this has an affect on the issue since it's optimized for controller support.
Reply With Quote


  #10  
Old 07-08-2017, 03:15 AM
r3v3nant r3v3nant is offline
Registered User
r3v3nant's PC Specs
 
Join Date: Sep 2014
Location: Newbury Park, CA
Posts: 20
POST ID # = 910721
r3v3nant Reputation: 10
Default

Nick - I need to get two usb extensions so I can easily connect that PC to the K70 LUX and try that for you. I have that KB wired into my other PC now, like cables are properly routed and tied down in place under the desk and such. It will be a day or two to get those and I will then be able to run those tests.

EDIT: I am having issues now with my M65 RGB (optical) mouse disconnecting after windows freshly loads up. Just about every other boot after windows loads I hear the USB disconnect sound and my M65 is not responding. Re-plugging it recovers it. Just a note about the M65, it has always felt like it added a little input lag in comparison with the M40 which it was replacing. Before removing it I calibrated it with the surface (a corsair cloth large mat), I tuned the sensitivity plus disabled mouse acceleration and other pointer precision control so software should not be trying to enhance anything, just raw input to mouse to control it. It still felt like it had more input lag that the M40 had with just the basic microsoft mouse driver. So because of all these issues I have uninstalled Cue completely from that PC to just run it with my tried and true non-Cue peripherals, an M40 mouse and older K70 red led for a few days. I just want to establish a working baseline before I get more into this. If things are still solid after a bit I will try adding the K70 lux and M65 again with Cue and run those tests and just test for general stability.

Last edited by r3v3nant; 07-08-2017 at 08:30 PM.
Reply With Quote


  #11  
Old 07-17-2017, 04:28 PM
kryptic57 kryptic57 is offline
Registered User
 
Join Date: Jul 2017
Posts: 5
POST ID # = 912144
kryptic57 Reputation: 10
Default

I am also experiencing this same type of issue with Rainbow Six Siege. I do not have any USB devices plugged in except a sound amp and a mouse. Switching the keyboard to BIOS also corrects the issue. I am not using any profiles for the keyboard except to set a rainbow wave lighting effect. I've uninstalled CUE which corrected the issue, but reinstalling it immediately brought back the problem.

Last edited by kryptic57; 07-17-2017 at 04:33 PM.
Reply With Quote


  #12  
Old 07-17-2017, 10:16 PM
FuzzyWolf FuzzyWolf is offline
Registered User
FuzzyWolf's PC Specs
 
Join Date: Jul 2017
Posts: 44
POST ID # = 912194
FuzzyWolf Reputation: 10
Default

I have this issue randomly too when u click the caps or numlock light doesn't change. I also have a weird issue that when this happens PC would not completely shut down till I unplug the keyboard (http://forum.corsair.com/v3/showthread.php?t=169206). I have K70 LUX RGB Cherry MX red and also on Asus MoBo (Maximus VIII Ranger)
Reply With Quote


  #13  
Old 07-19-2017, 10:01 AM
kryptic57 kryptic57 is offline
Registered User
 
Join Date: Jul 2017
Posts: 5
POST ID # = 912400
kryptic57 Reputation: 10
Default

edit: thought I fixed it but still has issues. I think it's related to USB conflicts to do with the media keys as the bios mode shuts them off and fixes the issue completely.

Last edited by kryptic57; 07-20-2017 at 11:28 PM.
Reply With Quote


  #14  
Old 04-07-2018, 06:42 AM
desolator4u desolator4u is offline
Registered User
desolator4u's PC Specs
 
Join Date: Feb 2012
Posts: 21
POST ID # = 948985
desolator4u Reputation: 10
Default

I was just searching for R6 Siege lighting profiles because I purchased the K70 LUX a few days ago. I play that game religiously. My Logitech G910 keys are trash so I wanted to switch to Corsair and I can't believe this problem I am reading about.

There must have been a fix by now. Right? I can't switch from a crappy keyboard to such a fancy, high expensive one only to have this problem.
Reply With Quote


  #15  
Old 04-07-2018, 10:50 AM
DevBiker's Avatar
DevBiker DevBiker is offline
iCue βeta Team Green
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 5,132
POST ID # = 949019
DevBiker Reputation: 76
Default

I do know that they have been investigating and working on this; I cannot say when there will be a fix available.
__________________
Please click "Edit System Specs" and fill out your system info.

This comment is provided "as-is", without warranty of any kind, express or implied, including, but not limited to, the sanity or mental fitness of the author. The author is not a Corsair employee, does not represent Corsair, and no comment should be construed as an official statement from Corsair.

Reply With Quote


Reply

Tags
cue, freeze, freezing, steam, usb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.