The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cases

Notices

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 09-11-2017, 10:26 AM
Ukguy232Gaming Ukguy232Gaming is offline
Registered User
Ukguy232Gaming's PC Specs
 
Join Date: Sep 2017
Posts: 1
POST ID # = 919672
Ukguy232Gaming Reputation: 10
Post Carbide Titanium 330R IO panel issue

hi guys,
I purchased a carbide titanium 330R case 3 days ago and am having an issue with the IO Panel, only one of the front USB3 ports works i have updated the bios to latest version, updated the USB3 drivers to the latest version, updated the chipset drivers to the latest version but still face this issue.

I have contacted the retailer who advised me to take the first faulty item back and they will exchange it (just the front IO panel) in which i did, the retailer provided me with a replacement item and upon installing it back into the case i still face the same issue

is anyone else facing this same issue and does anyone know if there is a fix to this?

do i have to RMA the case with Corsair?


thanks in advance for your help and support in resolving this frustrating matter

Last edited by Ukguy232Gaming; 09-11-2017 at 10:40 AM.
Reply With Quote


  #2  
Old 09-13-2017, 07:56 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 18,425
POST ID # = 919852
Toasted Toasted Reputation: 104
Default

Put in a support ticket with Corsair. Make sure you upload your proof of purchase to verify warranty.

https://support.corsair.com/
Reply With Quote


Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.