The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 01-14-2019, 04:12 PM
bradthepilot1 bradthepilot1 is offline
Registered User
bradthepilot1's PC Specs
 
Join Date: Jan 2019
Posts: 3
POST ID # = 989878
bradthepilot1 Reputation: 10
Default Issue with K55 and Harpoon RGB Mouse

Hi everyone.

Relatively new to the forums... got my Corsair K55 back in March 2018 and it's been great! Love it, brilliant keyboard, iCUE is also great, but i encountered an issue with it a few days ago...

On Friday night my previous mouse broke, so i decided to purchase the Corsair Harpoon RGB (because i already have a Corsair keyboard, it makes sense to get the mouse too) and when i got home, plugged it in, adjusted all of the settings, DPI and lighting that i wanted. I then restarted my PC and realised my K55 is no longer turning on with my PC for some strange reason... it worked completely fine before i got the Harpoon RGB mouse, but ever since i got that everytime i turn on my PC i have to unplug the K55 and plug it back in before it decides to work. Any ideas as to why this is happening?

P.S Sorry if this has been posted in the wrong channel, i saw others were reporting issues with Mice and Keyboard in here so assumed this is the correct room.

Thanks, Brad.
Reply With Quote


  #2  
Old 01-17-2019, 11:31 AM
Krupas Krupas is offline
Registered User
Krupas's PC Specs
 
Join Date: Jan 2019
Posts: 10
POST ID # = 990271
Krupas Reputation: 10
Default

Try to change the USB port. I had a similar problem, but the change of port to the more powerful one solved it.
Reply With Quote


  #3  
Old 01-20-2019, 05:39 AM
bradthepilot1 bradthepilot1 is offline
Registered User
bradthepilot1's PC Specs
 
Join Date: Jan 2019
Posts: 3
POST ID # = 990613
bradthepilot1 Reputation: 10
Default

Quote:
Originally Posted by Krupas View Post
Try to change the USB port. I had a similar problem, but the change of port to the more powerful one solved it.
Thanks. I'll try that and report back :)
Reply With Quote


  #4  
Old 01-21-2019, 11:55 AM
bradthepilot1 bradthepilot1 is offline
Registered User
bradthepilot1's PC Specs
 
Join Date: Jan 2019
Posts: 3
POST ID # = 990821
bradthepilot1 Reputation: 10
Default

This did not work unfortunately. I have tried all USB ports on my PC and non of them are working. I've noticed it only does it when i turn on my PC. If i restart the PC then it doesn't do it, it only does it when i power on the PC....
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.