The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Corsair Link

Reply
 
Thread Tools Rate Thread Display Modes
  #16  
Old 08-06-2017, 03:07 PM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,155
POST ID # = 914855
red-ray Reputation: 81
Default

Quote:
Originally Posted by YhuggyBear View Post
Same boat as OP z170 asus hero alpha. Same error code 52. Its killing mee :(
See http://forum.corsair.com/forums/showthread.php?p=914671
Reply With Quote


  #17  
Old 08-13-2017, 07:10 AM
Makra Makra is offline
Registered User
 
Join Date: Aug 2017
Posts: 2
POST ID # = 915985
Makra Reputation: 10
Default

Answer fron corsair support on how to solve the isse.
Please disable driver authentication for the device within device manager.
Reply With Quote


  #18  
Old 08-18-2017, 03:36 AM
watchEm watchEm is offline
Registered User
watchEm's PC Specs
 
Join Date: Jan 2017
Posts: 4
POST ID # = 916581
watchEm Reputation: 10
Default

I had the same problem with my H115i and by reading on forums the solution Corsair support gives you is to disable the driver signature enforcement in Windows. It's a security feature in Windows that allows only digitally signed drivers to function but it's more a pain in the butt than it actually helps.
It's a very easy procedure and it will work afterwards, I followed this guide:
Reply With Quote


  #19  
Old 08-18-2017, 03:48 AM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,155
POST ID # = 916582
red-ray Reputation: 81
Thumbs down Wrong Solution

Quote:
Originally Posted by watchEm View Post
It's a security feature in Windows that allows only digitally signed drivers to function but it's more a pain in the butt than it actually helps.
https://www.youtube.com/watch?v=71YA...l=MDTechVideos
It's there to stop viruses loading unsigned kernel drivers and disabling it is the wrong solution.

The correct solution is for Corsair to correctly sign their driver and until they do I recommend using the correctly signed Corsair drivers I attached to:
  1. http://forum.corsair.com/forums/showthread.php?p=856104 (coolers).
  2. http://forum.corsair.com/forums/showthread.php?p=888388 (AXi PSUs).

Last edited by red-ray; 08-29-2017 at 08:24 AM. Reason: Add link
Reply With Quote


  #20  
Old 08-18-2017, 01:38 PM
Corsair Dustin's Avatar
Corsair Dustin Corsair Dustin is offline
Corsair Employee
Corsair Dustin's PC Specs
 
Join Date: Oct 2013
Posts: 3,995
POST ID # = 916655
Corsair Dustin Reputation: 41
Default

I just checked our internal bug tracking to make sure this has been reported, and it has. We're aware of this bug and I've prioritized it. We ARE working on a fix.
__________________
Corsair DIY & Gaming Systems Architect
Product Manager for Corsair Link Software


Please do not send private messages requesting tech support or trouble shooting. You can create a thread and let the solution to your issue be visible to everyone, or alternatively, work directly with tech support by contacting them here.
Reply With Quote


  #21  
Old 08-30-2017, 01:52 PM
Corsair Dustin's Avatar
Corsair Dustin Corsair Dustin is offline
Corsair Employee
Corsair Dustin's PC Specs
 
Join Date: Oct 2013
Posts: 3,995
POST ID # = 918253
Corsair Dustin Reputation: 41
Default

Users having these issues, are you also running any of ASUS's software? If so, which software are you running?
__________________
Corsair DIY & Gaming Systems Architect
Product Manager for Corsair Link Software


Please do not send private messages requesting tech support or trouble shooting. You can create a thread and let the solution to your issue be visible to everyone, or alternatively, work directly with tech support by contacting them here.
Reply With Quote


  #22  
Old 08-30-2017, 03:37 PM
Catalonia Catalonia is offline
Registered User
Catalonia's PC Specs
 
Join Date: Jan 2017
Posts: 23
POST ID # = 918260
Catalonia Reputation: 10
Default

Quote:
Originally Posted by Corsair Dustin View Post
Users having these issues, are you also running any of ASUS's software? If so, which software are you running?
Hello.

I have two Corsair products with this very same "signature" issue.

AX1500i and H115i

I happen to have an Asus Motherboard (Rampage V Edition 10) (without having Asus AI Suite installed by the way)

And an Asus Strix 1080 Ti OC with the Asus Tweak II 1.4376 software installed.

All on Windows 10 64 bit build 1703 fully updated.



I had to install the "old" drivers linked in previous posts in order to be able to see the PSU and the Cooling in corsair Link V 4.8.2.1 otherwise they just wouldn't show up in Link, and appeared with an error in device manager.

Last edited by Catalonia; 08-30-2017 at 03:41 PM.
Reply With Quote


  #23  
Old 08-30-2017, 04:04 PM
Goa Goa is offline
Registered User
Goa's PC Specs
 
Join Date: Apr 2017
Posts: 28
POST ID # = 918261
Goa Reputation: 10
Default

Hi there i have H80i v2 and asus z270f. In the device manager i see it as Corsair USBxp Driver. Before Ausu suit was installed in my pc but later i uninstall it from control panel. As i read in asus forum i need to unisntall it with asus cleaner but that program is not working anymore.
Attached Images
File Type: png device manager.png (82.5 KB, 61 views)
File Type: png device manager1.png (30.3 KB, 65 views)
File Type: png device manager2.png (50.1 KB, 51 views)
File Type: png device manager3.png (18.8 KB, 39 views)
File Type: png device manager4.png (50.0 KB, 47 views)
Reply With Quote


  #24  
Old 08-31-2017, 11:07 AM
Corsair Dustin's Avatar
Corsair Dustin Corsair Dustin is offline
Corsair Employee
Corsair Dustin's PC Specs
 
Join Date: Oct 2013
Posts: 3,995
POST ID # = 918396
Corsair Dustin Reputation: 41
Default

Thank you both for the information, I can feed this back to the engineering team.
__________________
Corsair DIY & Gaming Systems Architect
Product Manager for Corsair Link Software


Please do not send private messages requesting tech support or trouble shooting. You can create a thread and let the solution to your issue be visible to everyone, or alternatively, work directly with tech support by contacting them here.
Reply With Quote


  #25  
Old 09-01-2017, 04:53 PM
Toendy Toendy is offline
Registered User
Toendy's PC Specs
 
Join Date: May 2013
Posts: 5
POST ID # = 918620
Toendy Reputation: 20
Default

Quote:
Originally Posted by red-ray View Post
The issue is with the signing of the Corsair USBxp Driver and only Corsair can fix this.

The old driver package was OK, so you could try the copy of those drivers I attached to http://forum.corsair.com/forums/showthread.php?p=856104 which is the same driver, but with a different .INF file.

Once the old driver package is installed CL 4.8.0.82 should report Asetek coolers.
Dude you’re a boss!

I’ve been looking all night for a fix.
I noticed my pump was running at full speed all the time but everything else was running normal speed.
I tried everything that was on other topics.
Until i sa this topic.
After a simple remove, download your drivers and then manually find of drivers corsair link finally finds my h115i.
And my windows also now says "Corsair Hydro Series 7289 USB Device"

Big thx m8

PS: DO NOT disable the driver signature enforcement, it’s there for a reason.
it’s to make sure viruses can't just install without a prompt of microsoft verification.
So plz be careful and safe in what you disable before it’s to late.

Last edited by Toendy; 09-01-2017 at 05:05 PM.
Reply With Quote


  #26  
Old 09-02-2017, 11:38 AM
VVagnard VVagnard is offline
Registered User
VVagnard's PC Specs
 
Join Date: Sep 2017
Posts: 2
POST ID # = 918690
VVagnard Reputation: 10
Default

Quote:
Originally Posted by Corsair Dustin View Post
Users having these issues, are you also running any of ASUS's software? If so, which software are you running?
No Asus software, I have an MSI motherboard. No MSI software either.
Same problem as the others.
Reply With Quote


  #27  
Old 09-03-2017, 03:22 AM
CosmicRichy CosmicRichy is offline
Registered User
 
Join Date: Sep 2017
Posts: 1
POST ID # = 918759
CosmicRichy Reputation: 10
Default

Hey guys. Just wondering if there is an update on this issue?

I have just run into this issue today after I was prompted to updated my Corsair LINK app to version 4.8.2.1
After the update my H100i V2 has completely disappeared from the app.

I'm also seeing the USBXp Driver error in my windows settings.

Any official solutions yet?
Reply With Quote


  #28  
Old 09-03-2017, 03:31 AM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,155
POST ID # = 918760
red-ray Reputation: 81
Idea Using the old drivers should work

Quote:
Originally Posted by CosmicRichy View Post
Any official solutions yet?
Not official, but using the old drivers should work, see http://forum.corsair.com/forums/showthread.php?p=917533

I expect if Corsair Dustin was not happy for users to do this he would have asked me to remove the posts which have been there for over 12 months.

Last edited by red-ray; 09-03-2017 at 03:41 AM.
Reply With Quote


  #29  
Old 09-03-2017, 04:35 PM
Catalonia Catalonia is offline
Registered User
Catalonia's PC Specs
 
Join Date: Jan 2017
Posts: 23
POST ID # = 918843
Catalonia Reputation: 10
Default

Corsair: When are we going to get new drivers properly signed for W10 64 bit 1703?

This is a serious issue, and your users are starting to be really angry.

Last edited by Catalonia; 09-06-2017 at 08:12 AM.
Reply With Quote


  #30  
Old 09-06-2017, 02:21 PM
Corsair Dustin's Avatar
Corsair Dustin Corsair Dustin is offline
Corsair Employee
Corsair Dustin's PC Specs
 
Join Date: Oct 2013
Posts: 3,995
POST ID # = 919174
Corsair Dustin Reputation: 41
Default

We have to reproduce the issue internally and figure out why the driver signing is malfunctioning only some of the time. This isn't affecting everyone, just a subset of users.

We have to isolate what the actual problem is because it's not just a simple case of a bad driver signature, and then we have to fix the driver. It could also depend on which driver within Corsair Link needs to be fixed. Problems which seem superficially simple can actually be extremely complex to solve.
__________________
Corsair DIY & Gaming Systems Architect
Product Manager for Corsair Link Software


Please do not send private messages requesting tech support or trouble shooting. You can create a thread and let the solution to your issue be visible to everyone, or alternatively, work directly with tech support by contacting them here.
Reply With Quote


Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.