The Corsair User Forums  

Go Back   The Corsair User Forums > Customer Service > Warranty and RMA Questions

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 09-10-2018, 05:02 AM
DKCDodge DKCDodge is offline
Registered User
DKCDodge's PC Specs
 
Join Date: Sep 2018
Posts: 0
POST ID # = 972121
DKCDodge Reputation: 10
Default Faulty H115i & Cannot register on website for support

Every time I try and create an account on RMA/Returns it keeps saying
The webpage cannot be found. I have tried on 2 computers with different browsers but still the same outcome.

I purchased the Hydro Series™ H115i Liquid CPU Cooler around Christmas 2017 time. Fitted it in my computer and was extremely happy with it. After a few months around April 2018 to May 2018 I started experiencing boot up errors while loading windows. CPU Fan Error Press F1 to load up BIOS to check fan speeds etc. Once in BIOS there were no known obvious reasons why it was displaying that error message so I just exit BIOS with no changes and it went straight into Windows no problem. This has been happening on and off since April / May when the issue first started.

Last week when starting windows it would not load at all, gave an error message saying windows had run into a problem and has shut down to avoid any problems. This would then repeat over and over again and I could not load windows at all, was just looping continuously. This continued to happen for about 4 days then started to report the CPU Fan error message again but this time it was saying my CPU Temperature was at 89 degrees and was seriously overheating so I shut it down straight away as I did not want my CPU Dying. I looked for loads of help guides in trying to fix this problem but not one of them was my issue and couldn't solve the problem. I then gave up hope of fixing it so bought the H115i PRO cooler to see if it was faulty or not. Once installed in my computer it booted up straight away so there for it was the H115i cooler that was 100% faulty.

I have tried to register on your website so I can start the process of claiming under the 5 Year Warranty you give but your website keeps crashing when I input all my details. I have tried on a couple of different computers like I said but they are all doing the same.

Can you please advise where I go now and how I can claim under the warranty.

I look forward to any help you can give me on this matter.

Regards

DKCDodge

Just bought Hydro Series™ H115i PRO Liquid CPU Cooler to replace the H115i and worked straight away!

Last edited by Technobeard; 09-10-2018 at 01:18 PM. Reason: specs removed; already in profile
Reply With Quote
  #2  
Old 09-10-2018, 01:19 PM
Technobeard's Avatar
Technobeard Technobeard is offline
Bearded Corsair Employee
 
Join Date: Oct 2012
Posts: 4,246
POST ID # = 972174
Technobeard Reputation: 68
Default

Are you going to https://support.corsair.com? It's working fine for me right now. If you're going somewhere else - where are you going?

How is it "crashing" ? What OS / browsers have you tried?
__________________
“Humor is reason gone mad.” - Groucho Marx
"I suggest a full frontal assault with automated laser monkeys, scalpel mines and acid." - Psychotic potato dwarf
"Do not meddle in the affairs of wizards, especially simian ones. They are not all that subtle." - Terry Pratchett
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.