The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > iCUE Software

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 06-29-2018, 08:23 AM
Syberon Syberon is offline
Registered User
Syberon's PC Specs
 
Join Date: May 2018
Location: Russia
Posts: 99
POST ID # = 961308
Syberon Reputation: 12
Default iCUE display incorrect charge status and battery level on Dark Core RGB SE

I found that very often iCUE displays that mouse is charging even with unplugged cable after PC wake up from sleep. To resovle this problem i have to plug in and plug out cable on running PC with iCUE. After this battery status starts to show correctly. I use last version of iCUE 3.4.95

How to reproduce:
1. Turn on PC and iCUE
2. Plug in wire to mouse to start charging
3. Turn PC to sleep mode.
4. Unplug cable from mouse
5. Wake up PC from sleep mode

After wake up iCUE continue to show that mouse is still charging even with cable disconnected.

And another issue related to charge - iCUE shows incorrect battery level after charging with Qi wireless charger.

How to reproduce:
1. Turn on PC and iCUE
2. Use mouse in wireless mode to drain battery to "low" or "critical low" level.
3. Put mouse on Qi charger for a few hours
4. Turn PC to sleep mode
5. Wake up PC from sleep mode

After wake up iCUE continue to show the battery level which was before PC goes to sleep mode ("low" or "critical low"). I can't find the 100% working solution for resuming display normal battery level. Some times it fixes after few plug/unplug cable, sometimes this not fixes and battery level normalizes after a some time (half hour or hour).

I do not know exactly that this problem related to iCUE or mouse firmware but i think this is important problem for wireless device and needs to be resolved asap.

And another problem - why mouse shows 75% battery when it fully charged?

It seems to me that there are too many problems concerning charging the Dark Core and it's time to solve them. Is not it?

Last edited by Syberon; 06-29-2018 at 08:26 AM.
Reply With Quote
  #2  
Old 06-29-2018, 03:04 PM
Inheritance's Avatar
Inheritance Inheritance is offline
βetα Nayn Cat
 
Join Date: Jul 2013
Location: Somewhere in Texas
Posts: 5,286
POST ID # = 961375
Inheritance Reputation: 41
Default

The problem might be with the fact that you are putting your computer to sleep. There are quite a few problems in iCUE right now that stem from Windows attempting to restart services after waking from sleep.

Can you reproduce this with a shutdown?
__________________
Colors of the RAINBOW shine so bright!
USER IS NOT A CORSAIR EMPLOYEE
Come Join My Discord =(^.^)= [iCUE Guide]
Corsair USER Forums is NOT Corsair Tech Support
Reply With Quote
  #3  
Old 06-29-2018, 10:39 PM
Syberon Syberon is offline
Registered User
Syberon's PC Specs
 
Join Date: May 2018
Location: Russia
Posts: 99
POST ID # = 961438
Syberon Reputation: 12
Default

It seems that the problem is in the mouse firmware. Now i tried to reproduce this with full PC shutdown.

1. Turn on PC and iCUE
2. Plug in wire to mouse to start charging
3. Shutdown PC
4. Unplug cable from mouse on shutted down PC
5. Turn on PC and iCUE

After Windows and iCUE starts it shows that mouse is charging even with cable disconnected.

Same with wireless charging - mouse shows incorrect battery level after shutdown/turn on PC.
Reply With Quote
  #4  
Old 06-29-2018, 10:44 PM
Inheritance's Avatar
Inheritance Inheritance is offline
βetα Nayn Cat
 
Join Date: Jul 2013
Location: Somewhere in Texas
Posts: 5,286
POST ID # = 961439
Inheritance Reputation: 41
Default

Gotcha, I'm trying to reproduce this, and push it up so Corsair can try to recreate this bug too.

I'm assuming your dongle is connected. But is your mouse on or off after turning on the PC again?
__________________
Colors of the RAINBOW shine so bright!
USER IS NOT A CORSAIR EMPLOYEE
Come Join My Discord =(^.^)= [iCUE Guide]
Corsair USER Forums is NOT Corsair Tech Support

Last edited by Inheritance; 06-29-2018 at 10:50 PM.
Reply With Quote
  #5  
Old 06-29-2018, 10:51 PM
Syberon Syberon is offline
Registered User
Syberon's PC Specs
 
Join Date: May 2018
Location: Russia
Posts: 99
POST ID # = 961440
Syberon Reputation: 12
Default

Quote:
Originally Posted by Inheritance View Post
Gotcha, I'm trying to reproduce this, and push it up so Corsair can try to recreate this bug too.

I'm assuming your dongle is connected. But is your mouse on or off after turning on the PC again?
Yes, dongle is always connected to PC and mouse normally works in wireless mode despite of incorrect battery level reporting.

Dongle and charging wire both connected to motherboard USB ports.

Last edited by Syberon; 06-29-2018 at 10:54 PM.
Reply With Quote
  #6  
Old 06-29-2018, 10:56 PM
Inheritance's Avatar
Inheritance Inheritance is offline
βetα Nayn Cat
 
Join Date: Jul 2013
Location: Somewhere in Texas
Posts: 5,286
POST ID # = 961442
Inheritance Reputation: 41
Default

Yup, Got the bug now. I was doing it wrong had the mouse turned off after shutting down. Thank you for the bug report.

Hopefully, they will be able to get the charge % bug too.
__________________
Colors of the RAINBOW shine so bright!
USER IS NOT A CORSAIR EMPLOYEE
Come Join My Discord =(^.^)= [iCUE Guide]
Corsair USER Forums is NOT Corsair Tech Support
Reply With Quote
  #7  
Old 06-29-2018, 11:02 PM
Syberon Syberon is offline
Registered User
Syberon's PC Specs
 
Join Date: May 2018
Location: Russia
Posts: 99
POST ID # = 961444
Syberon Reputation: 12
Default

I think that both this problems (incorrect charging status and battery level after wireless charge) related to one software bug.
And together with this problem can still be corrected the battery levels (I mean 75% on a fully charged battery). Several versions of iCUE have already been published, but the problem has not been solved
Reply With Quote
  #8  
Old 06-29-2018, 11:07 PM
Syberon Syberon is offline
Registered User
Syberon's PC Specs
 
Join Date: May 2018
Location: Russia
Posts: 99
POST ID # = 961445
Syberon Reputation: 12
Default

Well, maybe there is related problem that the software profile does not applied to mouse after PC wakes up from sleep when mouse in wired mode. The profile immediately applies after pluging out wire.
But in contrast to the previous problem this one appears only when PC wake up from sleep.

Last edited by Syberon; 06-29-2018 at 11:13 PM.
Reply With Quote
  #9  
Old 07-14-2018, 11:34 PM
Syberon Syberon is offline
Registered User
Syberon's PC Specs
 
Join Date: May 2018
Location: Russia
Posts: 99
POST ID # = 963517
Syberon Reputation: 12
Default

I also opened a ticket about this problem two weeks ago but Corsair support only replies to me with template answers that it "Windows drivers problem after sleep/hybernate/fast-boot". They just do not want to listen explanation of problem and methods to reproduce it. How it can be drivers problem if it appears even after fully shutdown and cold boot with disabled all hybernate/fastboot options?
Reply With Quote
  #10  
Old 10-08-2018, 03:39 PM
Blofeld2k Blofeld2k is offline
Registered User
Blofeld2k's PC Specs
 
Join Date: Nov 2011
Location: Angola IN
Posts: 108
POST ID # = 975591
Blofeld2k Reputation: 12
Default

Anything new on this 75% topic?
Reply With Quote
  #11  
Old 01-21-2019, 05:37 AM
Couscous78150 Couscous78150 is offline
Registered User
Couscous78150's PC Specs
 
Join Date: Dec 2018
Posts: 4
POST ID # = 990778
Couscous78150 Reputation: 10
Default

No news on this topic. I encountered the same issue.
Reply With Quote
  #12  
Old 02-10-2019, 09:25 AM
ceevee369 ceevee369 is offline
Registered User
ceevee369's PC Specs
 
Join Date: Feb 2019
Posts: 5
POST ID # = 993477
ceevee369 Reputation: 10
Default

The newest iCue patch didn't solve the faulty / wrong battery level indication on the dashboard. Never ever shows it as100% charged, max is 75% only. This ain't fun after having spent nearly 700 USD on all new Corsair stuff :(
Reply With Quote
  #13  
Old 02-13-2019, 01:13 AM
Corsair Calico Jack's Avatar
Corsair Calico Jack Corsair Calico Jack is offline
Registered User
 
Join Date: Oct 2016
Posts: 279
POST ID # = 993980
Corsair Calico Jack Reputation: 10
Default

Hey guys,

Updates to iCUE are basically done months in advance. We program, and then submit it to QA where it's subjected to rigorous testing across all like.... 7 product categories that use iCUE. What I'm really trying to get at here though is that the updates you get on the website have basically been around for like a month or two before they hit the wild, and don't always have resolutions to the newest bugs we're seeing out here.

I'll forward the forum post to the dev teams to make sure they're aware, but I see Inheretence has already done that. Hopefully there will be a permanent fix soon.
Reply With Quote
  #14  
Old 02-15-2019, 03:18 PM
Merlin840 Merlin840 is online now
Registered User
Merlin840's PC Specs
 
Join Date: Jul 2017
Posts: 2
POST ID # = 994373
Merlin840 Reputation: 10
Default

Just got my Dark Core in today and the 75% battery level thing has been throwing me off.. Guess its just wait and see what happens with iCUE patches.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.