The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 10-23-2014, 02:13 AM
xbuild xbuild is offline
Registered User
xbuild's PC Specs
 
Join Date: Oct 2014
Posts: 2
POST ID # = 737421
xbuild Reputation: 10
Question new owner off RGB K95-3 days old -issues and problems

hi Corsair-ians..

New forum user and owner of the new RGB k95 cherry red keyboard..

Ive read a lot of reviews and posts by others on the forum to see that its not just me having problems.

at the moment:

1) software crashed, need to turn of computer or unplug keyboard seeing still frozen after restart. usually pull keyboard out. then plug 2 connecters in one at a time in the correct order keyboard diagram one last.

2) when i plug keyboard in it goes to my profile set then to a rainbow one with all keys flashing and illuminating at different times, then freezes or some times rainbow dosent if work goes straight to other profiles i haven't chosen its different every time. cant figure it out.

3) the light brightness switch is playing up blinks between going down, ie if two or more colours on from 66 down to 33 all will be on at 33 then flashes then turns everything of except 1 or 2 keys

4) when i set certain colours to keys IE:: black it goes to red, when i set it to white it changes keys to pink, if i chose purple goes green, etc etc blue to light purple???? am-mm software? or my PC.

5) some keys are not lighting up or is that the design of the keyboard for example all the numbers 1234567890-= have the symbols above the number lighting up but not the actual numbers, same as numlock the secondary numbers are not lighting up also caps lock is only half lite ie the CAPS part is this a design flaw or is it my keyboard led that are dead or what is it pls help i could go on and on.........

i just wanted to get some tech help and answers to see where to go from here. i can post my logs once i figure out how. errors every where but because i was hitting keys after it froze..

love corsair and the development of solid built and ingenuity but after waiting nearly 9 months for this product to get to this stage feeling like bf4 not sure if it my PC or hard wear but refund maybe but not until, i help out with the fix a bit and hopefully help the technicians find a fix/ result.

any help at this stage would be great.!!!

should i keep this keyboard? first mechanical after 25 year and loving it minus the issues but $$ wise so confused!!.

thanks for reading this to the bitter end..

xbuild

ps can post logs if asked by corsair..


thanks
Reply With Quote


  #2  
Old 10-23-2014, 09:58 AM
mtik00 mtik00 is offline
Registered User
mtik00's PC Specs
 
Join Date: Oct 2014
Posts: 2
POST ID # = 737475
mtik00 Reputation: 10
Default

The first thing I'd recommend is disabling CUE loading on boot and delete the Corsair folder in your %APPDATA% folder (if you are on Windows). That cleared up 95% of my problems. I don't know why, but it did. I was asked to do that by customer services.

Quote:
Originally Posted by xbuild View Post
3) the light brightness switch is playing up blinks between going down, ie if two or more colours on from 66 down to 33 all will be on at 33 then flashes then turns everything of except 1 or 2 keys
I had a similair issue w/ the brightness button, but it when away after a cold boot. No help there... sorry.

Quote:
Originally Posted by xbuild View Post
4) when i set certain colours to keys IE:: black it goes to red, when i set it to white it changes keys to pink, if i chose purple goes green, etc etc blue to light purple???? am-mm software? or my PC.
Argh, this got me for a long time too. It's a sort of cool feature of CUE. You can "layer" colors together. What's happening is that there is a keymap called "All" in your profile. Delete that (or set it to "black"), and you'll be able to select any color you want.

Quote:
Originally Posted by xbuild View Post
5) some keys are not lighting up or is that the design of the keyboard for example all the numbers 1234567890-= have the symbols above the number lighting up but not the actual numbers, same as numlock the secondary numbers are not lighting up also caps lock is only half lite ie the CAPS part is this a design flaw or is it my keyboard led that are dead or what is it pls help i could go on and on.........
I have the same thing. I think it's just a function of where the LED sits, since all the keys are like that. It appears the LED sits at the "top" of the keys. I don't know though...
Reply With Quote


3 members found this post helpful.
  #3  
Old 10-23-2014, 01:39 PM
Roaminrome Roaminrome is offline
Registered User
 
Join Date: Sep 2014
Posts: 19
POST ID # = 737528
Roaminrome Reputation: 10
Default

Not even my thread, but i had to 1 up this guy ^ very thorough response dude. I love it!
Reply With Quote


1 members found this post helpful.
  #4  
Old 10-23-2014, 03:57 PM
Yellowbeard's Avatar
Yellowbeard Yellowbeard is offline
Banned
 
Join Date: Oct 2002
Location: Atlanta,GA, USA.
Posts: 11,531
POST ID # = 737559
Yellowbeard Reputation: 46
Default

Quote:
Originally Posted by Roaminrome View Post
Not even my thread, but i had to 1 up this guy ^ very thorough response dude. I love it!
Click on the "scales" icon in the post and rep him!
Reply With Quote


  #5  
Old 10-23-2014, 07:35 PM
xbuild xbuild is offline
Registered User
xbuild's PC Specs
 
Join Date: Oct 2014
Posts: 2
POST ID # = 737602
xbuild Reputation: 10
Default

Awesome thanks heaps mtik00, was the answers to all of my questions i was looking for greatly appreciated. +rep 1

also big thanks to yellow-beard your forum posts on this RGB keyboards have been so useful informal and just what people need.

ill get on to trying to delete my temp folders ext and get backto you all with an update..
Reply With Quote


Reply

Tags
k95 rgb, k95 rgb problems, keyboard

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.