The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 11-08-2018, 12:34 AM
Ryslar Ryslar is offline
Registered User
 
Join Date: Nov 2018
Posts: 2
POST ID # = 979417
Ryslar Reputation: 10
Default HS70 Driver Issues (Mic/Drivers/Audio Output/Discord)

I love my new HS70 headset. But it really is doing its best to make me not like it. Discord regularily fails to recognize the microphone, I've had the EQ and 7.1 stop functioning more than once (only being fixed by reflashing firmware), and the mic talkback sometimes doesn't activate even when it is turned on. However, the biggest issue I face are the drivers constantly 'restarting' themselves. It seems to happen most often when attempting to use the microphone, mostly with Discord, sometimes in the Battle.net app as well. When viewing the current output/input in the sounds tab of Windows 10 settings, the name of the headset and mic flicker, reverting to my speakers then back and forth, the microphone switching to no input recognized. It's like the headphones are having a sezuire. It can never seem to have Discord and the mic active when launching a game, then every aspect of the headphone fails except for the talkback feature. The audio cue for the mic turning on plays repeatedly, the headset occassionally switches off and sometimes Windows and iCUE will fail to recognize that the adapter is even plugged in and the only way to fix this is to restart my computer. Does anyone have any similar problems to mine? Is this a driver problem? Software? My 5 year old computer hardware? Is the adapter faulty? I'd be happy to have it replaced, but I don't want to wait weeks for another product to have the same problem. Any advice would be helpful, and yes, I have tried reinstalling the drivers repeatedly. And I have used different USB ports for the adapter.
Reply With Quote


  #2  
Old 11-08-2018, 05:41 PM
Corsair Mint Corsair Mint is offline
Corsair Employee
 
Join Date: Apr 2016
Posts: 660
POST ID # = 979518
Corsair Mint Reputation: 24
Default

Hey Ryslar, just in case, can you try the headset on another computer to see if the issues happen there as well?
Reply With Quote


  #3  
Old 11-08-2018, 06:02 PM
Ryslar Ryslar is offline
Registered User
 
Join Date: Nov 2018
Posts: 2
POST ID # = 979531
Ryslar Reputation: 10
Default

Testing it with my laptop, everything seems to be fine. I can't recreate any of the problems I'm having on my PC. This is leading me to believe it's an issue with the drivers being installed incorrectly, my outdated internal hardware, or a combination of both.
Reply With Quote


  #4  
Old 11-13-2018, 03:09 PM
Corsair Mint Corsair Mint is offline
Corsair Employee
 
Join Date: Apr 2016
Posts: 660
POST ID # = 980293
Corsair Mint Reputation: 24
Default

Try a repair of iCUE just in case. When you go to launch iCUE, right-click and set to Run as Administrator in case it's not getting the proper permissions for the drivers.
Reply With Quote


Reply

Tags
defective, disconnect, drivers, hs70, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.