The Corsair User Forums  

Go Back   The Corsair User Forums > Customer Service > Warranty and RMA Questions

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 11-22-2018, 02:31 PM
bhavitratech bhavitratech is offline
Registered user
 
Join Date: Nov 2018
Posts: 0
POST ID # = 981623
bhavitratech Reputation: 10
Default support

I am using RM1000X PSU. Today I have seen it is not working. Not even booting. I purchase it for my Web Design Company not the system is totally stopped working. I seen some little smell comming from inside. What is the replacement procedure.

Can Anyone suggest me.

Last edited by Technobeard; 11-22-2018 at 05:39 PM.
Reply With Quote
  #2  
Old 11-22-2018, 05:40 PM
Technobeard's Avatar
Technobeard Technobeard is offline
Bearded Corsair Employee
 
Join Date: Oct 2012
Posts: 4,263
POST ID # = 981637
Technobeard Reputation: 68
Default

Please create a support account at support.corsair.com so that our support team can assist you.
__________________
“Humor is reason gone mad.” - Groucho Marx
"I suggest a full frontal assault with automated laser monkeys, scalpel mines and acid." - Psychotic potato dwarf
"Do not meddle in the affairs of wizards, especially simian ones. They are not all that subtle." - Terry Pratchett
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.