The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cooling

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 12-05-2017, 09:09 AM
Makenshii Makenshii is offline
Registered User
Makenshii's PC Specs
 
Join Date: Dec 2017
Posts: 2
POST ID # = 929177
Makenshii Reputation: 10
Default Corsair link bsod

Hi all

Since building a new rig from parts sourced on Black Friday I have encountered non stop bsod with a few different error codes.

Mainly memory_management
irql_not_less_or_equal
kernel_security_check_failure

I am normally pretty good with being able to diagnose and repair bsod but this one had me stomped for ages. I tested all hardware with no fails. RAM and all storage was fine. Drivers also came back fine. BOIs was flashed at cpu install all chip set and relevant mobo drivers installed and up-to-date and yet bsod still appears.

I did everything I could think of until I reinstalled windows. At this point I realised the one app/driver I had yet to install was Corsair link/H100i GTX cooler but my windows was the most stable it has been since being built.

Device manager flags "H100iGTX cooler" as no drivers detected. Upon reinstalling Corsair link as Admin and load up a game...... bsod. Then every time I restart, enter pin for windows and get to desktop.... bsod.
I've tried installing and rebooting with disabled signature signing and still bsod.

After removing Corsair link I can now restart, log into windows and game effortlessly with 0 bsod.

Is there a fix/work around for this? Can I just continue without the drivers?

Thanks in advance for your time and patience.
Reply With Quote


  #2  
Old 12-05-2017, 09:33 AM
DevBiker's Avatar
DevBiker DevBiker is offline
iCue βeta Team Green
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 4,428
POST ID # = 929182
DevBiker Reputation: 69
Default

That's odd ... it does sound like you've definitely isolated the issue to the H100iGTX cooler's driver.
Have you tried plugging the cooler into another USB port? You can also use a standard mini-USB cable to an run it outside of the case to plug in to an external port.
Yes, you can continue without the drivers. You won't be able to monitor or control the cooler but it'll still work.
Reply With Quote


  #3  
Old 12-05-2017, 09:50 AM
Makenshii Makenshii is offline
Registered User
Makenshii's PC Specs
 
Join Date: Dec 2017
Posts: 2
POST ID # = 929185
Makenshii Reputation: 10
Default

Quote:
Originally Posted by DevBiker View Post
That's odd ... it does sound like you've definitely isolated the issue to the H100iGTX cooler's driver.
Have you tried plugging the cooler into another USB port? You can also use a standard mini-USB cable to an run it outside of the case to plug in to an external port.
Yes, you can continue without the drivers. You won't be able to monitor or control the cooler but it'll still work.
Unfortunately I don't have a mini-USB cable to try an external port.
As both a little OCD and an Engineer, this nags at me as I'd like to have the issue resolved. I can't honestly think of any logical reason why this is a problem (I fully understand that PC logic isn't always solid) but would have hoped for a fix by now. I do believe the cooler in question is at least 2 years old now and I do understand the mobo cpu combo I have is under a year old.

Either way, for now, I shall continue without the drivers and keep a keen eye out for any additional information or advice.

Thank you for acknowledging my issue
Reply With Quote


  #4  
Old 12-05-2017, 09:55 AM
DevBiker's Avatar
DevBiker DevBiker is offline
iCue βeta Team Green
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 4,428
POST ID # = 929187
DevBiker Reputation: 69
Default

Quote:
Originally Posted by Makenshii View Post
Unfortunately I don't have a mini-USB cable to try an external port.
As both a little OCD and an Engineer, this nags at me as I'd like to have the issue resolved. I can't honestly think of any logical reason why this is a problem (I fully understand that PC logic isn't always solid) but would have hoped for a fix by now. I do believe the cooler in question is at least 2 years old now and I do understand the mobo cpu combo I have is under a year old.

Either way, for now, I shall continue without the drivers and keep a keen eye out for any additional information or advice.

Thank you for acknowledging my issue
Well, if it helps, I don't recall other reports of BSODs due to the cooler's driver on the forum. That doesn't mean that they aren't there but, considering how loudly people complained about Link not starting minimized to the tray, widespread BSODs from the cooler probably would have launched WWIII. Hopefully one of the Corsair folks will have some additional insight.
Reply With Quote


Reply

Tags
bsod, corsair link

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.