The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cases

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 09-04-2017, 06:55 AM
Farisy Farisy is offline
Registered User
Farisy's PC Specs
 
Join Date: Sep 2017
Posts: 4
POST ID # = 918897
Farisy Reputation: 10
Default 460x RGB LED hub burned

Hi guys,

I've finally done it. I have built my first PC and it's amazing and I'm very proud of it. every thing went well and the build was very easy.
But I had a problem. I smelled something burning and saw smoke coming out of the case and freaked out. The SATA power cable in the RGB LED fan hub burned out. Also, you can notice that the fan in the slot number 3 wire is burned as well so the rest of the wires are burned too and stuck together as well as one the fan's power cable. Off course the fans are working fine and spinning but the RGB light is not working and obviously, I disconnected the hub.
I've filed a ticket but still yet to get any response but I'd love to hear from to see what the problem is and if it's my mistake or malfunction of the hub.

Thanks!
Attached Images
File Type: jpg IMG_9480.JPG (1.05 MB, 90 views)
File Type: jpg IMG_9479.JPG (1.25 MB, 75 views)
File Type: jpg IMG_9475.JPG (2.34 MB, 68 views)
File Type: jpg IMG_9472.JPG (1.22 MB, 67 views)
Reply With Quote


  #2  
Old 09-04-2017, 07:45 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 18,607
POST ID # = 918901
Toasted Toasted Reputation: 104
Default

I've seen it before on some case fan controllers. It's possible the hub may be faulty rather than something else causing it.
Reply With Quote


  #3  
Old 09-05-2017, 01:49 PM
Corsair Blake Corsair Blake is offline
Banned
Corsair Blake's PC Specs
 
Join Date: Jun 2016
Location: Fremont, CA
Posts: 300
POST ID # = 919065
Corsair Blake Reputation: 14
Default

Give me your ticket number and I'll have this looked at.
Reply With Quote


  #4  
Old 09-05-2017, 02:39 PM
Farisy Farisy is offline
Registered User
Farisy's PC Specs
 
Join Date: Sep 2017
Posts: 4
POST ID # = 919073
Farisy Reputation: 10
Default

Quote:
Originally Posted by Corsair Blake View Post
Give me your ticket number and I'll have this looked at.
It's #615132
Reply With Quote


  #5  
Old 09-18-2017, 10:42 AM
Farisy Farisy is offline
Registered User
Farisy's PC Specs
 
Join Date: Sep 2017
Posts: 4
POST ID # = 920443
Farisy Reputation: 10
Default

Hi guys :)
So Corsair kindly sent me a new hub.
But I just wanted to ask if it's ok to plug the new hub with these melted fan 4 pin wires ?
Or should I get new wire or new fans ?
Reply With Quote


  #6  
Old 09-18-2017, 12:32 PM
Corsair Blake Corsair Blake is offline
Banned
Corsair Blake's PC Specs
 
Join Date: Jun 2016
Location: Fremont, CA
Posts: 300
POST ID # = 920456
Corsair Blake Reputation: 14
Default

Quote:
Originally Posted by Farisy View Post
Hi guys :)
So Corsair kindly sent me a new hub.
But I just wanted to ask if it's ok to plug the new hub with these melted fan 4 pin wires ?
Or should I get new wire or new fans ?
I highly recommend you replace all of the affected components. If you have 3-4 fans that got burned up, please update your ticket and request an RMA on those as well. We should have covered them in the initial ticket. Do not use them as there may be additional damage that would take place.
Reply With Quote


  #7  
Old 09-18-2017, 01:19 PM
Farisy Farisy is offline
Registered User
Farisy's PC Specs
 
Join Date: Sep 2017
Posts: 4
POST ID # = 920471
Farisy Reputation: 10
Default

Quote:
Originally Posted by Corsair Blake View Post
I highly recommend you replace all of the affected components. If you have 3-4 fans that got burned up, please update your ticket and request an RMA on those as well. We should have covered them in the initial ticket. Do not use them as there may be additional damage that would take place.
Ok glad to hear that I will update my RMA but how do I do that?
I've been using the fans I have 4 SP120 RGB 3 included in the case and bought one extra. I've disconnected the hub from the sata power off course so the LED RGB lights are off, but They are working AND spining fine but I believe I should get them replaced as the 4 pin RGB LED wires are melted together as seen in the attached pictures.
Reply With Quote


  #8  
Old 09-25-2017, 04:44 PM
versus4582 versus4582 is offline
Registered User
versus4582's PC Specs
 
Join Date: Sep 2017
Posts: 4
POST ID # = 921151
versus4582 Reputation: 10
Default

Same thing happened to me today..

I saw a small white flash inside the case and immediately i could smell something burned. If i re-position the fans on the controller's position 1 they light up just fine. All of the controllers positions are burned except position marked ''1''. Corsair can you please advise ???

Thanks in advance...
Reply With Quote


  #9  
Old 09-26-2017, 06:53 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 18,607
POST ID # = 921206
Toasted Toasted Reputation: 104
Default

If there is an issue with the hub, you will want to put in a support ticket.
https://support.corsair.com/

Make sure you upload your proof of purchase as this will be used to verify the warranty period.
Reply With Quote


  #10  
Old 09-26-2017, 12:15 PM
versus4582 versus4582 is offline
Registered User
versus4582's PC Specs
 
Join Date: Sep 2017
Posts: 4
POST ID # = 921235
versus4582 Reputation: 10
Default

Thank you for your response but as i said in another thread here: http://forum.corsair.com/v3/showthread.php?t=170740

the ''Claim your account'' does not work for some reason. My email is correct , the bar turns green but then i get

''NO MATCHING ACCOUNT WAS FOUND. PLEASE CHECK THE EMAIL AND TRY AGAIN. IF THIS IS AN ERROR PLEASE CONTACT OUR SUPPORT DESK
. PLEASE CONTACT CUSTOMER SERVICE.''

Can someone please advise ??
Reply With Quote


  #11  
Old 09-26-2017, 05:44 PM
Speedbreaker12 Speedbreaker12 is offline
Registered User
Speedbreaker12's PC Specs
 
Join Date: Aug 2017
Posts: 17
POST ID # = 921273
Speedbreaker12 Reputation: 17
Default

Holy Cow, what is up with all those burning LED Hubs, I have 2 of them in my machine and it's running 24/7 I don't want to come back one day to a burned out apartment! Can Corsair please release a statment about this?
Reply With Quote


  #12  
Old 09-27-2017, 09:01 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 18,607
POST ID # = 921341
Toasted Toasted Reputation: 104
Default

Quote:
Originally Posted by versus4582 View Post
Thank you for your response but as i said in another thread here: http://forum.corsair.com/v3/showthread.php?t=170740

the ''Claim your account'' does not work for some reason. My email is correct , the bar turns green but then i get

''NO MATCHING ACCOUNT WAS FOUND. PLEASE CHECK THE EMAIL AND TRY AGAIN. IF THIS IS AN ERROR PLEASE CONTACT OUR SUPPORT DESK
. PLEASE CONTACT CUSTOMER SERVICE.''

Can someone please advise ??
Did you previously have a secure.force.com support account?
Reply With Quote


  #13  
Old 09-27-2017, 09:14 AM
versus4582 versus4582 is offline
Registered User
versus4582's PC Specs
 
Join Date: Sep 2017
Posts: 4
POST ID # = 921345
versus4582 Reputation: 10
Default

When i try to login here: https://corsair.secure.force.com/ the site is down.

Do i need to go somewhere else ?

Please someone help because i have been trying to get some help for 2 days now with no success...
Reply With Quote


  #14  
Old 09-29-2017, 09:06 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 18,607
POST ID # = 921581
Toasted Toasted Reputation: 104
Default

The new support site is; https://support.corsair.com

If you previously had an account on the corsair.secure.force.com platform, you should be able to claim your account. Otherwise you will may need to register for a new support account instead.
Reply With Quote


Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.