The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 08-19-2015, 03:16 AM
acelfc9 acelfc9 is offline
Registered User
acelfc9's PC Specs
 
Join Date: Aug 2015
Posts: 3
POST ID # = 796783
acelfc9 Reputation: 10
Default VOID wireless no lights/Power up

Hi I just got the VOID wireless yesterday. took it out of the box turned it on, connected the wireless receiver, installed CUE. When I installed CUE it asked to update the firmware so I clicked ok but after 30-40mins it had not moved from 0%. so I aborted it and reset pc but now headset as gone off and there's no lights lighting up and I cant switch it on. Plus dongle light is just flashing. I have left headset plugged in all night for around 12 hours or so and still no power or lights etc. I have checked charge cable and USB port and all working. Please help!!!!!!!
Reply With Quote


  #2  
Old 08-19-2015, 12:46 PM
Corsair Chris Corsair Chris is offline
Corsair Employee
 
Join Date: Mar 2014
Posts: 381
POST ID # = 796837
Corsair Chris Reputation: 10
Default

UPDATE: Please RMA it and we'll take care of it (https://corsair.secure.force.com/).

Last edited by Corsair Chris; 08-19-2015 at 02:44 PM.
Reply With Quote


  #3  
Old 08-19-2015, 01:03 PM
acelfc9 acelfc9 is offline
Registered User
acelfc9's PC Specs
 
Join Date: Aug 2015
Posts: 3
POST ID # = 796839
acelfc9 Reputation: 10
Default

can I just rma this with the store or yourselves?
Reply With Quote


  #4  
Old 08-19-2015, 01:05 PM
Corsair Chris Corsair Chris is offline
Corsair Employee
 
Join Date: Mar 2014
Posts: 381
POST ID # = 796840
Corsair Chris Reputation: 10
Default

We will take care of it. Please fill out a RMA form at https://corsair.secure.force.com/

Last edited by Corsair Chris; 08-19-2015 at 02:40 PM.
Reply With Quote


  #5  
Old 09-06-2015, 01:17 PM
acelfc9 acelfc9 is offline
Registered User
acelfc9's PC Specs
 
Join Date: Aug 2015
Posts: 3
POST ID # = 805332
acelfc9 Reputation: 10
Default Same problem again

Been using my new headset which was a replacement for a bricked Void wireless for a couple of week but now the replacement seems to have bricked today. Its got no power or lights again. Also shows up as unknown device in device manager. I was using it earlier today then plugged it in to charge and now wont work. Any assistance on this matter would be great thank you
Reply With Quote


  #6  
Old 09-08-2015, 04:25 PM
Corsair Chris Corsair Chris is offline
Corsair Employee
 
Join Date: Mar 2014
Posts: 381
POST ID # = 805677
Corsair Chris Reputation: 10
Default

Hey acelfc9, I'm sorry that you're having issues with VOID. Could you create another ticket and private message me your RMA number? I'd like to get this unit back for failure analysis.
Reply With Quote


  #7  
Old 09-09-2015, 03:44 PM
Beef Hammer Beef Hammer is offline
Registered User
Beef Hammer's PC Specs
 
Join Date: Sep 2015
Posts: 3
POST ID # = 805884
Beef Hammer Reputation: 10
Default

Having the opposite problem, my void lights wont turn off, even with the headset powered off and unplugged.
Reply With Quote


  #8  
Old 01-22-2019, 09:43 PM
Dorito_Head_21 Dorito_Head_21 is offline
Registered User
 
Join Date: Jan 2019
Posts: 1
POST ID # = 991045
Dorito_Head_21 Reputation: 10
Default

I bought this headset off a friend and it’s worked really well until the dongle stopped lighting up to connect. I’ve had it for about a year now and need help on how to fix the dongle. It’s a Corsair Pro.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.