The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Power Supplies

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 01-19-2019, 05:12 PM
cyberr_c28z cyberr_c28z is offline
Registered User
cyberr_c28z's PC Specs
 
Join Date: Jan 2019
Posts: 2
POST ID # = 990543
cyberr_c28z Reputation: 10
Default HX750 problems

Well I got some weird things happening to me.
1. When I start the PC, the PSU clicks and shutdowns then same thing happens again and after 2 shutdowns and clicks the PC boots normally.
2. I've been getting random shutdowns during gaming. Both the PC and the monitor are connected to an UPS. The shutdowns occur during gaming and both the PC/Monitor are shut off. I don't understand why..

Can someone help me and explain me why this happens, this isn't my first build...


Specs
i7 8700k

ASUS ROG XI HERO
G.Skilll 3200MHz 16gb
H115i Platinum AIO
1070ti Zotac AMP!
Cougar panzer evo case
3 fans intake in the from
2 AIO fans intake at the top
1 fan exhaust back
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.