The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 01-14-2019, 01:14 PM
Ananomalymoose Ananomalymoose is offline
Registered User
Ananomalymoose's PC Specs
 
Join Date: Jan 2019
Posts: 1
POST ID # = 989844
Ananomalymoose Reputation: 10
Default HS50 mic not working

Hello, I recently bought a HS50 but I have a very strange problem. I am using the y cable and have set both the headphones and mic to default. When I test the mic it is working and recording my voice. But when I get in to a game the mic will not work. Am I doing something wrong or maybe I have missed a step in the setup process? Any help would be much appreciated.
Reply With Quote


  #2  
Old 01-25-2019, 12:03 AM
Zealothia Zealothia is offline
Registered User
Zealothia's PC Specs
 
Join Date: Jan 2019
Posts: 3
POST ID # = 991278
Zealothia Reputation: 10
Unhappy

I am having a similar issue with the same headset.....
Brand new pc, all drivers up to date, headphones work perfectly, but then I plugged the mic in, and it does not work at all.
I tried everything google could offer me and the mic doesn't pick any sound at all.
The most of sound the mic produced was horrible stactic, but that's it.
The only thing I couldn't do is update the mic's driver, because Corsair's own site doesn't have it disponible for download.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.