The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 11-08-2018, 11:32 AM
Epimetheus Epimetheus is offline
Registered User
 
Join Date: Nov 2018
Posts: 3
POST ID # = 979466
Epimetheus Reputation: 10
Exclamation My RGB Dark Core (Not SE)

The mouse randomly failed a firmware update about a week ago and has refused to update since then, it just stays on the step where you toggle all the switches. When plugged in the mouse battery is listed as "not connected" and none of the custom functions work while the box functions work fine and it treats the mouse as though I'd just plugged it in for the first time every time I do so. Whenever I unplug the wireless receiver the mouse disappears completely from the software even when the mouse is plugged in. I even have a firmware image that it is still refusing to update to. Whenever I have the mouse plugged in a yellow triangle (!) sign appears in the home screen on the mouse's picture.
Attached Images
File Type: png Screenshot_2.png (114.6 KB, 129 views)
Reply With Quote


  #2  
Old 11-08-2018, 04:54 PM
Apophis3 Apophis3 is offline
Registered User
Apophis3's PC Specs
 
Join Date: Feb 2018
Posts: 331
POST ID # = 979507
Apophis3 Reputation: 12
Default

Time to utilize that pinhole and do a hard reset.
Reply With Quote


  #3  
Old 11-08-2018, 05:39 PM
Epimetheus Epimetheus is offline
Registered User
 
Join Date: Nov 2018
Posts: 3
POST ID # = 979517
Epimetheus Reputation: 10
Default Hard reset

Quote:
Originally Posted by Apophis3 View Post
Time to utilize that pinhole and do a hard reset.
Hold it how long and what other things do I need to do?
Reply With Quote


  #4  
Old 11-20-2018, 01:28 PM
j_ayf j_ayf is offline
Registered User
j_ayf's PC Specs
 
Join Date: Jul 2018
Posts: 8
POST ID # = 981348
j_ayf Reputation: 10
Default

I've got the same problem after upgrading the firmware to 3.19.

The mouse cannot connect to the software anymore, any macros or rebinds don't work in wired mode. Funny thing is it is perfectly fine in wireless mode.

I did what Apophis3 suggested and did a reset (described >>>here<<<) and that did reset the Hardware profiles but it didn't fix the connection issues. Any help is much appreciated, I don't really want to RMA.
Reply With Quote


  #5  
Old 11-23-2018, 12:40 AM
joshuaknouf joshuaknouf is offline
Registered User
 
Join Date: Nov 2018
Posts: 1
POST ID # = 981661
joshuaknouf Reputation: 10
Default

lol I just bought mine tonight. It's the first time I've owned a corsair product and everything was going good until I did the firmware update. The problem started for me when the firmware update failed due to going inactive and the lights went out in my Dark Core RGB se. I followed all the instructions as directed in the iCUE program. There is one instruction I missed and that is the one that says only do a firmware update if directed to do so by support. I only come across this info while searching for info on what to do about my problem and came across the YouTube videos corsair provided on their website...(nice to find that after installing and setting everything up). I noticed that others have similar issues when performing the same actions. If someone out there has a link and or good direction to point us in that would be greatly appreciated. Oh and as a side note *the website multiple times popped the error code 404 after trying to create an account 8 times* I'm not sure what that is about but will contact support as soon as they open during the next week.

*update on my issues*
I managed to follow the reset option as mentioned above[QUOTE][I've got the same problem after upgrading the firmware to 3.19.

The mouse cannot connect to the software anymore, any macros or rebinds don't work in wired mode. Funny thing is it is perfectly fine in wireless mode.

I did what Apophis3 suggested and did a reset (described >>>here<<<) and that did reset the Hardware profiles but it didn't fix the connection issues. Any help is much appreciated, I don't really want to RMA.
/QUOTE] and now my lights work again but it seems as though I cannot set profiles with just the USB plugged into the mouse. I only have profile options when in wireless mode and the device doesn't register while plugged into the cable either (like it did new right out of the box). So it seems that is where it stands for us at the moment.

*FINAL UPDATE*
So after some messing around with uninstalling the drivers first and then reinstalling them <---(although this may not have had as much of an impact as)---> uninstalling the iCUE software and starting from scratch has allowed me to correct the issue. Once you uninstall the iCUE and reinstall it allows you to go through the update on the firmware and it was successful this time around *note* (go step by step and pay attention to the directions with plugging and unplugging the USB cord and wireless dongle) . I paid attention to any warnings that popped up and followed those as needed. after clearing onboard storage and deleting the "micro SD card looking icons" from my profiles I can create and have access to all profiles I create on USB cable only operation and or USB wireless operation now. Charging icons in the iCUE software read as they should and all seems to be in working order. After going through this process and freaking out just a little things ultimately worked out for a successful and functional much needed upgrade to my system.

Last edited by joshuaknouf; 11-23-2018 at 02:19 AM. Reason: FINAL UPDATE
Reply With Quote


  #6  
Old 11-23-2018, 01:13 PM
j_ayf j_ayf is offline
Registered User
j_ayf's PC Specs
 
Join Date: Jul 2018
Posts: 8
POST ID # = 981710
j_ayf Reputation: 10
Default

Nice, that it worked for you. I actually tried a complete reinstall but the mouse still isn't registered by the software, so I opened a ticket with support.
Reply With Quote


Reply

Tags
firmware broken, rgb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.