The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Power Supplies

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 12-10-2018, 03:55 AM
Mondstaub Mondstaub is offline
Registered User
Mondstaub's PC Specs
 
Join Date: Dec 2018
Posts: 6
POST ID # = 984632
Mondstaub Reputation: 10
Default Corsair RM 650x Bang&Spark when switching on

Hello,

This morning when I wanted to start my PC and wanted to turn on the power supply, a RM 650x, there was a bang and spark in the power supply, right where the cable is plugged. The fuse of the electricity in my flat sprung out too.
The power adapter is 2 years old.
I've removed the power supply and connected it alone and found that the fan is no longer running, but it has not popped, when switching it on. As for the rest of the hardware in the PC, I do not know, because I did not want to take the risk to connect the power again to the PC.
I therefore assumed that the PSU is broken and i have ordered a new one, also a RM 650x.
I don't have an awful lot in my PC, an EVAGA GTX 950, a CPU water cooler, a Corsair, two Samsung SSDs and the MOBO with a Skylake 6500K CPU. In addition, I have two active speakers each have 200W, two monitors and an audio interface, which also does not need much.
Has anyone had the same experience, is that normal with a 2 year old PSU? Is it better to only shut down the PC & keep the PSU constantly on, so it draws not so much current to blow out the fuse?
Reply With Quote


 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.