The Corsair User Forums  

Go Back   The Corsair User Forums > Alternate Language Support >  German Language Support > Tastaturen & Mäuse (Keyboards and Mice)

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 09-23-2017, 07:20 AM
Fe_Lix Fe_Lix is offline
Registered User
Fe_Lix's PC Specs
 
Join Date: Sep 2017
Posts: 2
POST ID # = 920958
Fe_Lix Reputation: 10
Question Corsair K70 LUX RGB Ubuntu Erkennung erst nach neu einstecken

Guten Tag liebes Corsair-Forum,

ich nutze seit einer Weile die oben genannte Tastatur K70 RGB LUX und habe in Windows 10 auch kaum Beanstandungen.
Auch über das Flackern einzelner Tasten bei dynamischen Beleuchtungsszenarien kann ich hinweg sehen.

Da ich aber auch ein Dualboot mit Ubuntu (Mate) 16.04.3 LTS nutze, habe ich dort die Erfahrung gemacht, dass die Tastatur im Bootloader (Grub 2) - ebenso wie im UEFI - zwar wie gewohnt funktioniert.
Sobald aber der Authentifizierungsbildschirm (Passwortabfrage) vom OS kommt, wird die Tastatur fast immer nicht erkannt.
Erst wenn ich die Tastatur heraus ziehe, um sie dann wieder einzustecken, findet sie Ubuntu in den meisten Fällen wieder.

Ich habe ein paar Dinge bereits ohne nachhaltigen Erfolg getestet:
- Die quirks 0x20000000 sowie 0x400 und 0x8:
0x20000000 hat zu Beginn nach komplettem Kaltstart (Rechner für >halbe Minute komplett vom Netz nehmen)
gewirkt. (bei Neustarts nicht)
Die anderen beiden hatten mMn jedoch keine Auswirkung. (Jedenfalls ergab sich an dem Problem dadurch keine Verbesserung)
- Das Gerät per usbreset.c (aus ubuntuusers wiki) rücksetzen
hatte ebenso keine Auswirkung.
- Die Dampfhammer-Methode "rc.local"-script zum deaktivieren und aktiveren des xhci controllers hat (ich glaube) 3 mal funktioniert.
Danach war die Tastatur wieder vollständig deaktiviert und ab und an wurden nach einem Neustart Mausklicks vervielfacht.

Die Tastatur leuchtet zumeist, schaltet sich aber mitunter auch nach ein paar Minuten ab, wenn die Tasten nicht reagieren - sie also nicht erkannt wurde.

Ich nutze auch im OS den ckb-next Treiber in neuester Version und die laut CUE (Windows) neueste Firmware.

Ich habe auch ein Log des Kernels erstellt, weiß aber nicht, wie ich es hier einbinden soll.

Vielen Dank an alle, die sich mir und meinem Problem annehmen wollen.

Grüße Fe_Lix
Reply With Quote
  #2  
Old 10-01-2017, 05:24 PM
Bluebeard's Avatar
Bluebeard Bluebeard is offline
Corsair Mitarbeiter
 
Join Date: Sep 2007
Posts: 8,436
POST ID # = 921824
Bluebeard Reputation: 46
Default

Hi!

Leider kann ich dir nicht direkt weiterhelfen bei den Ubuntu Problemen, da mir schlicht die Erfahrung damit fehlt. Schaue aber bitte nach, ob ein Update für das BIOS deines Mainboards bereitsteht und installiere es. Lade auch einmal die optimierten Standardeinstellungen und versuche zu schauen, ob ein Ein- und Ausschalten des Legacy USB Supports eine Veränderung bringt.

Grüße
Reply With Quote
  #3  
Old 12-22-2017, 06:18 PM
Fe_Lix Fe_Lix is offline
Registered User
Fe_Lix's PC Specs
 
Join Date: Sep 2017
Posts: 2
POST ID # = 931822
Fe_Lix Reputation: 10
Default

Guten Abend,

entschuldigen Sie bitte, dass ich mich so lange nicht gemeldet habe.
Es lag am XHCI-Controller des Mainboards (ASUS Pro Gamer Z97).
Nach anstecken an einen HUB (in dem Fall EHCI sprich USB 2.0) funktionierte die Tastatur auch sofort nach dem Booten.
Nun habe ich sie an einem USB 3.1-Controller und sie wird auch sofort von Linux erkannt.

Wohlgemerkt, in Windows gab es diese Probleme mit Tastatur und Mainboard nicht.

Ich wünsche ein frohes Fest und danke für die Mühe. (:
Reply With Quote
Reply

Tags
k70 rgb lux, keine funktion, linux, nicht erkannt, ubuntu

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.