The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 09-13-2018, 09:27 AM
kasutaja kasutaja is offline
Registered User
 
Join Date: Dec 2007
Posts: 29
POST ID # = 972559
kasutaja Reputation: 10
Default Problem with K63 wireless

Hi,

I have been using Corsair K63 Wireless Mechanical Gaming Keyboard for a while and have ran into some problems.

Sometimes the keyboard looses connection after I unplug the cord (charging). It doesn't restore the connection when I press the keys to repair it with the usb dongle. Only way to restore the connection is to turn off the keyboard, remove the usb dongle. Reinstall usb dongle and switch on the keyboard.

And that's not all. Recently I'm having problems that after a while when using the keyboard it stops working correctly. For example you press the E key and explorer window open instead typing the letter E. All the keys are messed up and won't to what they should to. Even after removing the usb dongle and switching the keyboard on/off it woun't fix the problem. Only restarting the PC helps.

I'm using the latest iCue software and have flashed the keyboard 2 times with the newest FW.

Using Windows 10 x64 Pro. I haven't changed anything on my PC setup so I don't think its the PC fault.


Any ideas or help would be appreciated. It's really good keyboard but these bugs are killing my experience with it :(
Reply With Quote


  #2  
Old 09-13-2018, 01:51 PM
Apophis3 Apophis3 is offline
Registered User
Apophis3's PC Specs
 
Join Date: Feb 2018
Posts: 213
POST ID # = 972600
Apophis3 Reputation: 12
Default

Turn off, hold down Esc and turn back on, this will restore factory settings. I think something in the fw got befuddled.
Reply With Quote


  #3  
Old 09-14-2018, 11:58 AM
kasutaja kasutaja is offline
Registered User
 
Join Date: Dec 2007
Posts: 29
POST ID # = 972723
kasutaja Reputation: 10
Default

I turned the keyboard off, held down esc key and powered it on. It flashed the lights and reconnected with the dongle. And after the next startup from shutdown the keyboard didn't work again. I tried the esc trick, nothing. Removed the usb dongle. And after that it started to work again. So it seems that the reset did nothing and the keyboard works only when it feels like it :(
Reply With Quote


  #4  
Old 09-16-2018, 07:42 AM
Apophis3 Apophis3 is offline
Registered User
Apophis3's PC Specs
 
Join Date: Feb 2018
Posts: 213
POST ID # = 972967
Apophis3 Reputation: 12
Default

Can you test the kb using Bluetooth to see how it works?
Reply With Quote


  #5  
Old 09-18-2018, 04:02 PM
kasutaja kasutaja is offline
Registered User
 
Join Date: Dec 2007
Posts: 29
POST ID # = 973289
kasutaja Reputation: 10
Default

Quote:
Originally Posted by Apophis3 View Post
Can you test the kb using Bluetooth to see how it works?
I don't have a Bluetooth on motherboard to test it for a long time. But when I connect it to my console (ps4) it works fine (through Bluetooth), but I'm not using it with PS4 for longer periods of time so I don't know if it would start acting up like it does sometimes with the PC.
The issue is not that it won't work all the time. The issue is that out of nowhere it doesn't work and does strange things and then it works again like nothing has happened. Right now I have left the keyboard on when the PC is on and only turned it off when the PC is not working. This far it has been working. But its little bit inconvenient because if it works all the time when I'm not using it the battery wont last very long.

I will c how it goes and report back.
Reply With Quote


  #6  
Old 09-26-2018, 06:56 AM
kasutaja kasutaja is offline
Registered User
 
Join Date: Dec 2007
Posts: 29
POST ID # = 974260
kasutaja Reputation: 10
Default

Still having the same issues. Turned on the PC, turned on the keyboard. And nothing. The keyboard didn't work. The white leds lit up that shows if its connected. After unplugging the keyboards usb dongle and re-plugging it the keyboard started to work.

At first when I got this keyboard I didn't have this type of issues. But now it really common that the keyboard doesn't work when I start using my PC or when I switch the keyboard off for a while to save battery life when the PC is on but the keyboard is not needed.
Reply With Quote


  #7  
Old 09-27-2018, 12:35 PM
Apophis3 Apophis3 is offline
Registered User
Apophis3's PC Specs
 
Join Date: Feb 2018
Posts: 213
POST ID # = 974436
Apophis3 Reputation: 12
Default

Power Saving settings could be turning off your USB port(s).
Reply With Quote


  #8  
Old 09-28-2018, 11:19 AM
kasutaja kasutaja is offline
Registered User
 
Join Date: Dec 2007
Posts: 29
POST ID # = 974526
kasutaja Reputation: 10
Default

Quote:
Originally Posted by Apophis3 View Post
Power Saving settings could be turning off your USB port(s).
hm, how? It didn't to it before and I haven't reinstalled anything. And when the keyboard was new it worked fine except it sometimes didn't want to register the "turn off windows key" function.

I'm using front usb ports for the keyboard at the moment (corsair matx case). I could try to blug it in with extension cable to one of the usb ports at the back of the motherboard.

will c if i can find out anything.
Reply With Quote


  #9  
Old 09-29-2018, 10:37 AM
kasutaja kasutaja is offline
Registered User
 
Join Date: Dec 2007
Posts: 29
POST ID # = 974644
kasutaja Reputation: 10
Default

Quote:
Originally Posted by kasutaja View Post
hm, how? It didn't to it before and I haven't reinstalled anything. And when the keyboard was new it worked fine except it sometimes didn't want to register the "turn off windows key" function.

I'm using front usb ports for the keyboard at the moment (corsair matx case). I could try to blug it in with extension cable to one of the usb ports at the back of the motherboard.

will c if i can find out anything.
Today the keyboard started acting up when I powered on the PC. So I don't think that the usb power saving has anything to do with the problem. Besides I didn't have any problems before with the keyboard when I got it. I switched the keyboard off and on all the time while the PC was in sleep mode/powered on. And had 0 issues.

Maybe its the keyboard firmware or windows updates? That's the only thing that has changed since I got the Corsair keyboard.
Reply With Quote


  #10  
Old 09-29-2018, 11:34 AM
Apophis3 Apophis3 is offline
Registered User
Apophis3's PC Specs
 
Join Date: Feb 2018
Posts: 213
POST ID # = 974650
Apophis3 Reputation: 12
Default

A WU update may have turned on a feature, like say Fast Boot. That's notorious for issues like this.
Reply With Quote


  #11  
Old 09-29-2018, 02:51 PM
kasutaja kasutaja is offline
Registered User
 
Join Date: Dec 2007
Posts: 29
POST ID # = 974670
kasutaja Reputation: 10
Default

Quote:
Originally Posted by Apophis3 View Post
A WU update may have turned on a feature, like say Fast Boot. That's notorious for issues like this.
I disabled it and will see if it makes any difference.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.