The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cooling

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 01-13-2019, 04:57 PM
IamBrownCow IamBrownCow is offline
Registered User
IamBrownCow's PC Specs
 
Join Date: Jan 2019
Posts: 2
POST ID # = 989713
IamBrownCow Reputation: 10
Default Corsair H100i Pro RGB SATA power cable melting.

So I bought the Corsair H100i Pro RGB for my system. When I installed it and powered the pc on, it melted the SATA power cable. I returned it and got a replacement, but the same thing happened with the second one. It has to be something I'm doing wrong because I don't think I would get two defective units. I also made sure everything else was plugged in correctly.
Reply With Quote


  #2  
Old 01-13-2019, 07:42 PM
DevBiker's Avatar
DevBiker DevBiker is offline
iCue βeta Team Green
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 6,088
POST ID # = 989741
DevBiker Reputation: 83
Default

That's typically from a short. Usually that's caused by using the wrong cables with the PSU. Are you using only the cables that came with that PSU?
__________________
Please click "Edit System Specs" and fill out your system info.

This comment is provided "as-is", without warranty of any kind, express or implied, including, but not limited to, the sanity or mental fitness of the author. The author is not a Corsair employee, does not represent Corsair, and no comment should be construed as an official statement from Corsair.

Reply With Quote


  #3  
Old 01-13-2019, 07:54 PM
IamBrownCow IamBrownCow is offline
Registered User
IamBrownCow's PC Specs
 
Join Date: Jan 2019
Posts: 2
POST ID # = 989749
IamBrownCow Reputation: 10
Default

Quote:
Originally Posted by DevBiker View Post
That's typically from a short. Usually that's caused by using the wrong cables with the PSU. Are you using only the cables that came with that PSU?
Yes. I am using the SATA connectors that came with my power supply.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.