The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 06-13-2018, 02:54 PM
Phenomenal_Ozzy Phenomenal_Ozzy is offline
Registered User
 
Join Date: Jun 2018
Posts: 1
POST ID # = 958946
Phenomenal_Ozzy Reputation: 10
Exclamation Keyboard on, but not detected?

So I got the k68 and started using it just fine, but after a while it just stopped working. When I restart my PC, it says keyboard not detected, yet my keyboard is connected and the lights are lit. It started to [I]wave flash.[I] I don't know what that means, but can anyone help me with this.
Reply With Quote


  #2  
Old 06-13-2018, 04:54 PM
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 853
POST ID # = 958971
Corsair Nick Reputation: 39
Default

Which OS are you using for your PC? Have you tried plugging into a different USB port stack on the back of the motherboard?

You can try soft resetting the keyboard by unplugging it, hold ESC, plug the keyboard back in, then release the ESC key after 5secs. The keyboard should blink and work normally.
Reply With Quote


  #3  
Old 07-03-2018, 07:20 AM
Norman24 Norman24 is offline
Registered User
Norman24's PC Specs
 
Join Date: Jun 2018
Posts: 4
POST ID # = 961918
Norman24 Reputation: 10
Default

[QUOTE=Phenomenal_Ozzy;958946]So I got the k68 and started using it just fine, but after a while it just stopped working. When I restart my PC, it says keyboard not detected, yet my keyboard is connected and the lights are lit. It started to [I]wave flash.[I] I don't know what that means, but can anyone help me with this.

I'm having the same issue, (K68) yes I tried different USB ports with same outcome..

Last edited by Norman24; 07-03-2018 at 07:31 AM.
Reply With Quote


  #4  
Old 07-03-2018, 07:24 AM
Norman24 Norman24 is offline
Registered User
Norman24's PC Specs
 
Join Date: Jun 2018
Posts: 4
POST ID # = 961920
Norman24 Reputation: 10
Default

Quote:
Originally Posted by Corsair Nick View Post
Which OS are you using for your PC? Have you tried plugging into a different USB port stack on the back of the motherboard?

You can try soft resetting the keyboard by unplugging it, hold ESC, plug the keyboard back in, then release the ESC key after 5secs. The keyboard should blink and work normally.
I tried it but still the same outcome... The keyboard is lit but not registering in the iCUE program, therefore I cannot load my defaults..

Last edited by Norman24; 07-03-2018 at 07:36 AM.
Reply With Quote


  #5  
Old 07-03-2018, 09:06 AM
Norman24 Norman24 is offline
Registered User
Norman24's PC Specs
 
Join Date: Jun 2018
Posts: 4
POST ID # = 961928
Norman24 Reputation: 10
Default

Well, I downloaded the iCUE software again and reinstalled it, all is well again...
Reply With Quote


Reply

Tags
k68, keyboard

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.