The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Bulldog and Lapdog

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 09-11-2018, 11:08 AM
cyberluigi cyberluigi is offline
Registered User
 
Join Date: Sep 2018
Posts: 1
POST ID # = 972284
cyberluigi Reputation: 10
Default Lapdog stopped working

I purchased the Lapdop along with the K70 and the M65 on April 24, 2018. It was my first Corsair purchase!

Yesterday, September 10, 2018, the lapdop stopped working. The keyboard lights up but it does not respond. The mouse does not work at all. I took out the mouse and keyboard off the Lapdog and verified that they both work without the lapdog. Yes, they both work without it.

I'm not sure what went wrong with the lapdog. It was working fine the night before and the next day it did not work. The power supply works, it lights up. But the mouse and keyboard does not work when it's plugged into the Lapdog.

What else can I do? Is there any warranty or something on this? I would hate to have spent money on this thing (my first Corsair purchase) to just be told "There's nothing we can do".

Thanks for any help guys, much appreciated.

Edit: After replacing the USB cable with another USB 3.0 cable, the unit is now working. The cable went bad, that's all.

Last edited by cyberluigi; 09-17-2018 at 12:14 PM.
Reply With Quote


Reply

Tags
lapdog

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.