View Single Post
  #1  
Old 06-26-2017, 08:26 PM
Greybeard's Avatar
Greybeard Greybeard is offline
Corsair Employee
 
Join Date: Feb 2012
Location: Corsair HQ
Posts: 1,305
POST ID # = 909574
Greybeard Reputation: 14
Default AIO Liquid CPU Cooler: Proper way to power your pump

Hello everyone,
If you have an AIO Liquid CPU cooler that uses SATA connector, please ignore this post. But If you have any of these coolers below, this post might help to make sure you have your cooler connected properly.

• H100i V2
• H105
• H90
• H80i V2
• H75
• H55

We are still getting a lot of inquiries regarding our AIO coolers that are using the 3pin connector to power the pump. Many of these questions are pertaining on where to plug them on the mobo. There's a couple of things that we have keep in mind when installing these coolers. For optimal cooling performance, you want to make sure that these pumps are getting constant 12v from the mobo fan header. They are designed to run on 12v and setting them to anything less will degrade their performance overtime. To ensure that you’re feeding the pump 12v at all times, you need to do the following:

1. Connect the 3-Pin pump connector to the 4-Pin fan header marked “CPU_FAN” on the motherboard.
2. Boot the system and enter BIOS.
3. Locate the FAN CONTROL section of the BIOS.
4. Set the “CPU_FAN” to VOLTAGE CONTROL.
5. Set it to 100% to ensure that the pump operates at 12V.
6. Press F10 to save and exit the BIOS.

Last edited by Greybeard; 06-30-2017 at 01:53 PM.