View Single Post
Old 12-08-2018, 08:50 AM
Vladpiko Vladpiko is offline
Registered User
Vladpiko's PC Specs
Join Date: Dec 2018
Posts: 6
POST ID # = 984343
Vladpiko Reputation: 10
Angry LL120 fans went dark...

Hi, this is my first thread i hope some one could help me because after the third day trying to make them work i feel like i want to throw this entire system from the window...

Btw english isnt my native lenguage so ignore the typos..

So i just bought the new corsair obsidian 500d rgb se that comes included with 3 ll120 rgb fans, commander pro and a led 6 way rgb hub.

Bought another 3 ll120 fans and acorsair aio hydro150i.

The cooler work fine, no problems there.

Now to the fans... on first boot all the leds turned on and every thing was fine,except the third port on the rgb hub made my fan flicker and go crazy but not all the time.

I had the corsair link software fully updated and the commander pro was recognized and it let me to "tinker" with the rgb settings, all was fine until i booted the system and the fans went dark..

Corsair link showed the COPO but there wasnt any way to change any option.

I downloaded icue played with every option and still no succsess.

After about 8 hours on the second day i managed to turn the leds 2 time for a couple of minutes until i booted and it all went to hell.. i dont know what i did to make them work but no matter what i try they just wont turn the leds.

Ive read all the issue threads about those fans, made sure i did every thing anyone suggested, still no luck.
Today i connected all the wires to another pc, downloaded link and icue but the leds just wont turn on..

At this point i just gave up becuase 3 days to make some fricking fans work isnt worth it.

The fans are connected to the rgb hub by order.
The rgb hub connected to the copo in channel one, and a a sata cable to the psu.

The copo connected to one sata cable to psu and 1 cable to the usb on mobo.

I checked every port on the hub in order and out of order, tryed channel 1 and 2.
Tryed different cables even went to bios.
Uninstalled and reinstalled link and icue maybe 20 time but still no luck

The first time the leds turn on on the second day was when i ended corsair services in task manager but it doesnt work anymore.

Maybe the hub that came with the case is faulty, but i cant buy another one coz they dont sell those in my country.

If nothing will work i swear i wont buy another corsair product again.. its just sad i spent a decent amount of money and it doesnt even work proprly. Plus i spend almost 3 days trying to fix something that was supposed to be easy and with out all this problems.

Well i think i tryed every thing there is, i hope some one could help my problem somehow.

PS i only got 5 ll120 now coz i probebly disconnected one of tge cables in the led 4 pin connector from all the pulling and llaying around with the fans.

Last edited by Vladpiko; 12-08-2018 at 09:26 AM.
Reply With Quote