The Corsair User Forums

The Corsair User Forums (http://www.asktheramguy.com/forums/index.php)
-   Audio (http://www.asktheramguy.com/forums/forumdisplay.php?f=207)
-   -   Corsair Gaming Headset Software 2.0.37 (http://www.asktheramguy.com/forums/showthread.php?t=132482)

Corsair James 09-22-2014 09:27 PM

Corsair Gaming Headset Software 2.0.37
 
Hi all,

An update to the audio software has been released here: http://softwaredownloads.corsair.com...2.0.37.msi.zip

This is version 2.0.37.

This software as added support for Windows 10 for the H1500, H2100, Vengeance 2000, Vengeance 2100, 1500, 1500v2, as well as HS40.

Nurdle 09-23-2014 09:07 AM

using vengeance 2000 headset. Audio is still too loud and distorts (seems boosted by x2) and 5.1 > 7.1 up-mixing is still broken. Rear channels (more specifically directly behind) are far too quiet.

LCruel 09-23-2014 10:29 AM

Quote:

Originally Posted by Nurdle (Post 729535)
using vengeance 2000 headset. Audio is still too loud and distorts (seems boosted by x2) and 5.1 > 7.1 up-mixing is still broken. Rear channels (more specifically directly behind) are far too quiet.

Can also confirm same case with the Corsair Vengeance 2100

Minax 09-23-2014 11:55 AM

When i look at the downloads tap for the Vengeance 2100 the only change is this :

Added support for H2100 & H1500 headsets

andyvee 09-23-2014 02:53 PM

Quote:

Originally Posted by Minax (Post 729575)
When i look at the downloads tap for the Vengeance 2100 the only change is this :

Added support for H2100 & H1500 headsets

changelog

1. increase number
2. replace " Vengeance " with " Gaming "
3. Add H1500 / 2100 ( exactly the same as old Vxxx - side note made the Hxxx with yellow highlights but couldn't be bothered to change the led to yellow so still blue , just how lazy have they become :(: )

That's all she wrote , tadah :D:

vexed 09-23-2014 06:22 PM

Wait.... so theres now a H2100 or is it just the same as a the V2100 and now comes in yellow with a new branding on :confused: I cant keep up with these products. Most issues from v2000 days are still not fixed in terms of the driver for win 8.1 - loudness etc. I do worry for win9 release how that will be supported if at all :sigh!:

CBoismenu 09-23-2014 07:07 PM

To bad they didn't do something about the Mute issue (flashing blue/red):sigh!:

escannihilator 09-24-2014 12:16 AM

new software works great for me, thanks corsair....

nimdo 09-24-2014 03:33 AM

Introducing a rebranded headset without fixing the it, wow.
and this new logo in my opinion is horrible...

this time the sound is so loud i hear sound in 0% and the driver is the same.

Witblitz 09-28-2014 08:54 PM

I never had a day's problem with my Corsair Vengeance 1500. Apart from the blinking mute lights which came into play after 1.1. I suspect it will never get "Fixed".

TheErectedDonke 09-30-2014 09:19 AM

Still hasn't fixed my issue with the Corsair Vengeance 1500 v2. Mic displays no sound at all apart from static or whenever i touch the headset itself which causes a thud sound. Ever since i installed the corsair drivers it seems to have stopped the mic from working. However when i had the windows default drivers it was working perfectly. I tried uninstalling the drivers but whenever i plug my headset back in, it would install the latest drivers for my headset. Really wish corsair would fix this issue.

ramzanox 09-30-2014 12:25 PM

i have vengeance 1500
Sound is still too low, have to keep on minimum that the button on the cable goes (2/100).
So its like a on off button, no sound there between to adjust.

And like others said, realy **** logo, probably the only thing updated in the driver

FALE 10-02-2014 12:12 AM

Are these drivers worth installing vs the Razer drivers I'm currently using?

wachon1992 10-03-2014 01:12 PM

Quote:

Originally Posted by FALE (Post 732095)
Are these drivers worth installing vs the Razer drivers I'm currently using?

wich drivers are you using, just curious. i downloaded razer synapse but it wont detect my vengeance 2100

Celtus 10-10-2014 02:42 PM

When changing volume headset either goes mute or software and game freezes, Anyone else have this issue?


All times are GMT -4. The time now is 01:08 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.