The Corsair User Forums

The Corsair User Forums (http://www.asktheramguy.com/forums/index.php)
-   SSD Firmware Update (http://www.asktheramguy.com/forums/forumdisplay.php?f=206)
-   -   Two SSDs - different firmware update versions? (http://www.asktheramguy.com/forums/showthread.php?t=124850)

Naki 12-22-2013 11:42 AM

Two SSDs - different firmware update versions?
 
I have two Corsair Force GS 360 GB drives.
I had just one at first, then bought a second.
The 2nd one appears to be the same model, but is thinner. And I tried to update its firmware (and the firmware of the old SSD), but I have a problem, however - now my old drive shows the firmware as 5.07, and new one - 5.05a and there does not appear a way to update to 5.07.
EDIT: When I try to update the old drive via Corsair Toolbox, it says its firmware 5.07 is latest (Current: 5.07/Latest 5.07), and when I try updating the NEW drive, it says an update is available, but trying to update says the update failed.

Has 5.07 firmware been recalled/pulled from your web site?
Will using 5.07 firmware cause issues? Why is there no longer a 5.07 update on your forums/web site, and 5.05a appears as latest?

Using Windows 7, 64-bit Ultimate, SP1. Rest of specs - see my specs.

Toasted 12-23-2013 02:52 AM

FW5.07 was never released on the forums.
No, you shouldn't experience any issues with 5.07.

What's the new FW for the new drive?
If its, 5.20, i'd suggest you avoid updating it for now.

Naki 12-23-2013 09:17 AM

4 Attachment(s)
Quote:

Originally Posted by Toasted (Post 688836)
FW5.07 was never released on the forums.
No, you shouldn't experience any issues with 5.07.

What's the new FW for the new drive?
If its, 5.20, i'd suggest you avoid updating it for now.

New firmware shows as 5.07. EDIT: Edited to include some screenshots.

Toasted 12-24-2013 01:01 AM

Have you tried uninstalling the Intel RST drivers and let Windows isntall the MSAHCI drivers to update the firmware?
Is the SSD plugged into an Intel SATA port? If not, plug it into one.

Naki 12-24-2013 05:34 AM

Quote:

Originally Posted by Toasted (Post 689033)
Have you tried uninstalling the Intel RST drivers and let Windows isntall the MSAHCI drivers to update the firmware?
Is the SSD plugged into an Intel SATA port? If not, plug it into one.

1) Drive 1 updated just fine with these same drivers. I have not tried uninstalling them, will try now.

2) Yes, Intel SATA3 port.

Naki 04-13-2014 07:00 AM

Sorry for the very slow update.
Some days (a week?) after trying to update to 5.07 firmware, the firmware version magically became correct, i.e. showing as 5.07.

kabamaru2372 07-29-2015 03:16 AM

Hi all,
i didnt want to start a new thread since this one exists so...
I have the same problem with two force GS 128gb ssd's...
One of them has 5.41 but the other one has 5.24 and ssd tool says it is the latest firmware....
Any ideas? Which is the latest firmware for these disks?
I have them in raid 0 mode and only in ATTO bench i get speeds of 1gb/s in read-write.
In all the other benchmarks like AS SSD, Crystal and many others i get 800mb/s read but only 400mb/s write....
Thank you in advance

Technobeard 07-29-2015 04:11 AM

Quote:

Originally Posted by kabamaru2372 (Post 792173)
Hi all,
i didnt want to start a new thread since this one exists so...
I have the same problem with two force GS 128gb ssd's...
One of them has 5.41 but the other one has 5.24 and ssd tool says it is the latest firmware....
Any ideas? Which is the latest firmware for these disks?
I have them in raid 0 mode and only in ATTO bench i get speeds of 1gb/s in read-write.
In all the other benchmarks like AS SSD, Crystal and many others i get 800mb/s read but only 400mb/s write....
Thank you in advance

Most firmware updates are just for BOM compatibility. Run the SSD toolbox, if it says what you have is the latest for your drive, then that's it. In regards to ATTO vs AS SSD vs Crystal, they all test in different ways. The results from one can't be compared to another.

kabamaru2372 07-29-2015 04:45 AM

1 Attachment(s)
Quote:

Originally Posted by Technobeard (Post 792175)
Most firmware updates are just for BOM compatibility. Run the SSD toolbox, if it says what you have is the latest for your drive, then that's it. In regards to ATTO vs AS SSD vs Crystal, they all test in different ways. The results from one can't be compared to another.

Thank you for the prompt reply!
Its not just the benchmarks, when i copy a file from these disks to themselves the speed doesnt go higher than 280mb/sec....
Also to be more specific, one of the two disks was not able to go from firmware version 5.20 to 5.24 until i did a secure erase...
P.S. please forgive me for my (sometimes bad) English, i am Greek :)


All times are GMT -4. The time now is 12:42 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.