The Corsair User Forums

The Corsair User Forums (http://www.asktheramguy.com/forums/index.php)
-   Corsair Link (http://www.asktheramguy.com/forums/forumdisplay.php?f=209)
-   -   Need help - H150i not detected (http://www.asktheramguy.com/forums/showthread.php?t=175650)

B0D0 03-10-2018 09:18 PM

Need help - H150i not detected
 
Hi - had major system changes. New mainboard (Z370) new CPU (8700K), new RAM (G.Skilll DDR4 whatever), new AIO (Corsair H150i pro). The latter not being detected by LINK4. Have system running @ 0.8 GHz (just imagine!) to keep uncooled system from frying. Found hint here in forum about USBxp driver, can't find that in Device manager or online for download and install. What the heck can I do?

Zotty 03-11-2018 04:11 AM

check the sata connection bud.... is the pump lighting up? it should do regardless of link connection

B0D0 03-11-2018 07:09 AM

SATA power is OK, pump lights up. Tried every possible USB connection: On all three USB3 headers on board (no USB2 header), or connected to Commander, or even by micro USB cable plugged into rear USB2 header. Pump does not appear to be running, lowest temp @ 0.8 GHz (!) is around 65 C. Worst of all: I have a second 150i that I planned to install in another system, took that and tried it out on the Z370 and it shows the same problem. However all USB headers work, SATA power is available. BIOS is set to Fastboot=OFF, Secureboot=OFF, USB-Legacy=ON. Mainboard is ASRock Z370 Taichi in case this matters. Any idea, anyone?

B0D0 03-11-2018 10:22 AM

What about that Corsair USBXp Driver that is supposed to be visible in Device Manager? I definitely don't have that driver. I suppose it is being supplied through installation of LINK4, but that I did at least 10 times. Is there any other way to obtain and install this driver, or is it no longer compatible with the new line of Corsair AIO and therefore not provided in my install?

DevBiker 03-11-2018 10:44 AM

Are the fans spinning? When you plug the the fan connection into CPU Fan, it should show pump speed. What is the CPU Fan Speed?

The driver (and USB connection) isn't required for proper operation of the pump. It's only required for control. Even without the USB connection (at all), you shouldn't be thermal throttling to 0.8 Ghz - which is what appears to be happening.

Also, did you check the mount?

B0D0 03-11-2018 11:59 AM

"Thermal throttling" is hand made. As there is obviously no cooling, temps quickly rise and during the setup I did not want temps to linger near 100 C. BIOS shows CPU_FAN N/A, so there is no connection. Tried CPU_FAN as "Standard" and "Full Speed". Also tried CPU_OPT at PWM Full Speed, PWM Standard, DC Full Speed, DC Standard. Nothing helped. All my fans are (for now) connected to chassis headers (and spin). Question: The pump is supposed to be spinning already when I am in BIOS, right? And it does not need any initial setup in Windows, right? The (well not so) funny thing is, that I have two H150i here at hand, and none of them works. Just checked out, whether fans would be spinning when directly connected to the pump: a 3pin Corsair does, the 4pin Corsairs from the h150i box don't, my Noctua NF-F12 prof. don't.

DevBiker 03-11-2018 02:00 PM

I do find it odd that 2 H150's in a row are DOA. That would make me lean more towards an issue with the system, rather than with the H150s ... simply because that's really defying the odds.

Changing the BIOS settings, for the Pro series coolers, won't have an impact. They don't get any power from the fan header; instead, they only supply a fan tachometer signal so that you don't get a CPU Fan warning at boot time. It also provides a second measure of the pump speed - the fan speed indicated will be the same as the pump speed.

The pump does not need any initial setup in Windows; it does have default settings stored in the flash for the pump controller that will be sufficient for the vast majority of installations (even if not ideal or optimized ... sufficient).

The fan situation is quite interesting as well. A 3 pin, DC-controlled fan spins (which means it's getting at least 7V from the fan header) but two different 4-pin, PWM-controlled fans do not. This would indicate that they are either not getting any power, not getting enough power or are getting 0 for a PWM signal. My guess (without testing with a multi-meter) would be that it's getting the 12V (indicating that your power is good) and sending 0 for the PWM signal. However, it's also possible that your 5V and ground power line are crossed, which would wind up supplying 7V on the 12V rail.

But, again, the odds of this happening with two coolers are pretty slim. I would, very honestly, lean towards looking at the power leads to ensure that it's getting the full 12V where it's supposed to be getting the full 12V. I've, personally, found it impossible to directly test the SATA power leads with a multi-meter BUT ... using a SATA-to-Molex adapter does allow you to easily test the 5V and the 12V rails. As the cooler only uses the 12V rail, this would be sufficient to validate that it's getting the correct power. There's also a nifty unit from Thermaltake that will test all of the power delivery rails for an ATX PSU (DR Power II).

B0D0 03-11-2018 02:24 PM

That's interesting, DevBiker! You say you would test using a SATA-to-Molex. That means the PSU would be the culprit? That's a Corsair HX1000i, working all fine, cannot image that.. I think I still have some Molex/SATA around, just have to find them and then check with the multi-meter. What concerns the 3pin fan that was spinning: That was by far not at full power, could well have been 7V like you mentioned. Thank you very much.

DevBiker 03-11-2018 02:41 PM

You could also check the power on the fan connectors with a multi-meter; it'd be easier than a SATA connector. Pin 1 is +12V, pin 2 is ground. (Pin 3 is tach, Pin 4 is PWM ... to complete the list.) As it's a PWM controller, is should provide +12V at all times.

Regardless, I'd still test the connector.

If you are getting +7V, rather than +12V, I'd lean towards the cable rather than the PSU. As I mentioned, crossing the one of the ground with the +5V rail will give you +7V on the +12V rail. There's plenty of stuff on the web that shows how to do this as a means of slowing down fans.

B0D0 03-11-2018 03:46 PM

Thanks DevBiker, very useful hints! I'll check that out tomorrow. Also I'll see if I have yet another Corsair Type 3 peripherals cable to eventually replace the actual one.

B0D0 03-11-2018 04:36 PM

I CANNOT BELIEVE THIS ... it was the PSU cable! In years and years I have never ever had anything like this! You sure made my day, DevBiker! Thanks a ton!

DevBiker 03-11-2018 04:53 PM

W00t! Glad we were able to get you sorted!!

https://i.pinimg.com/736x/f0/90/91/f...0fc3ad35fe.jpg

Zotty 03-11-2018 05:44 PM

Quote:

Originally Posted by Zotty (Post 944251)
check the sata connection bud.

Quote:

Originally Posted by B0D0 (Post 944262)
SATA power is OK,

Quote:

Originally Posted by DevBiker (Post 944308)
lean towards looking at the power leads

Quote:

Originally Posted by B0D0 (Post 944340)
I CANNOT BELIEVE THIS ... it was the PSU cable!!

Feeling smug lol. Glad your sorted OP :)

B0D0 03-13-2018 05:15 PM

Yeah, you're right, you pointed to the right direction. But while you said "check the sata connection bud.... is the pump lighting up?" (and it was lighting up!) I did not stress on that first. Actually the pump did get power, but not to the extent it needed. I saw that later when it lit up so much brighter. So, anyway - kudos to you too!

Zotty 03-13-2018 05:30 PM

Quote:

Originally Posted by B0D0 (Post 944706)
Yeah, you're right, you pointed to the right direction. But while you said "check the sata connection bud.... is the pump lighting up?" (and it was lighting up!) I did not stress on that first. Actually the pump did get power, but not to the extent it needed. I saw that later when it lit up so much brighter. So, anyway - kudos to you too!


LOL... Smug doesn't always mean right ;)..

Love a happy ending me :)


All times are GMT -4. The time now is 03:27 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.