The Corsair User Forums

The Corsair User Forums (http://www.asktheramguy.com/forums/index.php)
-   SSD Firmware Update (http://www.asktheramguy.com/forums/forumdisplay.php?f=206)
-   -   Firmware Update Won't Work (http://www.asktheramguy.com/forums/showthread.php?t=124552)

uffbros 12-11-2013 11:49 PM

Firmware Update Won't Work
 
I have a Corsair 120GB Neutron GTX SSD running Windows 8.1 Pro. I downloaded and installed Corsair SSD Toolbox and it says I have firmware version M310 and that there is an firmware update. I click the firmware update button and it says downloading and then 20 seconds later says update failed. I disabled my antivirus and anti spyware programs and it still fails. Any ideas why? Thanks.

Yellowbeard 12-12-2013 02:32 AM

Fully power your system off and leave it off for 30- seconds and reboot. Check your firmware again. Also, check any SSD product page for the download and make sure you have the latest version of the toolbox, 1.1.0

uffbros 12-12-2013 04:34 PM

I have the latest version and turned off machine over night and still says the same thing. I have my BIOS set to UEIF and secure boot. Would this matter?

uffbros 12-12-2013 05:08 PM

Update..I went into bios and disabled secure boot and I still get the same message that it fails. The bios also says legacy disabled could that be it? Thanks.

uffbros 12-12-2013 05:14 PM

Update 2..I just did the bios with out secure boot and with legacy enabled and disabled. It still won't install. Anyone?????

HP 3500 Desktop with Intel I-5.

snfo 12-12-2013 06:11 PM

try to change the intel SATA drivers with the windows standard SATA drivers

uffbros 12-12-2013 06:40 PM

How do you do that

snfo 12-12-2013 07:33 PM

Search for Device Manager and click on it
then a window will show, look for IDE ATA/ATAPI controllers and expand it by clicking on it
Now you will have something like Intel(R) ......... SATA AHCI controler
RIGHT CLICK on it
Choose Update driver software
Chose Browse my computer for driver software
Chose Let me pick from a list .....
And now you will see something like Standard AHCI 1.0 Serial ATA controller.
Select this one and then click Next

uffbros 12-12-2013 07:51 PM

snfo...That worked..I appreciate all your help. Take care.

snfo 12-12-2013 08:09 PM

Glad to ear
Don't forget to return to the intel drivers

uffbros 12-12-2013 11:38 PM

Yep..Did that right away. Thanks.

uffbros 05-22-2016 11:49 AM

Ok..Here I am 3 years later and just downloaded the newest toolbox. It says has a firmware update of version 311.....I already have that version.....this happened 3 years ago as well. I have it do the update for the hell of it and says successful. I turn off machine and then back on 2 min later and it's still 311. Yes I changed to the standard adapter in device manager first. Any ideas?

Toasted 05-23-2016 06:36 AM

If the SSD is working fine, you don't really need to update the firmware.

Have you tried updating the SSD on another computer with AHCI enabled?

You can also contact technical support for further assistance.
https://corsair.secure.force.com/

feline1 06-29-2016 08:11 AM

I downloaded the latest SSD Toolbox today (v1.2.3.9) as it still doesn't work.

This software is hopeless


All times are GMT -4. The time now is 09:25 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.