The Corsair User Forums

The Corsair User Forums (http://www.asktheramguy.com/forums/index.php)
-   iCUE Software (http://www.asktheramguy.com/forums/forumdisplay.php?f=280)
-   -   iCUE prevents system sleep/standby (http://www.asktheramguy.com/forums/showthread.php?t=180692)

ritalin 08-27-2018 01:24 PM

iCUE prevents system sleep/standby
 
I recently purchased the LL120 3 pack with the Link Node Pro.
After installing the iQue software I noticed my PC was no longer starting the screensaver, turning off the monitors or going to sleep.

If I stop the software and service, the above problems are still present.
If I prevent the software/service from starting on boot, the problem is rectified, but the fans go back to demo mode.
If I uninstall the software, obviously the issue is resolved, but fans run in demo mode.

I have tried searching this issue on Google and found one other user with the same problem, but a reinstall of iCue seems to have resolved his problem.
I attempted the same on my system but had no luck. As soon as the software is installed again the problem returns.

Ive run "powercfg -requests" and it returns nothing preventing sleep, though this seems pretty common for issues such as this in Win10. Quite a few bits of software seem to keep the system awake and are not reported with this command. Im looking at you ADOBE.

Running:
iQue - v3.6.109
Node Pro - v0.05.104
Win10 - v1803

Inheritance 08-27-2018 10:18 PM

Could you export your iCUE logs and upload them. That way they can take a closer look at the issue. There were reports of this happening before but from what I know it was said to be fixed. But clearly there are still some bugs.

ritalin 08-27-2018 10:45 PM

1 Attachment(s)
Quote:

Originally Posted by Inheritance (Post 970511)
Could you export your iCUE logs and upload them. That way they can take a closer look at the issue. There were reports of this happening before but from what I know it was said to be fixed. But clearly there are still some bugs.

Oh, look at that.
Totally overlooked the logs button.
Sorry would have provided them, to begin with, had I seen it.

Inheritance 08-28-2018 04:12 PM

Thanks.. :D

ritalin 08-30-2018 11:54 AM

An update to this issue for the iCue team.

I have suspected that the Sleep issue here revolves around the fact that the Node Pro connects as a USB device directly to a USB header.
Win10 seems to have a ton of these issues with different USB devices.

If the device is booted up with the Node Pro attached and iCue blocked at startup. The sleep issue is NOT present.

If the device is booted with the Node Pro disconnected at the USB header and allow iCue to launch it will only interact with my Corsair Vengeance RBG DIMMs.
The sleep issue is not present.


This issue seems to be related to how iCue interacts with the node pro as a USB device. It is NOT the software itself causing the problem.

I noticed that on boot before the iCue software starts, there are no issues with Sleep/Idle.
When the iCue software starts I get a Win10 notification chime that new hardware has connected (USB). Since Win10 has a good deal of issues revolving around USB and Sleep/Idle, I suspected this might be the root cause. Disconnecting the USB device (node pro) and running iCue without issues seems to confirm that.

Im hoping to get an answer to this soon as my only choices as of right now are to run the fans in demo mode without the software present or reboot my PC every time I step away from it for more than a few minutes.

ritalin 09-04-2018 01:30 AM

Is no one else having this issue?

fourrr 09-07-2018 11:30 PM

I am having the same issue. With iCue and Corsair Link 4.

Using the Light Loop Fans with commander.

meeekael 09-08-2018 08:04 AM

1 Attachment(s)
Hello, same issue here. Using iCue, Lighting Node PRO, 3x ML120's and a 115i PRO RGB.

Using usbdeview to track down and disable the Lighting Node PRO USB device allows the PC to sleep. Resets the lighting to demo rainbow though.

Have tried using powercfg -requestsoverride but that thing is finiky at the best of time and it won't have a bar of it. Seeing the Lighting Node Pro uses the default windows HID drivers, I can't just add the HIDdriver to the override because my computer would sleep, forever. Ha ha.

I'm out of ideas short of finding a program which force-sleeps after a set time.

Attached are my logs, two files of each. There is 2 or so minutes of inactivity there where it should sleep. Second one (labeled) I let iCue continue logging after disabling the Lighting Node Pro. . There's a weird repeating error with the 115i, which doesn't appear to be affecting operation (or sleep) at all.

fourrr 09-08-2018 01:11 PM

I reinstalled windows. Installed icue second (after chrome) and its working so far. Here's hoping it stays.

fourrr 09-08-2018 03:56 PM

Update : As I began reinstalling my generic apps, Sleep/Screensaver/Monitor Off stopped working.

So I began exiting my new apps one by one and success! Logitech Gaming Software (controls my kb and mouse LEDs) seems to be a problem.

I'll keep working at it.

meeekael 09-08-2018 07:03 PM

Ah lucky you, sounds like a different issue to us.

We aren't using the commander, and it's directly tied to iCUE being on (or off) / Lighting Node Pro being connected(or not).

In my opinion its an issue with how windows is "seeing" the Node Pro default HID drivers. The 115i doesn't use the default drivers, so the computer can sleep.

fourrr 09-08-2018 10:33 PM

I take it back. After a reboot. Exiting LGS no longer fixes it. Back to start. The only way I can get it to sleep is by exiting icue.

meeekael 09-27-2018 11:55 PM

Still happening for me. Sleep works perfectly when I disable Lighting Node Pro with USBDEVIEW. Have modified XHCI USB handling, fastboot, the works, no difference.

It's obviously your product Corsair, any help would be greatly appreciated.

fourrr 12-08-2018 05:51 PM

I no longer seem to have the problem. Uninstalling Steel Series Engine fixed the problem. Must uninstall as exiting the application did not resolve the issue.

Also, I mispoke when I said that I had the commander. I have the LNP.

Good Luck.

chad.j 12-09-2018 06:18 PM

I have the same issue. When iCUE is running, sleep doesn't work. Once I turn off iCUE, sleep works as expected.

I've ended up leaving iCUE off permanently and setting the lighting presets that I use as the on-board profiles for my K95.

Running Windows 10


All times are GMT -4. The time now is 01:52 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.