The Corsair User Forums

The Corsair User Forums (
-   Bulldog and Lapdog (
-   -   Msi bios? (

wolfyboy359 06-29-2017 03:47 PM

Msi bios?
Can I use the BIOS from the MSI website on my bulldog 2.0?

Corsair Alan 07-06-2017 12:58 PM

Hi Wolfboy359,

No sadly, as the bios is specific to Bulldog 2.0 as it comes with a custom fan curve designed for the cooler.

wolfyboy359 07-07-2017 05:18 PM

Do you know where I can find a changelog for the 1Q9 bios for the Bulldog 2.0?

Corsair Dustin 07-19-2017 06:00 PM

There isn't a changelog; the 1Q9 BIOS is the only BIOS for Bulldog 2.0. It's the initial release.

wolfyboy359 07-21-2017 12:25 PM

My bios in my bulldog 2.0 says it is the 1Q4 version. Specifically it lists it as EZA66Iz1.1Q4. It is from 11/10/2016.

wolfyboy359 07-30-2017 12:20 PM

So I am trying to update to the latest bios using the flash utility in the bios itself. I have downloaded the latest bios (1Q9) and put it on a flash drive. I entered the bios and started the flash utility. No matter what I do it does not see the bios on the flash drive. I have tried many different ways of putting the bios on the drive. I just copied the bios over to the flash drive and tried putting it in the root directory and copying the whole folder I downloaded over. No luck. I also tried running the program in the folder I downloaded containing the bios. It exits with some error to fast for me to read. Any suggestions?

wolfyboy359 08-01-2017 12:27 PM

Quick update: I tried the MSI bios update utility in windows, I believe it was called LiveUpdate6. It said my bios was up to date and didn't need updating. I am confused by this since my bios and the "new" one on the MSI website have different names and dates.....

SilverJS 03-28-2018 03:28 PM

Bit of a necro here - is the fan curve the only difference? Would the MSI BIOS otherwise be functional in the Bulldog mobo, or will I brick the Bulldog if I try to flash the MSI BIOS?

(A better question may be : will the Bulldog board even let me flash the MSI BIOS?)

wolfyboy359 06-01-2018 10:20 AM

And where is the updated bios for the motherboard? I see they locked the other thread. Why?

wolfyboy359 07-23-2018 02:57 PM

Is there a trick to updating to the new bios? I loaded it onto a usb stick and rebooted into the bios, then went to mflash mode. It sees the usb stick but not the file? It is formated in fat32. What am I doing wrong? Is there a special usb port one has to use?

wolfyboy359 07-26-2018 10:45 AM

Anyone got any ideas?

Corsair StormShadow 07-28-2018 10:02 PM

Where did you get the bios file from? Are you sure it’s the right one? Make sure you put the file in the root directory of the drive.

wolfyboy359 07-29-2018 11:07 AM


Originally Posted by Corsair StormShadow (Post 966009)
Where did you get the bios file from? Are you sure itís the right one? Make sure you put the file in the root directory of the drive.

I managed to get it updated, thanks.

riccatizhg 11-26-2018 12:41 AM

how did you manage to update the bios, I have the same issue right now

riccatizhg 11-26-2018 12:42 AM

the latest version I can get is E7A66IZ1.1QA and it is from the first sticky post. Corsair, any thoughts?

All times are GMT -4. The time now is 12:16 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.